or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › Stuttering HD Playback on Gigabit Network
New Posts  All Forums:Forum Nav:

Stuttering HD Playback on Gigabit Network

post #1 of 12
Thread Starter 
Let me start with my setup:

Network:
Belkin G Wireless Router
Netgear Unmanaged Gigabit Switch

HTPC:
AMD Phenom II 955
4GB DDR3
160 SATA HD
ATI Radeon HD 4200 (OC'd to 680MHz with 1GB Memory)
Gigabit NIC
Windows Media Center
Shark007 Win7 Codec 32/64-bit with Shark007 suggested settings
Connected to Netgear switch

Media-Server:
AMD Phenom X3 8450
8GB DDR2
Severa HDDs housing media files (HD, SD, TV Videos, etc.)
Gigabit NIC
Connected to Netgear switch

Video:
1080p, DTS, MKV

Okay. When I playback high definition movies on the HTPC (streaming from the Media-Server) I get stuttering. I have attempted to troubleshoot this and I've narrowed it down my network configuration. However, I'm stuck.

If I change the network settings (Speed & Duplex) on both PCs to 1Gigabit Full, it works for a day, maybe two. Then I have to change it back to Auto Negotiate to make it work again.

Copying files from one PC to the other does not have any issues. It's only when I playback movies. I have tried VLC, Total Media Theatre, Windows Media Center, Media Player, and Media Player Classic. They all have the same issue.

If I copy the video file to HTPC hard drive, it plays like a dream.

I cannot figure this out. Any help would be greatly appreciated.
post #2 of 12
http://www.speedguide.net/articles/w...08-tweaks-2574

I have a Netgear GSM7324. I can copy large 10g+ files at sustained 100MB/s but even 720p movies stutter; until I turned off "netDMA". The NIC on my htpc was not completely compatible with all the windows 7 features. Here are my settings for both the htpc and storage server (win2008r2):

C:\\>netsh int tcp show global
Querying active state...

TCP Global Parameters
----------------------------------------------
Receive-Side Scaling State : disabled
Chimney Offload State : disabled
NetDMA State : disabled
Direct Cache Acess (DCA) : disabled
Receive Window Auto-Tuning Level : disabled
Add-On Congestion Control Provider : ctcp
ECN Capability : disabled
RFC 1323 Timestamps : disabled
post #3 of 12
set an exception in your antivirus software to NOT monitor networked sources.
post #4 of 12
Actually bdiddy73, you might want to try NetDMA again, just make sure that you have ChimneyOffload turned off (and your chipset supports I/OAT). If neither one of you supports I/OAT, then I would enable ChimneyOffload. Otherwise, I would use NetDMA (just make sure that ChimneyOffLoad is turned off). This will save you a lot of CPU cycles, if you can use it without stuttering.
post #5 of 12
Thread Starter 
I applied the following to both PCs.

biddy73 - I checked my netsh params and made some changes (add-on congestion control provider - ctcp made a big difference for my internet pages displaying - thank you) but none of the other settings made a difference with playback.

shark007 - I tried to turn that off in Micorsoft Security Essentials. The only thing I could find remotely close was "Enable Network Inspection System". I unchecked the box and I still had stuttering. I went as far as to turn off real time monitoring on both PCs. Still stuttered.

Thank you both for the suggestions.

BTW, the NICs are both onboard:
HTPC - Realtek PCIe GBE Family RTL8168D
Media-Server - Realtek PCIe GBE Family RTL8168C

And not sure how I forgot this, both PCs are Windows 7 Ultimate 64-bit.
post #6 of 12
Quote:
Originally Posted by doublej0 View Post

When I playback high definition movies on the HTPC (streaming from the Media-Server) I get stuttering.

doublej0,

Have you already seen this post about Network Throttling causing stuttering? If not, read from the linked post to the end of the thread. Just a shot in the dark.
post #7 of 12
Thread Starter 
tehowell - So I read that post. Thank you. Made the modifications and I think I have a solved issue!!! Seems the CPUs were trying to send data too fast. *shrugs* At any rate, it seems to have worked!!!! Will give it a couple days and post back my results.

Thank you again everybody.
post #8 of 12
The real problem lies within Realtek and non-managed network hardware. I would not disable NetworkThrottlingIndex...at most I would change the parameters. Now if you use the MS drivers for that NIC, you would see that you do not need to disable that parameter and stock settings would work fine. I stopped using Realtek drivers a while ago after analyzing the traffic across my Cisco.
Also, with cheap switches and routers you would also see a difference in network speed (and resources) by moving to a managed switch.
I hate to see people using 10% of their CPU cycles to stream a file across their network. By the time you add that and other resources, all of sudden you are maxing out your CPU. No need to do that, if you can help it...just a thought...
post #9 of 12
Thread Starter 
So I backed off network throttling from 10 to 50 and it seems to have solved the issue. No hiccups since.

-AlterEcho... I will look into getting a managed network switch. The one I have is unmanaged Netgear ProSafe 8-port. Came free with Uverse. I am using the realtek drivers but that's what Windows 7 auto-updated to. HOwever, I will see about changing the drivers.

Thank you everybody for the suggestions!
post #10 of 12
I have been fighting this same battle as well.

At first it was the demigrator.exe service on my WHS that was the major cause of the hiccups/stutters. After turning that off during watching hours it improved but not completely.

I also tried numerous network and NIC setting changes, replaced cabling, isolated the WHS and HTPC to their own switch, etc... The issue would disappear for a couple of movies and then reappear.

Finally two things resolved it for me. The first was I replaced my main switch with a Netgear GS116 which has 512k of que buffer memory per port. After reading many sites and articles I stumbled on a recommendation from the Windows Media Center Group or Alliance which recommended at minimum
192k of memory per switch port for streaming media especially HD content. The Netgear was the only desktop (non-managed) switch I could find that had this feature and above what was recommended. When I replaced my Linksys Gigabit switch with the Netgear Gigabit switch the stutters/hiccups went from several repetitious stutters/delays to just slight blips every now and then. Some were just audio dropouts or looked like layer changes in the disc like on a two layer DVD. Much, much better than before but not perfect. Oh and my network throughput went from 150-170Mbps to 220-250Mbps when I measured Windows Home server to HTPC with JPERF.
The second change that resolved it completely was to replace the Realtek NICs in the server and the HTPC with Intel Pro PCIe Gigabit NICs. The onboard Realteks on the server and HTPC were both Gigabit and running the latest drivers. I tried all the tweaks of the driver settings and nothing worked. Finally for $30 each I installed new Intel NICs and ran 6 Blu Ray movies (ISO's / VCD mounted / TMT3 Platinum / MyMovies on WMC Win7 Home) from my WHS and not one stutter/hiccup/dropout all weekend. I tested network throughput with this change and the HTPC went from 220-250Mbps after the switch change to 320-350Mbps with the NIC change.
I even ran some stress tests on the network by streaming other Blu Ray movies to two other desktops and another HTPC in the house. So in all I had 4 HD streams going at once and I had no issues.
For $30 investment I advise replacing the Realtek NICs and save yourself some headaches. If that doesn't solve it try the Netgear switch for $155 online.
post #11 of 12
For what it's worth, my problem ended up being the boot drive in my WHS. I really never figured out how that was affecting streaming media, since the media was not on the boot drive, but installing a new drive completely solved my stuttering problem. I'm still using unmanaged gigabit switches and the onboard Realtek NICs. I don't even have trouble with demigrator.
post #12 of 12
I got intermittent stuttering in HD videos with my Realtek RTL8111 onboard gblan also. I have all un-managed Dlink gigabit switches. My resolution was to install the 03/22/2010,7.018.0322.2010 version of Realtek drivers. Any version after this would cause the stuttering. It may very well be a driver issue for you so I would try that Realtek version or one of the new stable Realtek releases from Gigabyte's website from here. So far all of the Realtek gblan driver revisions that I have gotten off of Gigabyte's website have been rock solid with no stuttering. Let me know if it fixes your problem.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › Stuttering HD Playback on Gigabit Network