or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Pioneer VSX-820-K Dolby Digital 5.1 problem
New Posts  All Forums:Forum Nav:

Pioneer VSX-820-K Dolby Digital 5.1 problem

post #1 of 5
Thread Starter 
Hi,

I just purchased a Pioneer VSX-820-K and connected it to my Motorola cable PVR. The signal from the PVR is Dolby Digital 5.1 but the Pioneer is only putting sound out of the left and right speakers. There is nothing coming from the center, subwoofer, or surround speakers. Why is this and how do I get it to use the full 5.1 setup? I have tried monkeying with settings and can't get it to work. I even tried using both the coaxial and optical digital connections.

I know the PVR outputs a Dolby Digital 5.1 signal as my previous receiver had a graphical display that showed all 5.1 channels lit up meaning it was receiving a signal for them all.

I know the speakers are set up correctly as when I go in to the setup program on the Pioneer the test tones come out of all 5.1 speakers. Also, if I use my media player to output a DTS 5.1 signal then it uses all 5.1 speakers. It only seems to be the Dolby Digital 5.1 from the PVR that it will only use the stereo speakers.

Has anyone else had this issue or have any idea how I can fix it?

Thanks!
post #2 of 5
You only need to use one digital connection from the Motorola for an audio connection. Don't use both. Pick either digital coax, or optical for audio. Are you running an HDMI cable straight to the TV for video? It seems that you may have stereo selected as the listening mode on the receiver. Try selecting Dolby Digital.
post #3 of 5
Thread Starter 
Quote:
Originally Posted by Secret Squirrel View Post

You only need to use one digital connection from the Motorola for an audio connection. Don't use both. Pick either digital coax, or optical for audio. Are you running an HDMI cable straight to the TV for video? It seems that you may have stereo selected as the listening mode on the receiver. Try selecting Dolby Digital.

Hi, sorry, I wasn't very clear. I meant that I tried the digital coax and the digital optical but not at the same time.

Yeah, I'm running HDMI from the Motorola to the TV for video and the digital coax from the Motorola to the Pioneer receiver for digital audio. This setup worked fine with my Yamaha receiver.

I selected Auto Surround Sound on the receiver which the manual said should pick the best setting according to the incoming source. I tried the direct setting too and that didn't change. The manual doesn't say if there's a way to see exactly what signals it's receiving. It just says that the Dolby symbol and a D should display when it is receiving a Dolby Digital signal (which it is). My old Yamaha would light up individual speaker icons to show what channels it was getting.

The weirdest thing is I tried movies on two different channels and they behaved differently. They both showed Dolby Digital 5.1 in the guide on the PVR but one had output from the center channel, surround, and subwoofer while the other one didn't.

Very weird...
post #4 of 5
Your going to have to get better about identifying the audio on the particular content and using your software on the audio processor accordingly.

Remember, if the audio processor makes sound it is decoding what the source is putting out.
post #5 of 5
Thread Starter 
Quote:
Originally Posted by JOHNnDENVER View Post

Your going to have to get better about identifying the audio on the particular content and using your software on the audio processor accordingly.

Remember, if the audio processor makes sound it is decoding what the source is putting out.

Well with the PVR I can only go by the info the PVR provides and both programs showed Dolby Digital 5.1.

The receiver says it's getting a Dolby Digital signal but it doesn't indicate what channels are in that signal or at least I couldn't see a way to get it to show that.

I had some surround sound issues with my media player when I first got it and the channel icons on my Yamaha were a huge help. I was playing content with 5.1 sound but the media player couldn't decode AAC in 5.1, only AC-3. So if I looked at the content it would say dolby digital 5.1 but the receiver would only show icons for stereo channels (R and L). That told me that something was wrong since I knew it should have 5.1 channels. Turns out after some investigation I came across the AAC vs AC-3 issue. Once I recoded the content to be 5.1 in AC-3 then all 5.1 icons lit up on the receiver so I knew it was getting all 5.1 channels.

I mean, is it possible for something to have Dolby Digital 5.1 but only provide right and left channel signals? That wouldn't seem to make sense to me. If the PVR says 5.1 then I would assume that it would send all 5.1 channels so I'm not sure why the receiver wouldn't output them all. I can only assume that the receiver is not handling it properly for some reason.

Very frustrating :/
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Pioneer VSX-820-K Dolby Digital 5.1 problem