or Connect
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Players › Official LG BD690/670/650/6xx Series Thread
New Posts  All Forums:Forum Nav:

Official LG BD690/670/650/6xx Series Thread - Page 66

post #1951 of 2320
I have BD660 - is there some fix for the white subtitles yet? They're driving me nuts and what's the worst, I can't do anything about it. Any plans from LG to throw an update fixing the matter or not really?
post #1952 of 2320
I have the BD670 and When I play Netflix it seems like the audio and video are out of sync. Is there any way to fix this? What causes it?
post #1953 of 2320
Hi, just connected my BD670 to my PC to watch .m4v files that are stored on the PC.

I have tried connecting via wireless and ethernet, using CIFS and DLNA (Nero Media home4) and get the same result....

If I watch the films on the PC I can skip chapters forwards and backwards, if I try to skip chapters on the blu ray player it skips to the next or previous film, i.e. skips to the next file stored on the PC!!!!

I know the file contains the chapter marks because hte PC will skip chapters.

Is there a trick to get the LG 670 to respect chapters in a m4v files? I'm new to all this codec, container stuff!,

I'm using AnyDVD to backup to an .ISO fie, then Handbrake to shrink and convert to a .m4v file.
post #1954 of 2320
Quote:
Originally Posted by DeAd MiKe 187 View Post

They really need to fix this DVD audio stutter when going to a new chapter, already. It's been months!

Yes, I wrote twice to LG for this, and they said there is no such a problem and suggested to bring my bd670 to assistance.
But with the sw version released two generations before the BD.8.97.413.E there was no audio stutter. But if you use that one you can't use the apps...

Some days ago tried the last firmware (H90378) and can't play dvd no more!
Reverted to H90377! Always store on you PC the previous versions...

So, I have no more faith in LG SW and I'm really pessimistic about the fact that the problems will disappear in the future.

PS: if you try and play Beatles' "Let it be... naked" on this player, it recognizes it as a data disc (the cd has 2 sessions) and you can't listen to it (of course it worked on every other player I have at home or in the car).
post #1955 of 2320
Quote:
Originally Posted by Panacotta View Post

I have the BD670 and When I play Netflix it seems like the audio and video are out of sync. Is there any way to fix this? What causes it?
It's not uncommon at all. The Netflix app on my BD670 is pretty much unusable and has been for most of the time I've owned this unit. I've tried everything to fix it but now I just use my Roku to stream it, the Roku is easy and much more reliable for streaming than my 670.
post #1956 of 2320
I have a 670 that I just purchased. Here is the current firmware version I have:
BD.8.62.351. H90359

My first question: Should I stay where I am? Lol!

I have hooked up flash drives and external HD and it plays mp4 and some .mkv movies effortlessly! But some .mkv movies show "resolution not supported".
But I can play that same movie/file on the usb TV input on my PZ950.
What gives???
post #1957 of 2320
*edit* I just came across a .mp4 1080p file that the 670 also won't play but the TV will!

????
post #1958 of 2320
*edit* I just came across a .mp4 1080p file that the 670 also won't play but the TV will!

Also... I can seek forward and reverse but can't skip by chapters/sections.

????
post #1959 of 2320
Quote:
Originally Posted by mindcrimemc View Post

Yes, I wrote twice to LG for this, and they said there is no such a problem and suggested to bring my bd670 to assistance.
Those people are retarded. They never know anything.
post #1960 of 2320
The problem with LG customer service is same as probably 90% of the customer service reps they are not technician they are just reading what the computer screen said about the problem and most of them doesn’t know even the models and what features each model have or does not think before give you an answer.
One of the times I call LG Customer about the Juddering and blur problem that my plasma TV have on the Camera moves the customer service rep told me to turn on the thru motion to see if that fix the problem.
I reply to them that thru motion is on LCD TV and the model I give to them is a plasma TV that does not have thru motion and should not have that problem since is a 600hz and not a 120hz.
post #1961 of 2320
Quote:
Originally Posted by TXSTYLE View Post

I have a 670 that I just purchased. Here is the current firmware version I have:
BD.8.62.351. H90359
My first question: Should I stay where I am? Lol!
I have hooked up flash drives and external HD and it plays mp4 and some .mkv movies effortlessly! But some .mkv movies show "resolution not supported".
But I can play that same movie/file on the usb TV input on my PZ950.
What gives???

Anybody???
post #1962 of 2320
yes, but the real problem is that there shouldn't be bugs so big.
post #1963 of 2320
Quote:
Originally Posted by TXSTYLE View Post

Anybody???
Is really strange that you can play the movie thru the USB on the TV and not from the USB on the BD670, The only I think is configuration on the B-R Player thru the HDMI.
I see the message one time on my 650 and when I check the movie on my Computer my friend encode the movie with a resolution of 2560x 1440 to watch in his computer and that resolution is not supported, I believe the max resolution supported is 1920x1080, that is why i think is configuration of your HDMI port on the 670 because you can be able to see the movie from the TV
post #1964 of 2320
I am also interested in how to upgrade the hard drive on the LG BD690. Followed the instructions online for upgrading the BD590 but that only bricked two 1TB and 1 2TB hard drives.
post #1965 of 2320
Not sure why the problems upgrading the hard drive on the BD690

Mine worked first time no issues. was I just lucky?

My drive was a Western Digital 2 TB drive.
post #1966 of 2320
Hi folks!
I got a bd670 and it's been sttutering when I watch movies on Netflix on wireless, mainly when it reaches "X-High HD" definition.
Does anybody has this issue? How to solve it? If I use two routers (bridge connection) the problem disappears?
Thanks in advance!
post #1967 of 2320
Quote:
Originally Posted by fernandocw227 View Post

Hi folks!
I got a bd670 and it's been sttutering when I watch movies on Netflix on wireless, mainly when it reaches "X-High HD" definition.
Does anybody has this issue? How to solve it? If I use two routers (bridge connection) the problem disappears?
Thanks in advance!
I have nothing but trouble with Netflix on my 670, it's unusable for the most part. A couple of firmware versions had it working but as soon as the next update came along it was ruined again. All my other premium apps work great (Amazon, YouTube, MLB, Vudu) but Netflix does nothing but skip and jump and stutter with audio going in and out. I don't worry about it much because I can use my Roku that is connected to the same TV.
post #1968 of 2320
Quote:
Originally Posted by fernandocw227 View Post

Hi folks!
I got a bd670 and it's been sttutering when I watch movies on Netflix on wireless, mainly when it reaches "X-High HD" definition.
Does anybody has this issue? How to solve it? If I use two routers (bridge connection) the problem disappears?
Thanks in advance!

I haven't used the wireless connection on my BD670, but based on other comments here, it's my understanding that many others have had the same problem. I have mine connected via ethernet, and I haven't had any stuttering issues, so I would suggest trying that if possible. Good luck!
post #1969 of 2320
Quote:
Originally Posted by Rick313 View Post

I haven't used the wireless connection on my BD670, but based on other comments here, it's my understanding that many others have had the same problem. I have mine connected via ethernet, and I haven't had any stuttering issues, so I would suggest trying that if possible. Good luck!

Quote:
Originally Posted by Buckeye911 View Post

I have nothing but trouble with Netflix on my 670, it's unusable for the most part. A couple of firmware versions had it working but as soon as the next update came along it was ruined again. All my other premium apps work great (Amazon, YouTube, MLB, Vudu) but Netflix does nothing but skip and jump and stutter with audio going in and out. I don't worry about it much because I can use my Roku that is connected to the same TV.


Thank you, I'll try ethernet connection.
post #1970 of 2320
In case you missed this critical question...

I have a 670 that I just purchased. Here is the current firmware version I have:
BD.8.62.351. H90359
My first question: Should I stay where I am?
post #1971 of 2320
Quote:
Originally Posted by TXSTYLE View Post

In case you missed this critical question...
I have a 670 that I just purchased. Here is the current firmware version I have:
BD.8.62.351. H90359
My first question: Should I stay where I am?

It depends on who you ask. I think you basically just need to read the last several pages of this thread and make the decision for yourself. I'm using the most current firmware BD.8.97.413.E H90378, and I haven't had any issues with the unit. I had some Netflix issues a while back where it would begin to play a movie and then say that it encountered an error and stop, but since I disabled Quick Start, that hasn't been a problem. Several people have reported audio issues and Netflix stuttering issues, but I haven't encountered either of those. However, I have my BD670 connected via ethernet which seems to be less error prone than WiFi, and I only use it to play DVDs and Blu-Rays and stream movies from Netflix, Amazon, or Vudu. I don't use it to stream media files from my local network or USB drives or anything.

One word of advice. If you do decide to upgrade the firmware, remove your USB flash drive first. I've tried a couple of different brands of flash drives, and if I had either of them connected when I attempted to upgrade the firmware, the player would download the firmware, but then the install would fail. Once I removed the flash drive and rebooted, the update worked, so there seems to be some sort of conflict there.
post #1972 of 2320
Hey all. I have a BD660 running the latest firmware and am having a weird issue. The unit powers on randomly. It runs fine, playing Blu-Rays, Netflix or media from my NAS. And when the unit is on, it stays on, at least while its in operation. But everytime I shut the unit off, walk away, I'll come back and its powered on. I called LG, and as I'm sure everybody on here knows, they were useless and told me to bring it to a repair center. It's within a year so its still covered under the warranty. Anybody else have a similar experience?

The unit has been running fine up until now. Hasn't moved, or changed outlets, have not added anything new to the system except a new router. The 660 is plugged to my Denon AVR-1712 via HDMI and to my Netgear WNDR 4500 via ethernet. It's more annoying then anything because I have a Harmony universal remote and when I press the DVD activity button, if the unit is already powered on, it shuts it off. Appreciate any help or input. Thanks all!
post #1973 of 2320
Are you sure you don't have another remote that might be operating your LG player? This was happening to me on my Panasonic BDP500 because my TV remote signals were operating the Panny player and I had to turn these settings off in the player before it stopped.
post #1974 of 2320
A few months ago I purchased two lg bd690 players and have experienced most of the problems noted by the many forum people.
One problem has me completely perplexed. When new these machines would convert to mp3 but now they just remain as wave files and will not downconvert.
As I want to store more music etc, I would like this function to work . On my one machine which just recently locked up, I reinitialized the harddrive, wiping all info and did a factory reset, even doing the cold shut down and reboot several times; the machines will still not convert to mp3- looks to be locked in lossless.
Called Lg service a few weeks back and got the usual nonanswers--have you cleaned the drive? etc...
well so far my luck has been that they will play all types of discs ( so far). The first unit i bought and returned made a sound like a chainsaw whenever any disc was inserted. Does anybody have any insight or have experienced the same problem. All latest firmware installed- as well as the newest driver a few weeks back- wonder if that had anything to do with it.
I know Lg support will not be any help with this problem.
post #1975 of 2320
Quote:
Originally Posted by lujan View Post

Are you sure you don't have another remote that might be operating your LG player? This was happening to me on my Panasonic BDP500 because my TV remote signals were operating the Panny player and I had to turn these settings off in the player before it stopped.

Nope, don't think so. I have all my remotes (TV, BluRay, Cable, Receiver) stored a way in a drawer in another room and I just use my Harmony to control the entire system.

I called LG and they told me to take it to a repair center. The repair center then directed me back to the store where I purchased the unit and said they will give me a new one. Just wasted almost an hour this morning getting to the repair center and they told me LG sends people there all the time even though they should be telling customers to go back to the point of purchase and receive an exchange. Heading downtown later to Centre Hi-Fi. Pretty annoyed with LG right now.
post #1976 of 2320
Quote:
Originally Posted by stibone View Post

Hey all. I have a BD660 running the latest firmware and am having a weird issue. The unit powers on randomly. It runs fine, playing Blu-Rays, Netflix or media from my NAS. And when the unit is on, it stays on, at least while its in operation. But everytime I shut the unit off, walk away, I'll come back and its powered on. I called LG, and as I'm sure everybody on here knows, they were useless and told me to bring it to a repair center. It's within a year so its still covered under the warranty. Anybody else have a similar experience?
The unit has been running fine up until now. Hasn't moved, or changed outlets, have not added anything new to the system except a new router. The 660 is plugged to my Denon AVR-1712 via HDMI and to my Netgear WNDR 4500 via ethernet. It's more annoying then anything because I have a Harmony universal remote and when I press the DVD activity button, if the unit is already powered on, it shuts it off. Appreciate any help or input. Thanks all!
Sounds to me like HDMI CEC somehow got enabled somewhere in your system. I think LG calls theirs Simplink or something like that. Go thru the settings on the player and on your TV and AVR and make sure anything called sync or link is disabled. If it's enabled you can get phantom power ups as you've described whenever inputs change on your other devices. I doubt anything is wrong with your player.

If you want to fix your activity, just customize, add more control and add an extra discrete on or power on, rather than toggle. Or change the power commands used by the activity to the discrete ones. I just checked, and the harmony profile for many LGs does indeed have Power On and Power Off. So using those plus a redundant power on instead of power toggle will make your macros work regardless of the initial power state.

Your player uses the NECx1 protocol, device 45.45 which is also shared by some Motorola DVRs among a few others. So if you have such a device, there's a possibility of the same signal controlling both.
post #1977 of 2320
Simplink is off on both player and TV (which is also LG). And nothings changed on my setup. That's what's odd. And, as I said, the player will just turn on even when nobody's home and the system is totally off. Or, I'll be listening to music or watching TV, and not using the remote, and the player will just turn on. I can reprogram the Harmony but Im more concerned with something being wrong with the player and then my warranty expires (December 26) and then I'm SoL. I would more believe it was the issue you're describing if it had always been happening but since it just started out of the blue, I think it's got to be the player. I don't have kids and my wife doesn't touch the system so it seems unlikely a setting would have gotten changed. I also verified HDMI control is off on my Denon AVR.
post #1978 of 2320
Then I agree it's a defect.
post #1979 of 2320
Took it back, got a brand new player. We shall see what happens.
post #1980 of 2320
Can the BD670 be coaxed into playing mkv's remuxed from DVD (e.g. plain old mpeg2 +AC3 content)? It seems my 670 (with latest firmware) just won't do it (over the network...never tried on USB, and don't plan to). I saw a couple of tips here in this thread about making sure header compression was turned of (by remuxing with mkvmerge), which I did, and that didn't help. It's still saying it's an unsupported format. I've used makemkv and DVDfab (using passthrough mode to an MKV container). I've re-encoded to some other lossy codecs and that seems to be ok though. Raw mpeg2 work fine of course, but I'd really like to have chapter stops. Are there any other containers the BD670 supports that could give me chapter stops and that support mpeg2 payload remuxed straight from DVD? I'm starting to think they don't want me to play my dvd's without re-encoding smile.gif.
Edited by James Sponaugle - 10/3/12 at 2:25pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Blu-ray Players
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Players › Official LG BD690/670/650/6xx Series Thread