or Connect
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Software › Excalibur
New Posts  All Forums:Forum Nav:

Excalibur

post #1 of 4
Thread Starter 
I just picked up Excalibur new on HD-DVD for an ubber cheap price. My HD-DVD collection is pretty limited maybe 15 titles but they all play perfectly on my xbox 360 HD-DVD player except this movie. The movie has little pauses and sound cuts continuously from beginning to end. The pauses happen around every ten or so seconds. I bought this on HD-DVD because the blu-ray is stretched so everyone looks about 15lbs heavier than they really are. Looks like I'm forced to buy the over weight edition. Did anyone else have problems with this title on an xbox 360 drive?
post #2 of 4
Try cleaning the disc. There always seems to be residue on the discs which I think come from the cases.
post #3 of 4
I have picked up two copies of Excalibur and cannot get them to play on my LG BD/HD combo drive. I cleaned and even boiled the discs, I wonder if there was a bad lot that is now being sold. Both of mine were new.
post #4 of 4
Thread Starter 
There is definitely something wrong with the disc. I cleaned the disc and put it in the player and the exact same thing happens. Also when I press the XBOX button which brings up the xbox menu while the Excalibur disc is in the HD drive the xbox menu is very slow and juttery as if the entire system is being bogged down by the disc. In contrast I put the HD-DVD of Blade Runner (disc 1 Final Cut) in the drive and it is flawless. When I press the XBOX button the xbox menu jumps on the screen very smooth and effortless. What a complete let down. Oh well off to buy the blu-ray version.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HD DVD Software
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Software › Excalibur