or Connect
AVS › AVS Forum › Gaming & Content Streaming › Home Theater Gaming › HTPC Gaming › PC Connected HDTV via HDMI. Very Dark Picture/Saturated Colour
New Posts  All Forums:Forum Nav:

PC Connected HDTV via HDMI. Very Dark Picture/Saturated Colour

post #1 of 14
Thread Starter 
As the thread title suggest. I have my PC connected to my HDTV by HDMI. But the picture is much darker than normal and colours are saturated. In content with dark scenes it is almost impossible to see what is happening. To put it simple it looks ugly compared to using the VGA connection or compared any other device I have connected through HDMI or Component. For example my PS3 connected by HDMI does not have this problem and looks great.

Does anyone know why this is and how it can be corrected. Simply adjusting the pictures settings on the TV has not helped. The TV is a Sony KDL46Z5500.
post #2 of 14
Adjust picture settings on the PC. Color, brightness, gamma, etc, also turn the sharpness waaay down/off on the TV.
post #3 of 14
If you have nVidia card, go into the control panel and select change resolution on the left. Then in the list of resolution options, there's two lists of resolutions. One is for HDTV, and the other is for PC. One is 50hz, and the other is 60hz. I forget which is which, but on my HDTV 60hz is too dark, and 50hz looks to be right on the ball.
post #4 of 14
i suppose ur tv recognizes the HDMI connection as a PC connection ( cuz my sony bravia does) ...in that, make sure the picture setting is something like TEXT (my tv has TEXT and VIDEO when using a PC connection)...in the video mode the dynamic contrast adjustment kicks in, and that ruins the gaming experience....use text mode, dynamic adjustment is OFF in that mode and it will likely fix your problem
post #5 of 14
Check the owner's manual for the signal table and make sure the signal being output by your card matches what is on the signal table for 1920 x 1080.
post #6 of 14
The problem is the colorspace. TV's use a colorspace where black is a value of in RGB is 16-16-16, whereas on a computer the RGB value of black is 0-0-0 (same thing happens with white, on a TV the value is 235-235-235, but on a computer the value is 255-255-255). You need to tell your computer to output using the TV colorspace, or you need to tell your TV that it needs to use the computer colorspace on that input. Obviously changing the TV is usually not an option as it would have needed to be a feature available on that particular model (typically reserved for the highest end sets). On your computer, it is typically a setting under the display drivers. I know both Nvidia and AMD have options for it, but you would need to look up how to do that with your particular graphics card (I don't remember exactly how off hand so I am not going to write a wrong procedure of how to set those settings here).
post #7 of 14
I have an ATI Mobility Radeon HD 4760 and I cannot find the colorspace setting anywhere. Even further I found a setting for Hertz and all i see are 30 or 60.

I am having the same issue with my pc color much brighter than every TV i plug it into. Please help
post #8 of 14
Go to Desktop Management then Desktop Color is CCC. You can change settings there.
post #9 of 14
Hello All,

I have scoured the internet with the same problem and achieved mixed results based on different approaches.

I can confirm that it appears to be a problem between what image the PC is sending and what processing the TV then does - or doesn't do with this image

This is on the HTPC still having the problems.
O/S: WIn 7
Video Card: XFX HD 7750, obviously using HDMI out..
HDTV/Monitor: Sony Bravia KDL-46W4500 (46" LCD purchased 2009)

I also experienced the same darkness color issue on a 2012 Samsung 27" being fed all sorts of resolutions from a Samsung Series 3 laptop via HDMI. I spent 4 months deployed for work without being able to sort out the issue on that TV/monitor.

Recently I found someones post that suggested I find the option within the TV menus to essentially change the label or name of the input on that HDMI selection. Doing this on the Sony TV didn't change a thing. I renamed it 'PC' and saw no difference. However! Once I found the option on the Samsung 27" with Samsung Laptop and selected "HDMI-PC" it was perfect! The option could only be found by pressing the input button on the remote and then pressing the 'tools' button as it is a specific 'tools' menu for the input selection screen.

I suspect as my Sony TV is a little older this setup option didn't have the same effect and was just for the sake of naming conventions and user comfort. The Sony has got a VGA input available and when this is utilised the picture looks great, it really appears as it should with the HDMI cable. The Sony even gives you specific menu options available only when the VGA input is used. The website below explains what must be changed in order to view a PC image properly on the Sony however the "[Scene Select] to [Graphics]' instruction can't be followed as my tv doesn't have that menu option.
http://www.sony-asia.com/microsite/bravia_i-manuals/FY12/X9000/AU_SG_SA/connectpc_europe_fsh.html

I did change the [Wide Mode] to [Full] and set the [Display Area] to [Full Pixel], both these changes helped the image but didn't solve the problem of the darkness/color issue. I Also needed to remove the underscaling and set it to 0% through the Catalyst Control Center (CCC). Again, this helped but didn't make the image colors look right and still not the same as when I connected the VGA cable.

In CCC I have adjusting the Pixel format to RGB 4:4:4 Pixel Format Standarrd (Full RGB).
I have run the color management walk through in Windows 7 but each time I can't get the Gamma close to the example of "just right".

There doesn't appear to be an option online to update my TV's Firmware, the current version is:
B.D-C-DU-C.EZ.gQ-A.DL.X

If i try adjusting the TV brightness, color settings it will look correct in one scene but not the next. Playing Skyrim is nearly impossibly because the dark areas are losing detail. To get Skyrim correct means that windows itself and most TV shows are Far too bright.



Has anyone got any other ideas?
Thanks for any help available!!
post #10 of 14
I would suggest trying all 3 different hdmi inputs. Normally at least one of these is actually a dvi connection and in my experience provides the highest compatibility and picture quality. YMMV

In example on my projector I have to use hdmi 2 because hdmi 1 looks horrible. I have found that hdmi 2 looks better on other sources but from my htpc was the most dramatic.

I have found that my htpc needs a better hdmi cable than any other component. You would probably be having further issues if this was the problem but I would try and rule out this possibility by switching around cables really quick and directly wiring to the tv(assuming you are going through an receiver).

If this doesn't work I would suggest looking into if you can connect the vga for video and use the hdmi connection only for audio.

Lastly you might get more/better responses on this issue in the normal htpc section...

Please report back on success/failure.
post #11 of 14
i am aware this thread is 2 years old but it always helps everybody on the internet when a solution is posted .
so i just signed up to share this and hope it works for anyone else with the dark side of gaming problem .

i use a hdmi lead from pc to sony bravia with nividia card and in the nividia settings dialogue i simply switched FROM [digital colour format] RGB -TO- YCbCr444
all other settings where defaults. Now i can see when the game goes darker
hope its of use
post #12 of 14
Quote:
Originally Posted by justanobody View Post

i simply switched FROM [digital colour format] RGB -TO- YCbCr444
all other settings where defaults.

FYI - if you update or re-install the graphics card driver, you will need to remember to change the color format. The drivers default to RGB for computer monitors, but to state it simply: most TVs want YCbCr444 via HDMI for best black levels.
post #13 of 14
I used to have this problem, just adjust the energy saving mode on your tv by making it Auto or Off and it will work hopefully
post #14 of 14
I used to have this problem, just adjust the energy saving mode on your tv by making it Auto or Off and it will work hopefully
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HTPC Gaming
AVS › AVS Forum › Gaming & Content Streaming › Home Theater Gaming › HTPC Gaming › PC Connected HDTV via HDMI. Very Dark Picture/Saturated Colour