or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Samsung LN40A650 Display Problems
New Posts  All Forums:Forum Nav:

Samsung LN40A650 Display Problems

post #1 of 3
Thread Starter 
I've had my LN40A650 since Feb. of 2009 and have been very happy with it overall.

Lately though, it has been acting strangely when I first turn it on after being turned off overnight. The picture is really dark and some images aren't visible at all for about the first 2-3 minutes it's turned on, and then it brightens up to normal and remains fine the rest of the day. Once it's "warm," turning it off and back on again doesn't seem to cause any problems. It's an intermittent issue--sometimes the TV acts just fine even after being turned off for a couple days.

The input doesn't seem to matter, as the TV's own menu options are dim along with the programming.

Any ideas what might be wrong? If it gets worse, is it something that would be cost prohibitive to fix? I paid $1250 for this set back then, but it looks like similar models today are only about $750, and I didn't buy the extended warranty.

Thanks!
post #2 of 3
Google "Samsung Capacitor Problem" and you may see that this is what you are experiencing. Good luck to you. I also have an A650 that I love and I pray every day that mine will continue to look as perfect as it currently does.
post #3 of 3
Sounds like the CFL power supply. It should be one of the less expensive repairs. The intermittent nature of the problem could make it more difficult to fix. I can't recommend a repair source.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Samsung LN40A650 Display Problems