or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Vizio E3D420VX
New Posts  All Forums:Forum Nav:

Vizio E3D420VX - Page 11

post #301 of 373
Quote:
Originally Posted by Rudy1 View Post

Go into MENU, then select HELP, and you should find the version number in the system info panel.

Thanks
Quote:
Originally Posted by Rudy1 View Post

I checked the Vizio website and they don't seem to have any firmware update files available for download. My TV has yet to download the update, and Vizio claims there is no way to force a download...you just have to wait for it to happen.

I just checked and I'm not on the current version either, I'm on 2.17.0.1100. Is it usual practice for Vizio to roll out updates this slowly??
post #302 of 373
According to Vizio tech support, the firmware updates roll out gradually to the TVs...all sets do not receive the update at once. So it can take several weeks.
post #303 of 373
Well, their support really sucks too... Or at least the chat does. I'm stuck on the software version 2.13.4.0935... What's taking MY firmware so long to update? All I want is for youtube to stop stopping so much :'( with 25MBPS internet, it gets very annoying.
Edited by Adam Cab - 1/12/13 at 9:59am
post #304 of 373
This is a perfect argument against web based firmware updates. Some seem to think it's the 'cats meow', but it surely isn't.

Give me the ability to do it myself when I have control of the process. Also give the ability to flash back to a previous version.
post #305 of 373
I'm still stuck on 2.13 firmware version, but I have a different problem I'd like to address -
I am playing 3D games, specifically Dirt 3, which has 3D support built in. It was playing very poorly at 1080 so I turned the resolution down to 720. But it literally turned the screen size down to 720. Now I have black bars all around the image, cutting off ~1 - 2 inches of my total display size. Changing picture mode or setting horizontal and vertical screen size is not available in the TV menu, all of these things are greyed out when I am in 3D mode. Game mode is still greyed out as it has always been when I put it in 3D, but is there any way to get the 720p image to take up the full screen size?
post #306 of 373
Quote:
Originally Posted by Coop Cooper View Post

Just ordered this TV for my bedroom. I went with the 42" version. I will mainly be gaming (non-3D 98% of the time) and watching TV/Movies (Some movies in 3D). It will be in tomorrow and I am very excited about it. Can't beat the price for all the features and the reviews have been mostly positive. Anybody else here game on this TV (360, PS3, Wii U) and have no problems? I have read some people say there is input lag but others have said it's 100% fine after you turn on Game Mode. I am guessing most the people complaining haven't turned on game mode or tweaked the settings enough to get it going like it should be? Any new owners feel like sharing their experiences? Thanks!

PS3 on it all the time in game mode. It's awesome! Even some 3D games smile.gif
post #307 of 373
Quote:
Originally Posted by videobruce View Post

This is a perfect argument against web based firmware updates. Some seem to think it's the 'cats meow', but it surely isn't.

Give me the ability to do it myself when I have control of the process. Also give the ability to flash back to a previous version.

I had mine off, literally unplugged for about two days, then I plugged it in and turned it on and Viola firmware update. I immediately looked up the version on line and found nothing about it so I figured it was new, hence my taking the photo and posting this.
post #308 of 373
Quote:
Originally Posted by petermg View Post

I had mine off, literally unplugged for about two days, then I plugged it in and turned it on and Viola firmware update. I immediately looked up the version on line and found nothing about it so I figured it was new, hence my taking the photo and posting this.

which version did it update to?
post #309 of 373
Petermg said his firmware was upgraded to version 2.20.0.1113. I'm still at version 2.17.0.1100, and Vizio tech support says the updates are rolled out according to the set's serial number.
post #310 of 373
That must be the case... I'm still at 2.17 also.
post #311 of 373
Is there any way to force an update? Mine is on 2.13.4.0935 and my Netflix app locks and I experience freezes that require me to unplug the power.
post #312 of 373
Quote:
Originally Posted by dwschoon View Post

Is there any way to force an update? Mine is on 2.13.4.0935 and my Netflix app locks and I experience freezes that require me to unplug the power.

I have tried several things, including leaving the unit unplugged for a few nights and resetting it to factory defaults. But I was not able to force an update.
post #313 of 373
the same goes for me... i contacted vizio and they said it was because it was wirelessly connected. so i went to buy a 50ft ethernet cable to be able to connect it via my router and guess what? NOTHING! they wont even bother sending you an update or even give you a link to download it yourself to a usb to update it frown.gif

this sucks..
post #314 of 373
Has anyone actually determined what the update does?
post #315 of 373
I'm not sure, but I think it adds basic DLNA capability to the set.
post #316 of 373
Quote:
Originally Posted by Rudy1 View Post

I'm not sure, but I think it adds basic DLNA capability to the set.

I was just curious as it seemed some folks were getting really upset over an unknown improvement.
post #317 of 373
i wish it would improve the youtube app cuz it always freezes and yet i get 15mpbs down when wireless and 20 mbps down when connected via a cord
post #318 of 373
Quote:
Originally Posted by Adam Cab View Post

the same goes for me... i contacted vizio and they said it was because it was wirelessly connected. so i went to buy a 50ft ethernet cable to be able to connect it via my router and guess what? NOTHING! they wont even bother sending you an update or even give you a link to download it yourself to a usb to update it frown.gif

this sucks..

I've only ever had mine connected via WIRELESS...
post #319 of 373
This is kind of digging up an old thread, but NewEgg currently has a 47" refurb of this TV for $480. I know this is almost a 2 year old TV at this point, and especially as a refurb, is that even a decent deal? I'm looking to replace a 7 year old 42" Samsung 720P DLP as my primary TV, and am not looking to spend a ton. I don't really need to 3D or SmartTv features. My only requirements are (true) 1080P, 120Hz refresh, and a matte screen (and preferably 47-55").
post #320 of 373
Quote:
Originally Posted by drocpsu View Post

This is kind of digging up an old thread, but NewEgg currently has a 47" refurb of this TV for $480. I know this is almost a 2 year old TV at this point, and especially as a refurb, is that even a decent deal? I'm looking to replace a 7 year old 42" Samsung 720P DLP as my primary TV, and am not looking to spend a ton. I don't really need to 3D or SmartTv features. My only requirements are (true) 1080P, 120Hz refresh, and a matte screen (and preferably 47-55").

Bj's has new E420i-A1's for the same price. Some Target's have E422VLE and E420i-A0 on sale around that price as well. Don't know for sure if they're matte, but their 120hz.
post #321 of 373
Came back in to see... anyone getting the 2.20.0.1113 firmware update? I'm 2.17.etc, not sure if 2.20.0.1113 is coming or lost in neverland.
post #322 of 373
Sorry if this has been asked before but I don't have the time to search all replies in this thread.
I have a question about the rear 3.5 mm audio out jack.

If you plug something into the jack, do the speakers continue to work, or do they turn off?
Also, is there any adjustment for this jack in the audio setup?

Thanks, I can't find this info anywhere.
post #323 of 373
Quote:
Originally Posted by GSfromCT View Post

Sorry if this has been asked before but I don't have the time to search all replies in this thread.
I have a question about the rear 3.5 mm audio out jack.

If you plug something into the jack, do the speakers continue to work, or do they turn off?
Also, is there any adjustment for this jack in the audio setup?

Thanks, I can't find this info anywhere.

Don't mean to sound like an a**, but wouldn't it have been just as easy to plug in some headphones or something in the jack and find out?
post #324 of 373
Nevermind... Got it!
Edited by voodoozen - 4/12/13 at 3:53am
post #325 of 373
Quote:
Originally Posted by ngwest36 View Post

Don't mean to sound like an a**, but wouldn't it have been just as easy to plug in some headphones or something in the jack and find out?

DEFINITELY!
But I don't own the TV. I don't know anyone who owns the TV locally and I went to 3 Walmarts and 2 Targets and cannot even find the TV on display.
So I thought it might be easier to just ask someone here who actually has this TV.
post #326 of 373
I don't think this is a current model anymore. It has most likely been discontinued.
post #327 of 373
Quote:
Originally Posted by GSfromCT View Post

DEFINITELY!
But I don't own the TV. I don't know anyone who owns the TV locally and I went to 3 Walmarts and 2 Targets and cannot even find the TV on display.
So I thought it might be easier to just ask someone here who actually has this TV.

Ah! Gotcha! lol
post #328 of 373
After signing up for Netflix over the weekend I was shocked and a tad disappointed to find that the Netflix app only supports standard definition output. Hulu works great, content from Rev3, Vimeo, youtube etc is fine and all HD, but Netflix looks to be sub 720 regardless of what content I pick (both movies and tv shows are the same). Is there a setting that needs to be changed, or is this as good as it gets?

I've got plenty of bandwidth, hopefully I'm just missing something?
post #329 of 373
change settings in your netflix account from your computer for the best possible stream you have three settings low medium and high
post #330 of 373
Good morning all!

I have the E3D470VX and currently the latest firmware is 3.18.2.1164, which is something that seems to have updated within the last two days. Since then, i am unable to select 3D mode anymore from the input from my PC via hdmi 1. A thread in these very forums suggested that its because it needs to say 1080p and not 1920x1080 in the upper right info box. Ive tried switching ports, doing a factory reset, to no avail. On the pc side i uninstalled and reinstalled the drivers - tried changing the resolution from 60 to 24 hz and everything between to no avail. Any advice from you guys would be apprecaited. What is the firmware version people are running?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Vizio E3D420VX