or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › Lav Madvr guide??
New Posts  All Forums:Forum Nav:

Lav Madvr guide?? - Page 3

post #61 of 581
Quote:
Originally Posted by Tong Chia View Post

Start simple. Softcubic on MadVR produces a pleasing image and there
is a sharpness knob you can play with. After that substitute the chroma
scaling and see what you like.

Catmull-Rom, Mitchell-Netravali and Spline is one group and
Lanczos is the other with cubic in the middle.

The Chronicles of Riddick is a good movie to experiment with the effects
of the various algorithms that MadVR provides.

Luminance and Chrominance are vastly different creatures. The former
is the reference intensity of one of the primary color signals and chrominance
is a pair of values containing the relative intensities of the other
2 primary colors, the color difference signal.

In simple terms the Luma channel needs a good 1D reconstruction filter and
chroma needs one that works well in 2D. Mitchell-Netravali and
its derivitive Catmull-Rom was originally designed as a 2D image reconstruction filters

If you are interested in how the information is encoded in video look
at the link below.
http://en.wikipedia.org/wiki/YUV


What calibration hardware/software did you use to generate your 3dlut?
post #62 of 581
Quote:
Originally Posted by riverhawk79 View Post

What calibration hardware/software did you use to generate your 3dlut?

You will need yCms to generate the 3d LUT table
http://forum.doom9.org/showthread.php?t=154719

Put the generated files in the madVR directory
post #63 of 581
I have a issue with MadVR and video levels. Setting MadVR to output 0-255 (and using custom Nvidia resolution) I get black crush in exclusive full screen mode. In windowed mode video levels are correct. Disabled exclusive fullscreen mode and video levels match between fullscreen and windowed mode.

MadVR .61
LavCUVID .7
LAV Splitter/Audio .28
MPC-HC .3018
ReClock
post #64 of 581
Quote:
Originally Posted by nightfly85 View Post

I have a issue with MadVR and video levels. Setting MadVR to output 0-255 (and using custom Nvidia resolution) I get black crush in exclusive full screen mode. In windowed mode video levels are correct. Disabled exclusive fullscreen mode and video levels match between fullscreen and windowed mode.

MadVR .61
LavCUVID .7
LAV Splitter/Audio .28
MPC-HC .3018
ReClock

Is exclusive mode running at the same resolution and refresh rate as windowed mode, if not you might have to define a custom resolution for
exclusive mode as well.
Best to check what your TV says and not rely on Windows.

This problem with Nvidia's driver is pretty tiresome.

Your version of MPC-HC is also getting old. .3177 is the current version,
MadVR seems to work better with the later versions.
post #65 of 581
Just a quick question, why not use Lanczos or Spline for Luma sampling in MadVR?
post #66 of 581
Quote:
Originally Posted by Rico66 View Post

Is there anything special that I need to do to get subtitles working when using madvr? On a recent blu ray (native, no rip) I noticed that the subtitles would not show up. This wasn't using lavsplitter, lav audio, and MPC for video. When I switched the renderer to EVR instead the subtitles would display as expected.

I'm just getting to try this out on my test PC with a NVIDIA 8600GT...
The image quality with madVR (+ LAVCUVID) is freaking awesome...

The only current issue is that the subtitile option is greyed out in MPC-HC while using madVR, but subtitles work well with EVR.

I am using the latest LAV, latest MPC-HC tryout, but on vista 32 bit.
Can the subtitile problem be due to vista?

My main HTPC runs win7 with a GTX460... will try setting it up there after Roland Garros is finished today...
In the meanwhile, if anyone has subtitles working with madVR kindly share your settings

Thanks.
post #67 of 581
Quote:
Originally Posted by balky View Post


I'm just getting to try this out on my test PC with a NVIDIA 8600GT...
The image quality with madVR (+ LAVCUVID) is freaking awesome...

The only current issue is that the subtitile option is greyed out in MPC-HC while using madVR, but subtitles work well with EVR.

I am using the latest LAV, latest MPC-HC tryout, but on vista 32 bit.
Can the subtitile problem be due to vista?

My main HTPC runs win7 with a GTX460... will try setting it up there after Roland Garros is finished today...
In the meanwhile, if anyone has subtitles working with madVR kindly share your settings

Thanks.

I'm Sure it will work better with the gtx460, the 8600gt only has like 15 stream processors compared to like 330.
post #68 of 581
Well this is a fun thread! Tong Chia, thank you for the invaluable information. I just generated 3DLUT tables for my main HTPC. Remarkable. I'm using MC16 with madVR. Man what an awesome combination.
post #69 of 581
so after uninstall lav, mpc 64, 32, and reinstalling lav, mpc32, madvr (finally), now 32bit cuvid will not register. (i unpacked it to a folder labeled "lav" in the root directory of C:


C:\\LAV>cd /d "C:\\LAV\\"

C:\\LAV>regsvr32.exe LAVCUVID.ax

C:\\LAV>

I get an error about:

module failed to load. make sure the binary is stored in the specific location.

any ideas?
post #70 of 581
Make sure you get the latest cuvid. It doesn't require the MSVC runtime. Also, madVR 0.62 just came out and has HUGE changes that will affect this crowd. Please go check it out ASAP.
post #71 of 581
downloaded lavcuvid .7. looks like th latest release.
post #72 of 581
Quote:
Originally Posted by joeydrunk View Post

I'm Sure it will work better with the gtx460, the 8600gt only has like 15 stream processors compared to like 330.

Since installing my GTX460 last November, I never got anything so thrilling out of it 2D wise.
The only issue I'm left with now is subtitle related... I just can't get sutitles to work.
I am wondering if anyone is using the LAV-LAVCUVID-madVR combination in 7MC... is it possible at all?
Anybody got subtitles working?

In MPC-HC, I get a pop up window telling me that I have to switch renderer to EVR, VMR9 et al if I want subtitles. I guess something still needs to be done in madVR for subtitles to work.
Anyone got suggestions?

Thanks.
post #73 of 581
Nope. LAV CUVID 0.8 was released this morning.
post #74 of 581
Quote:
Originally Posted by balky View Post

Since installing my GTX460 last November, I never got anything so thrilling out of it 2D wise.
The only issue I'm left with now is subtitle related... I just can't get sutitles to work.
I am wondering if anyone is using the LAV-LAVCUVID-madVR combination in 7MC... is it possible at all?
Anybody got subtitles working?

Thanks.

You won't with just that. You need something that displays subs in the chain. You don't have that. You can add ffdshow raw video decoder to that chain and it should work. That's what I use.
post #75 of 581
Quote:
Originally Posted by SamuriHL View Post

Nope. LAV CUVID 0.8 was released this morning.

figured the installer would fic the issue.. but (ran as adminstrator)




LL
post #76 of 581
To deal with subtitles you could also download and register vsfilter.dll from MPC-HC standalone filters (here).
post #77 of 581
considering cuvid is ONLY for nvidia, yes, i have a 550ti
post #78 of 581
Sorry, I saw it on first page and deleted my post. Anyway, try unregistering it (e.g with Graphstudio) first, then install it.
post #79 of 581
Yikes. I've not seen that issue. You might want to post that in the LAV CUVID thread on Doom9 and see if Nev has any ideas. (Try Tulli's idea first)
post #80 of 581
Quote:
Originally Posted by joeydrunk View Post

I'm Sure it will work better with the gtx460, the 8600gt only has like 15 stream processors compared to like 330.

I only have ati cards right now and i culdn't get decent frame rate on anything less than 120 stream processors.. does madvr do something unique to handle lower sp count on nvidia?
post #81 of 581
did the unregister via graph studio, same issue.
post #82 of 581
Quote:
Originally Posted by jbcain View Post

did the unregister via graph studio, same issue.

Then I would see if Nevcairiel has any ideas on the LAV CUVID thread. I don't know what could be causing it.
post #83 of 581
can't post on doom9 until i've been registered 5 days.
post #84 of 581
You could attempt to PM him on here and see if he has any thoughts.
post #85 of 581
im reloadin win7 64 from scratch
post #86 of 581
Quote:
Originally Posted by SamuriHL View Post

You could attempt to PM him on here and see if he has any thoughts.

He doesn't answer PMs and he is very blunt.

He might help but he wants specifics.

And when I say specifics I mean S-P-E-C-I-F-I-C-S if you know what I mean.
post #87 of 581
Well, he is a busy man.
post #88 of 581
Quote:
Originally Posted by SamuriHL View Post

You won't with just that. You need something that displays subs in the chain. You don't have that. You can add ffdshow raw video decoder to that chain and it should work. That's what I use.

Thanks,

But how do you add the ffdshow raw audio decoder in the chain?

I have enabled raw video support in ffdshow and added it to the list of filters in MPC-HC, but it still doesn't work

I also registered vsfilter and subtitles don't work either.

All of this is in MPC-HC 3177.

Thanks.
post #89 of 581
Raw video decoder. Add it to the preferred list in the external filters screen. Open up the properties and make sure it's set to use subtitles. But, if you're using MPC-HC, I would just use MPC's subtitle renderer as the later versions work with madVR. I use ffdshow raw video decoder because I use a different player.
post #90 of 581
Quote:
Originally Posted by SamuriHL View Post

Well, he is a busy man.

So am I. Trust me.

You have no idea what my day job is.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › Lav Madvr guide??