or Connect
AVS › AVS Forum › 3D Central › 3D Tech Talk › Mits 3DA-1 stopped working on my Samsung
New Posts  All Forums:Forum Nav:

Mits 3DA-1 stopped working on my Samsung - Page 2

post #31 of 243
Thread Starter 
The reset fixed my issue. I'm not going to try it without the gefen, I have a working setup and don't want to screw anything up, but I have a feeling it would work... I am not happy about this.
post #32 of 243
The lights on the Mits adapter now show a 3D mode and can actually do side by side or top / bottom when connected to HDMI 1 or 2.
post #33 of 243
I understand, I wonder whats different with HDMI 3 on the TV?
post #34 of 243
I just verified this with another Mits box. I have a 67" Samsung DLP in my basement (HL67A750) and I first tied the Mits 3D adapter on HDMI 1 without doing the fix and the Mits box would not switch to the 3D mode. After the fix the box would switch to the 3D mode on HDMI 1. Again I have HDMI 3 modified with the EDID changed so it is identified as a Mits TV. Simply amazing!!!!
post #35 of 243
Looks like the cat is finally out of the bag!
post #36 of 243
I'm still waiting for someone to try it on HDMI 3 that has not had the EDID changed to Mitsu.
post #37 of 243
Also be interested to hear if someone has tried running it through a 1.3 hdmi avr and if they were able to get full audio as well.
post #38 of 243
Justin-Dawson,

You are the man! Just did the reset on the 3DC-1000 that I bought on EBay this past week. Was planning to purchase Powerstrip to try to get 3d working, and happened onto this thread. Great Father's Day gift, man - thanks a lot!
post #39 of 243
It worked for me on my Samsung HL61A750 that was never flashed. I had to unconnect the power cord to restablish the 3D signal from my DirecTV HR-24-500 DVR but I am now watching 3D without the Gefen HDMI Detective. I am also running the HDMI from my. DirecTV HR24-500 to my Onkyo TX-SR805 Receiver to my Samsung HL61A750. My audio is limited to 2.0 from the HDMI but I am using a Toslink to get 5.1 Dolby Digital. My system works the same way it did before except I was able to remove the Gefen HDMI Detective.

This is amazing to me as many of us have spent several hours trying to work around the EDID restrictions concerning our Samsung 3D ready DLPs when the answer was so simple. Thanks.
post #40 of 243
I just ordered a 3DA-1 from Amazon.
post #41 of 243
Good luck Larry. It'll probably work out fine. I'm glad ppl won't get ripped off like I did anymore.

What the heck can I do with this Gefen now? Anything useful?
post #42 of 243
Ill let you know how it works out. I should get it within a few days.
post #43 of 243
Patiently waiting on your results Larry

Good thing I held off spend the 500 on the 3dc-100s kit. Didnt pull the trigger because I already had enough pairs of glasses laying around. Cant wait to play some 3d PS3/360 games on my 67A750!
post #44 of 243
Quote:
Originally Posted by D_N_G View Post
Patiently waiting on your results Larry

Good thing I held off spend the 500 on the 3dc-100s kit. Didnt pull the trigger because I already had enough pairs of glasses laying around. Cant wait to play some 3d PS3/360 games on my 67A750!
I have HL67A750 and mits 3DA-1 connected to HDMI3/PC named. Did the procedures describe above and works perfect. Device build Aug2010.
post #45 of 243
That is great, Thank you to Justin-Dawson. Good job you saved a lot of people $85.
post #46 of 243
Quote:
Originally Posted by Geaux Tigers View Post
I am also running the HDMI from my. DirecTV HR24-500 to my Onkyo TX-SR805 Receiver to my Samsung HL61A750. My audio is limited to 2.0 from the HDMI but I am using a Toslink to get 5.1 Dolby Digital. My system works the same way it did before except I was able to remove the Gefen HDMI Detective.
I have the samsung version, but want to pass audio through HDMI so when I watch 2D I can enjoy lossless audio(I have a PS3 so I can't do lossless when watching 3D)
Are you sure you can only get stereo audio? The receiver should try to tell the mits box that it can take 7.1 channels (I have a 805 as well) shouldn't it. I thought for sure someone tested it would pass more than stereo when connected to certain mits TV's that better supported DD. (i'm at work so I can't check it out yet)
post #47 of 243
Quote:
Originally Posted by Geaux Tigers View Post
It worked for me on my Samsung HL61A750 that was never flashed. I had to unconnect the power cord to restablish the 3D signal from my DirecTV HR-24-500 DVR but I am now watching 3D without the Gefen HDMI Detective. I am also running the HDMI from my. DirecTV HR24-500 to my Onkyo TX-SR805 Receiver to my Samsung HL61A750. My audio is limited to 2.0 from the HDMI but I am using a Toslink to get 5.1 Dolby Digital. My system works the same way it did before except I was able to remove the Gefen HDMI Detective.

This is amazing to me as many of us have spent several hours trying to work around the EDID restrictions concerning our Samsung 3D ready DLPs when the answer was so simple. Thanks.
HOLY $hit. I I haven't been here in a long time (me and Geaux were some of the bleeding edgers)

I came back to see if I could find a cheap 3DC-100S or see if the EDID overwrite was done and what do I find? A FREAKING MIRACLE....well not really, but HOLY HELL why didn't I try this last July??? WTF

So simple, so many devices use this same defaulting method and yet here we are almost a year later and JUSTIN DAWSON finally cracked the code. I'm sure Tru3D knew this awhile ago (they aren't the bad guy here, they are a business and have to feed their families)

anyway YAHOOO!!!!! Easy Peasy ROCK AND ROLL! It works!!!
post #48 of 243
Long time for me too. Came back yesterday after basically a year just to see what was new now that things have slowed down for the summer. I remember the furious plugging and unplugging over and over for hours last summer until we finally had a workaround, albeit a huge pain, but something that worked. This just blows it all out of the water. Thank you.
post #49 of 243
Well the cat might be back in the bag. I just got my 3DA-1 from Amazon, build date is May 2011. I did the reset procedure and got the one blink, but get the "TV not compatible" error. Tried a couple more times, no go. Finally for craps and giggles I keep holding the buttons, trying to get the double blink. It never did blink a second time.

I'm hoping I'm wrong, but it looks like the latest 3DA-1 firmware does not have two reset modes, but only one: factory with Mits EDID recognition.

I'll keep fiddling with it, but I think I might be out of luck.
post #50 of 243
Oh brother mine don't get here until Friday and its a new one, I should have bought a used one. Looks like Amazon will be getting a lot of returns.
post #51 of 243
lol, wow, just wow. I'm not laughing that the cats back in the bag, but that the solution was so simple all along. The question is if the Tru3D guy who warned about EDID bricks knew this all along. It probably would have solved the dreaded Mitsu xx833 problem as well. Heh, silence is golden, literally.
post #52 of 243
What's the build date on yours ?
Maybe we can make a connection here on if its a build date firmware change OR a bricked 3DA-1 if it doesn't reset as per the listed procedure.

Quote:
Originally Posted by Justin-Dawson View Post

The reset fixed my issue. I'm not going to try it without the gefen, I have a working setup and don't want to screw anything up, but I have a feeling it would work... I am not happy about this.
post #53 of 243
Mine is a 3DC-1000 from Tru3D. Build date September 2010.

So what can I do with this unneeded Gefen now??!
post #54 of 243
Quote:
Originally Posted by FronzDan View Post

Mine is a 3DC-1000 from Tru3D. Build date September 2010.

Sow at can I do with this unneeded Gefen now??!

Well I know at least 1 person that could use it

Seriously, I'm just going to try and update my EDID now and be done with it. Got my email request for the EDID PIN into powerstrip support, hopefully get it all working tomorrow.



EDID updated, works like a champ now. Cost me the extra $30 for Powerstrip but at least its working. Hopefully other folks with the 3DA-1 have better luck than me using the reset trick.
post #55 of 243
Quote:
Originally Posted by philnerd View Post
Well I know at least 1 person that could use it

Seriously, I'm just going to try and update my EDID now and be done with it. Got my email request for the EDID PIN into powerstrip support, hopefully get it all working tomorrow.



EDID updated, works like a champ now. Cost me the extra $30 for Powerstrip but at least its working. Hopefully other folks with the 3DA-1 have better luck than me using the reset trick.
My 3DA-1 just came in from Amazon and even after the reset, I am getting the "TV not compatible" error (or what ever it says).

Edit: I guess I will be updating my EDID as well.
post #56 of 243
Quote:
Originally Posted by theenoch View Post

My 3DA-1 just came in from Amazon and even after the reset, I am getting the "TV not compatible" error (or what ever it says).

Edit: I guess I will be updating my EDID as well.

I'm getting a 11/2010 unit to try next week.
I'll post my findings with my unmodified Samsung HL61A750.
post #57 of 243
Quote:
Originally Posted by theenoch View Post

My 3DA-1 just came in from Amazon and even after the reset, I am getting the "TV not compatible" error

Well I guess that confirms it

Good luck on the EDID update, it was actually incredibly easy.
post #58 of 243
My 3DA-1 just came in and I get the same results as theenoch, it doesn't work.
This program cannot be viewed because this TV is not 3D compatible
Mine was manufactured May 2011. Now I have to find the thread on how to modify the EDID.
Looks like we were led astray most likely every one that it worked for already had their EDID modified.
post #59 of 243
Has anyone really verified that a 3DA-1 worked on an Unmodified Samsung 67a750?
What was the date of you manufacture date?
post #60 of 243
It has worked. My Samsung is unmodified and so is the OP's. Mitsubishi must have changed the firmware at some point.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: 3D Tech Talk
AVS › AVS Forum › 3D Central › 3D Tech Talk › Mits 3DA-1 stopped working on my Samsung