or Connect
New Posts  All Forums:Forum Nav:

LG ST600 Owner's Thread - Page 3

post #61 of 133
Has anyone managed to use the LG Remote app for Android (or iOS)?

It doesn't even find the ST600 in my case.
post #62 of 133
Thread Starter 
Quote:
Originally Posted by jeffschallenberg
Has anyone managed to use the LG Remote app for Android (or iOS)?

It doesn't even find the ST600 in my case.
Yes, it works. There are two LG apps so try both.

Philip
post #63 of 133
OK, thanks Philip. The LG Remote app is the one that's supposed to work with the ST600. But of course it only half works.
post #64 of 133
Thread Starter 
Quote:
Originally Posted by jeffschallenberg View Post

OK, thanks Philip. The LG Remote app is the one that's supposed to work with the ST600. But of course it only half works.

The beta firmware that Nick posted over on the Plex site finally allowed me to play a video!

Text entry is a pain. They are supposed to address that for the TV's but the status of the ST600 seems up in the air.

Philip
post #65 of 133
I bought an ST600 last week and am very pleased, so far:
  • it streams Vudu and Amazon very well. This is what I bought it for. (I used to have a Vudu box.)
  • it streams DVD rips and HDTV caps via SMB/CIFS very well. (I normally use a Dune HD Smart D1 for this.)
  • it streams BD rips well, as long as the audio is legacy DD or DTS. (It cannot handle TrueHD or DTS-MA. Ditto on Dune.)
  • it works with DLNA (Serviio) but navigation seems crippled. (I avoid DLNA in any case, since it's a pointless PITA.)
  • I have no experience of PLEX but look forward to developments.
post #66 of 133
Quote:
Originally Posted by Geokep View Post

hi i am trying to share my files from windows 7 but i can not seem to find them. the pc comes up but the shared files dont. i have done this from my XP pc and works fine. Any help some one can offer would be great.

Thanks in advance

Here are the steps:

1. Go to Network and Sharing Center
2. Go to Advanced Sharing Settings
3. Turn On: "Turn on network discovery," "Turn ON File and Printer Sharing," "Turn on sharing to anyone with network access..." "Media Streaming is On" "Use 128-bit Encryption,"

4. Next go to the folders you want to share and right click them then click on PROPERTIES.
5. Click on the Sharing tab.
6. Click on the Share button
7. Add GUEST and EVERYONE (If you only do one of them it may not work because due to recent Windows 7 update that confuses Linux based OS media players with network encryption) then click SHARE then DONE
8. Click on Advanced Sharing the click on the box next to "Share this Folder" then hit apply...

You are Good to GO!! If not... disable your computers firewall (if you have a router you don't need your PC's firewall to be up).

After doing all these steps above and still not working... restart your ST600 and PC and Router...

Good Luck!
post #67 of 133
Quote:
Originally Posted by sgvroadster View Post

Here are the steps:
. . .
"Turn on sharing to anyone with network access..."
. . .
7. Add GUEST and EVERYONE
. . .
disable your computers firewall

Yikes. I'd use a specific userid and password. Guess I'm just paranoid.
post #68 of 133
Is there a possibility to do "HDMI MIRRORING" from my Android phone, using my ST600?
Mirroring enables to present the Android phone's screen on the TV screen.

Thanks
post #69 of 133
Thread Starter 
Quote:
Originally Posted by zolom View Post

Is there a possibility to do "HDMI MIRRORING" from my Android phone, using my ST600?
Mirroring enables to present the Android phone's screen on the TV screen.

Thanks

No.

Philip
post #70 of 133
On Sunday I received an "upgrade in progress" message on my st600, but not much had changed - the Napster and 'coming soon' links disappeared, and of course flash is still at 9.10.... bummer
ST.8.79.192.F
With the latest flash version this device would be SMOKING! Everything else I am enjoying a lot...come on LG! Let's come into the present...!

S puke
post #71 of 133
Thread Starter 
Quote:
Originally Posted by soundpuke View Post

On Sunday I received an "upgrade in progress" message on my st600, but not much had changed - the Napster and 'coming soon' links disappeared, and of course flash is still at 9.10.... bummer
ST.8.79.192.F
With the latest flash version this device would be SMOKING! Everything else I am enjoying a lot...come on LG! Let's come into the present...!

S puke

Flash will never be upgraded on these types of devices. Adobe recently announced it was getting out of Flash for mobile and similar devices. In other words, Flash has no future.

Does MediaLink work with the update? I agree that this device would be great, but they have to get Plex working properly. I bought an LG Smart TV and Plex works great on it. It is not sluggish like on the st600 and plays most files. It has trouble with DTS audio and subtitle support is limited to text subs. Otherwise, very nice. LG should get its act together and make the st600 work properly.

philip
post #72 of 133
Thanks Philip for the notes...
hopefully it will be a while before Flash truly dies, after all, it seems like everything- sites/ video's / are flash enabled... it's nearly impossible to browse on this unit without seeing the dreaded "Flash 9" red flag!

Again today I received a notice for another upgrade ST.8.79.198.F
(we used to go through this for the upgrades to the LG BD550...)

Does anybody care to take a gander and do the upgrade to see if it 'fixes' or 'brakes' any items....?

S puke
post #73 of 133
Thread Starter 
Quote:
Originally Posted by soundpuke View Post

Thanks Philip for the notes...
hopefully it will be a while before Flash truly dies, after all, it seems like everything- sites/ video's / are flash enabled... it's nearly impossible to browse on this unit without seeing the dreaded "Flash 9" red flag!

Again today I received a notice for another upgrade ST.8.79.198.F
(we used to go through this for the upgrades to the LG BD550...)

Does anybody care to take a gander and do the upgrade to see if it 'fixes' or 'brakes' any items....?

S puke

I am sure flash will take a while to go away. I never use flash so I don't realize the difference. A while back I picked up an HP Touchpad when they were giving them away. The brows has flash and I really noticed a difference with sites I frequent. They had a lot more ads than I was used to. I hope it takes a long the for Flash to disappear as I really don't care for ads.

Where are you getting these updates? I am still on 901 and is says there are no new updates. Does 198 finally fix playing mkv and xvid files through MediaLink? If so then that player becomes far more interesting.

philip
post #74 of 133
Quote:
Originally Posted by pmcd View Post

Where are you getting these updates? I am still on 901 and is says there are no new updates. Does 198 finally fix playing mkv and xvid files through MediaLink? If so then that player becomes far more interesting.

philip

When I first turn on the unit a notice appears "an upgrade is available.."
If you click "cancel", once on the main screen you can still do the upgrade, look in the top left hand corner- a blue icon labeled "update".

Alternatively go to >SETUP/OTHERS/SOFTWARE/UPDATE >.

And finally today LG has the update on available on their 'Product Support' website...(click on 'Drivers and Software') --
http://www.lg.com/us/support/product...roduct-profile

To check the Flash version http://www.playerversion.com/

I don't use the 'MediaLink' but have no problems playing MKV's etc. on the ST600 thru my DLNA server.

S puke
post #75 of 133
Love it!!! I had the WD TV Live and played with it for a few days and it was okay, just okay. I had to reset it a couple of times in the 5 days I used it. So far the ST600 has been hooked up for 3 days and no issues at all and no resets at all.

The WD did not do some of the premium apps I was looking for in Canada, such as Vudu, Amazon and Hulu +, to get those apps I would have needed to buy the American version of the WD Live TV media player. I found that out from WD tech level 3. In contrast the LG in the premium apps department gives me them all, whether you are in Canada or the US. The download for the apps is separate from the firmware. As I am ISP blocking my IP address and getting the apps mentioned above with no issues at all.
So far the LG plays everything I have thrown at it, streams over my network using Windows 7 and Serviio. (Serviio is way better in my mind).

Plex does not work for me, but all the other stuff is working just fine. Plex is seen on the computer and I have added a few files but the ST600 will not play them through Plex. They play fine through Serviio on the 600. I do not really understand what plex offers me at this time. I am using Serviio as a media sever to stream my files and it does a bang up job...... So>>>>>>>>>>>
Maybe somebody here can tell me what Plex can offer me???? Plex I find complicated to use, but I have not put the time into learning how to use it as of yet, but it is definately way more complicated to use than xbmc I find.

So far so good, just wanted to give my thoughts on this product, seems like LG is going to support it....
post #76 of 133
Quote:
Originally Posted by jeffschallenberg View Post

Has anyone managed to use the LG Remote app for Android (or iOS)?

It doesn't even find the ST600 in my case.

I have and it works just fine.....
post #77 of 133
Thread Starter 
Quote:
Originally Posted by Caanda45 View Post


Plex does not work for me, but all the other stuff is working just fine. Plex is seen on the computer and I have added a few files but the ST600 will not play them through Plex. They play fine through Serviio on the 600. I do not really understand what plex offers me at this time. I am using Serviio as a media sever to stream my files and it does a bang up job...... So>>>>>>>>>>>
Maybe somebody here can tell me what Plex can offer me???? Plex I find complicated to use, but I have not put the time into learning how to use it as of yet, but it is definately way more complicated to use than xbmc I find.

So far so good, just wanted to give my thoughts on this product, seems like LG is going to support it....

To get Plex to work install the beta 901 client available at

http://forums.plexapp.com/index.php/...-new-firmware/


You will also have to install the Plex Media Server. Install it on the same system you have Serviio. The main difference with XBMC is they have separated the client part from the server. Once you play with it you will find them quite similar. I also use Serviio and Mezzmo. Nice as far as DLNA goes.

Plex on the ST600 is not perfect. Still being fixed so to speak. It is much better on their TV's. In fact I liked it so much that I bought a Smart TV from LG and got rid of most of my media players. The only ones I have left are an ATV2 running Plex and the ST600. 90% of my video watching is taken care of by the LG 55LW5600 TV. The only time I don't use it is for videos with idx/sub subtitles which Plex does not support (but XBMC does).

It should be noted that a Smart TV from LG will not be suitable for real videophiles. It does have its place as a real alternative to something like a WDTV () unless you are into subtitles and higher-end audio. The TV's from Samsung will also do but I didn't care for their active 3D and the interface was not for me. Dedicated media players are far more powerful, but they may very well find themselves in a diminishing market.

Interesting that you mention the difference between the premium apps for the WDTV and LG units. I wasn't aware of that.

If LG would fix Plex on the st600 I'd be able to recommend it. Otherwise it's pretty solid if you don't mind DLNA or smb direct access (which the TV cannot do).

philip
post #78 of 133
Quote:


You will also have to install the Plex Media Server. Install it on the same system you have Serviio.

I think I understand, I did install Plex on my PC but not the beta software, the one from the plex site. I gather there is a difference? Please explain if you can? With the beta software running can I go back to the official software if I choose and have no issues? I guess i can also play as I am still with in my 30 days with BB..lol so cruel to do that....

Also why in the hell would they put something on a product that does not work? I think that would frustrate the ordinary consumer to no end!!!!

Got plex working, interesting, I tried to do some of the online plug ins, Jerry Sinefeld and it will not play??? What is up with that, I added it and rebooted all systems and still will not play...ugh, I find this program frustrating!!!!!

Quote:


If LG would fix Plex on the st600 I'd be able to recommend it. Otherwise it's pretty solid if you don't mind DLNA or smb direct access (which the TV cannot do).

So true I agree..... Plex just does not work that well. I tried to ff and rew on a TV show..... no dice it will not work, ff and rew works fine on DLNA using serviio...really can`t see why I should work so hard on a product to get it to work. Come on LG do not be like Samsung and gives us $hitty software....ughhhhh
post #79 of 133
Thread Starter 
You can go back to the official one though the beta is better. Just put it on a USB stick.

The video channels basically don't work now in MediaLink. A few do. What works are videos, iTunes music. Probably photos but am not sure, browser.

Essentially we are talking about a small box with XBMC on it. There are very few such players. Boxee Box and Apple TV. Not exactly a lot. Otherwise you have to use an HTPC. Almost every media player has a terrible GUI. I don't know why, but that's just the way it is. Don't forget that it took PC's 11 years to get windows 95 working to have a proper interface, and that would never have happened without the Mac. People traditionally have not cared about the interface but wanted speed and impressive specs. That is no longer the case with computers but it still is the case with media players where lists are fine as long as high-end audio and video play perfectly. Look at the problems the Boxee Box has had with audio, despite having a great interface. A lot of people want to replicate the Blu-ray experience on a media player and that is the number one priority for most people here I suspect. That is why you hear Dune, PCH, ... held is such high regard despite having pathetic interfaces ( without 3rd party jukeboxes).

Philip

Edit: On the TV I can jump ahead and back in MediaLink.
post #80 of 133
Thanks Philip, I agree the beta is better it is faster and more responsive. I have downloaded and used both, I am back to the beta. I will follow the threads here and on Plex and see what transpires. I must say at this time this box meets all my needs more so than the WD which I returned. Kind of a nice surprise!!!

One other quick question does this box have a resume playback feature on the DLNA server function? Had that in the WD which is only feature I miss so far!!!! Anybody comment please, maybe I have missed it???

Thanks again Philip and others for your comments!!
post #81 of 133
Yes, @Caanda45, both the SmartShare and the Medialink players give you the choice of starting from the beginning or resuming where you left off.

And the latest non-beta firmware is .198F, but it has not fixed Plex, alas.
post #82 of 133
Quote:
Originally Posted by jeffschallenberg View Post

Yes, @Caanda45, both the SmartShare and the Medialink players give you the choice of starting from the beginning or resuming where you left off.

And the latest non-beta firmware is .198F, but it has not fixed Plex, alas.

Yes I figured that out...but with the WD you were able to shut down completely and come back to it 2 days later and it would give the option to resume or start from the beginning...the ST600 does not do that, unless i missed something in set up....LG if you are listening that would be nice to have!!!!
post #83 of 133
Hi,
I just got one here in the UK to replace my 1st generation (not networked) WD HD media player.

The good:
1) On 1st install device has self-updated.
2) Moved HDD from connected to the player to my router (getting a poor man's cifs NAS )
and mostly everything plays nicely!
3) BBC iPlayer quality excellent.
4) Can play content hosted on my macbook running Serviio (but Plex works too)
5) Android remote app works

The bad:
1) Can't use the android remote app to enter text in the youtube app. this really sucks !
2) The Smart Share panel (containing the media players) is not on the 1st screen;
it requires quite a few clicks to get to.
3) The browser scrolling is too slow to be usable.
4) No paid-content to rent movies available yet.
5) Cannot find a support forum.
post #84 of 133
Thread Starter 
The best support for the LG ST600 is over at the Plex site. In particular, you may be interested in the beta 901 firmware.

Philip
post #85 of 133
From Philip posted in a post above...plex forums....http://forums.plexapp.com/index.php/...-new-firmware/

Beta firmware but it is better than the posted firmware on LG`s Global sites...Plex forums under third party clients on the plex forums you will find the LG Smart TV information on Medialink which is Plex...imho.
post #86 of 133
Thnaks got the beta FW but really can't find any difference.
Biggest gripes are not being able to place the smart share on main screen and lack of text entry in youtube ...
post #87 of 133
My ST600 worked fine for Vudu and Amazon. SMB/CIFS and DLNA were nothing special, but did work. This was on firmware .182 (I think).

Then I decided to try MediaLink and loaded the .901 beta. I found the Plex GUI less than useful (5 thumbnails at a time? I have 1500 movies!) and got "Cannot play the media" for each one I tried.

But now the SMB/CIFS and DLNA functions are borked. Whenever I click on Movies, for example, the system either freezes or crashes outright. I have tried firmwares .187 and .198 with and without resetting. No go.

Does anyone have similar a expeience or--better--a suggestion? How about firmware .182?


Edit: Those files that won't play are all SD .mpgs with mpeg-2 video and ac-3 audio. Nothing fancy.
post #88 of 133
Thread Starter 
Quote:
Originally Posted by lsarver View Post

My ST600 worked fine for Vudu and Amazon. SMB/CIFS and DLNA were nothing special, but did work. This was on firmware .182 (I think).

Then I decided to try MediaLink and loaded the .901 beta. I found the Plex GUI less than useful (5 thumbnails at a time? I have 1500 movies!) and got "Cannot play the media" for each one I tried.

But now the SMB/CIFS and DLNA functions are borked. Whenever I click on Movies, for example, the system either freezes or crashes outright. I have tried firmwares .187 and .198 with and without resetting. No go.

Does anyone have similar a expeience or--better--a suggestion? How about firmware .182?

Edit: Those files that won't play are all SD .mpgs with mpeg-2 video and ac-3 audio. Nothing fancy.

Are you sure you used the right beta? 901f I think. SMB and DLNA work with it as will mkv containers with h.264, etc ... The cannot play the media was with some other firmware. In any case you can go back to other firmware.

With Plex you can filter your selection to just added, recent, and so on .... It will handle libraries of your size. I must be missing something but I see far more than 5 posters at a time. More like 20 or more.

182 was the one that fixed some mkv issues, but 901f is better for those.

You can reset the st600 and try the 901 beta. 198 does not contain the Plex fixes.

Philip
post #89 of 133
Quote:
Originally Posted by pmcd View Post

Are you sure you used the right beta? 901f I think. SMB and DLNA work with it as will mkv containers with h.264, etc ... The cannot play the media was with some other firmware.

Yes, 901f. I have just .mpg and .m2ts and they do not play. Plex only ever played one, but without sound. SMB and DLNA no longer work, at all---that was the point of my post. Do you think I imagined this?

Quote:


In any case you can go back to other firmware.

I have, without improvement. No network function at all. It just crashes.

Quote:


With Plex you can filter your selection to just added, recent, and so on .... It will handle libraries of your size. I must be missing something but I see far more than 5 posters at a time. More like 20 or more.

I see only a handful. Most of the screen is occupied by metadata and synopses, which should not be presented at the top level.

. . .

Quote:


You can reset the st600 and try the 901 beta. 198 does not contain the Plex fixes.

I guess you missed the point that I've tried all this--without effect.

--------------

Sorry if I sound testy, but I've already covered all of this. Perhaps it needs service.

In any case, I really don't care at all about Plex--I normally stream with a Dune Smart D1 or HTPC/XBMC--but was simply curious. I don't need the SMB or DLNA functions of the ST600 either--I bought it for Vudu and Amazon--but am annoyed to have lost them without gaining anything.
post #90 of 133
Quote:
Originally Posted by lsarver View Post

Yes, 901f. I have just .mpg and .m2ts and they do not play. Plex only ever played one, but without sound. SMB and DLNA no longer work, at all---that was the point of my post. Do you think I imagined this?


I have, without improvement. No network function at all. It just crashes.


I see only a handful. Most of the screen is occupied by metadata and synopses, which should not be presented at the top level.

. . .


I guess you missed the point that I've tried all this--without effect.

--------------

Sorry if I sound testy, but I've already covered all of this. Perhaps it needs service.

In any case, I really don't care at all about Plex--I normally stream with a Dune Smart D1 or HTPC/XBMC--but was simply curious. I don't need the SMB or DLNA functions of the ST600 either--I bought it for Vudu and Amazon--but am annoyed to have lost them without gaining anything.

I would re do the firmware either the .901 or the latest off the USA or Canadian site (sorry did not see where you are from) and re set it. Plex is really a piece of **** in my mind, can never get it to work properly and I find it just takes way to much work to learn how to work it. I also discovered that it plays havoc (plex that is) with my torrent client when it is on and updates the meta data and I am downloading, I get torrent error......ugh it just is to much work...plex

I have no issues with the unit otherwise, dlna serving using serviio this little box is a champ, I also block my IP address and use a service to get American Netflix and other US sites on this box with no issues!!!
New Posts  All Forums:Forum Nav:
  Return Home