or Connect
AVS › AVS Forum › Video Components › Video Processors › iScan 50 power adaptor died?
New Posts  All Forums:Forum Nav:

iScan 50 power adaptor died?

post #1 of 4
Thread Starter 
I have an iScan 50 and the Universal 6V@7A AC-to-DC Power Converter stopped working. I can't find one using about every possible google search. Tried a universal but it doesn't seem to have enough amperage to cut on.

Does anyone have an idea or lead or any other info?
post #2 of 4
Best choice is to contact DVDO, same thing happened to me years ago and they will send you a new one, for a price.
post #3 of 4
Thread Starter 
Quote:
Originally Posted by gmanhdtv View Post

Best choice is to contact DVDO...for a price.

This is the scary part because I bet is is a PRICE. Did find the OEM and it's CUI, Inc. with a model number 3A-501DN06. I have an email into them both and now for a little crying.

I just bought a new preamp and did a full breakdown and re-hookup and can't fully test or enjoy. Also I'm buying a new projector next month and only need the iScan until then.

....and the power supply goes out now. Why could this have happened 6 months or a year ago?
post #4 of 4
Quote:
Originally Posted by William View Post

I have an iScan 50 and the Universal 6V@7A AC-to-DC Power Converter stopped working. I can't find one using about every possible google search. Tried a universal but it doesn't seem to have enough amperage to cut on.

Does anyone have an idea or lead or any other info?

Go to ebay and search for "UNIVPOWER SB-067A0F-11" $26.99 plus shipping.

It took 2 weeks for the unit to show up. My VP50 is still working after a month.

Same power supply from Simplay Labs cost $69 plus Fedex shipping, much more $. Good Luck.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Video Processors
AVS › AVS Forum › Video Components › Video Processors › iScan 50 power adaptor died?