or Connect
AVS › AVS Forum › Display Devices › Plasma Flat Panel Displays › 10 Blinks - Bad Power Supply? Panasonic Viera
New Posts  All Forums:Forum Nav:

10 Blinks - Bad Power Supply? Panasonic Viera

post #1 of 13
Thread Starter 
Specs: Panasonic Viera TH-46PZ85U 46-Inch 1080p Plasma HDTV
Purchased: September 2009 (1 year warranty - expired)
Date of Death: July 2011 (less than 2 years after purchase)
Diagnostics: 10 Blinking Lights
**Part I Think I Need**: ETX2MM704MGU

Hey all, I'm really trying to figure out the specific part I need to fix my Panasonic. I've tried unplugging my HDMI cables, resetting the TV, plugging the TV into the wall outlets and surge protector, and leaving it off for days at a time. The first time I encountered the 10 blinking lights, I simply plugged the TV from the surge protector to the wall and it worked again. Then the 10 blinking lights became a regular annoyance the following days...until it completely died. It won't turn on anymore, no matter what I attempt to do. From what I've read on these forums is - I have a bad power supply. Others swear that the 10 blinks could mean MANY different problems within the TV - from capacitors to the A-Board to who knows. I want to purchase the part for cheap online and try to find cheap labor so I don't get a bombarded with a 400+ dollar labor fee to fix a 2 year old TV. Thanks for ANY help!
post #2 of 13
I'm not sure about what would fix your issue, but I can attest that your PZ85U isn't that great of a plasma. I'd personally pass on trying to fix it, the 85U just isn't very remarkable in any respect... You ought to try searching the Electroncs section of your local Craiglist for used TVs, or just buy new The newer color accuracy, and black levels of recent plasmas' will definitely blow your mind.
post #3 of 13
If you like your TV, then it may be worthwhile to try replacement boards.

According to the part number you gave, you appear to have the TH-46PZ85UA model. There is a good chance it is the main power supply that is defective, but there are 2 power supplies in your TV. Finding the right part inexpensively might be difficult.

If you do have the TH-46PZ85U model instead, there is a ETX2MM704MGA board on eBay for under $50.

But it could be another board that is defective also. It's a gamble either way.
post #4 of 13
Thread Starter 
Thanks for the reply. I just double checked the model number on the back of my set and it is indeed the TH-46PZ85U. Just one more addition - when I do try to plug in the set, I hear 3 clicks. It goes click, click, ... click. I'm guessing the circuit is shorted. I'm tempted to just go forth and purchase the board, but I don't want to buy something I don't need. Thx again.
post #5 of 13
Quote:
Originally Posted by jeffo2448 View Post

Thanks for the reply. I just double checked the model number on the back of my set and it is indeed the TH-46PZ85U. Just one more addition - when I do try to plug in the set, I hear 3 clicks. It goes click, click, ... click. I'm guessing the circuit is shorted. I'm tempted to just go forth and purchase the board, but I don't want to buy something I don't need. Thx again.

It's hard to know. There could be a short somewhere else and it's triggering auto-shutdown to prevent damage. I would call Panasonic and see what they say they think it sounds like (or if you know a repair place that will tell you the info you need w/o being d'bags and telling you that you need to bring it in and pay them just to look at it).
post #6 of 13
Quote:
Originally Posted by dlplover View Post

It's hard to know. There could be a short somewhere else and it's triggering auto-shutdown to prevent damage. I would call Panasonic and see what they say they think it sounds like (or if you know a repair place that will tell you the info you need w/o being d'bags and telling you that you need to bring it in and pay them just to look at it).

If you fix it, let me know what you bought I'm having the same exact problem with my 50" version.
post #7 of 13
Quote:
Originally Posted by startny View Post

I have the Fix for the Panasonic 2 blinks error and also the 10 blinks fix ... I cannot give you the fix in this public forum because its a business for us.

For those who would like to repair it themselves, please look starting at this post.
post #8 of 13
What tomwil said.
post #9 of 13
I have the same problem with my TH-46PZ85U. Previously when you turned the unit on either via the power button, there were two separate and distinct clicks. Now there are origional two clicks, a short pause, then the third click. At this time the power light button blinks 10 times, pauses and repeats.

I had read that the three 220v 900 MDF power supply capacitors might be bad. This could be verfied if the top of the capicators were convex (domed as if swollen). Mine were so I replaced all three. Easy to desolder and solder in the new ones (making sure of the correct polairty), but not so easy to remove the seemingly 100 or so screws to get the board out.

Unfortunatley, this did not address the problem, as I still have the 3 clicks of death, followed by the 10 blinks of death. Now I am reading that there may be another power supply board or a 1 MDF capacitor on a sub-board that is fault producing. I dont mind putting a hundred bucks or so into self repairs for this $1,000 three year old TV, so if anyone can give a definitive answer as to the cause and/or has successfully repaired their unit, it would be appreciated.

As an aside, I bought the capacitors from Mouser Electronics (www.mouser.com), and I have no affiliation or financial interest with that company.
post #10 of 13
I have a TC-50PS14 and I heard a pop and my TV went out. I looked online and discovered that my YSUSTAIN Board went out (TNPA4782AB). At first I could not see an issue with any of the capacitors until further inspection I found a small rectangular component next to an aluminum cooling panel had blown. I had purchased a new board and replaced it, but now I am getting 10 blinks. I am getting different info online saying it's the power supply and another saying it is an A-board where I connect the HDMI and cable to. I would like to replace the part, but I'm not sure which one, and if that is the culprit as to why my YSUSTAIN Board blew. Can someone help? I find it hard to get rid of the TV if only a board needs replacing.
post #11 of 13
Quote:
Originally Posted by salba View Post

I have a TC-50PS14. I am getting 10 blinks.

This document, pages 30-31, might be of some help.
post #12 of 13
Did you find a solution to your 10 blinking lights?
I replaced both the power board (P board) and the A board (input board) with not luck.

thanks
post #13 of 13
Hi...
I just wanted to substantiate the post by tomwil below for replacing a bad 1uF capacitor ==> http://www.avsforum.com/t/1001318/master-thread-for-panasonic-plasma-not-turning-on/1110#post_2080299.
My wife found a Panisonc TH-46PZ85U for free on Craigslist, with the 10 blink symptom. We replaced the capacitor on both similar boards (only 1 seemed to read as a high impedance short - but just for good measure I did both) and viola - we have a working 46" plasma TV.. Thanks so much for the info...
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Plasma Flat Panel Displays
AVS › AVS Forum › Display Devices › Plasma Flat Panel Displays › 10 Blinks - Bad Power Supply? Panasonic Viera