or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › Intel Integrated HD Graphics Black Level Setting
New Posts  All Forums:Forum Nav:

Intel Integrated HD Graphics Black Level Setting

post #1 of 98
Thread Starter 
For some reason I can't get the black level set on my Intel i5 integrated graphics to stick to Full. It keeps reverting back to Limited under the Quantization setting.

I've tried two different versions of the driver. Is this thing broken or is it just my system (Onkyo TX-805 and Panny Plasma)?

I've got an Nvidia 430 that I could dust off, but I'd rather just use what is built in if I can get it to work. I'm just seeing crushed blacks and realized that it keeps reverting back to Limited. My Nvidia card never did that.
post #2 of 98
Thread Starter 
So my system is the only one that will not save the black level setting of Full?
post #3 of 98
Ah, I don't think so! I've got the exact same issue that has driven me to buy an NVIDIA card to get around it.

I was using the Intel HD Graphics HDMI output to connect to a Samsung C8700 LCD tv. Worked fine, except for the problematic playback of '24Hz' blueray stuff (which is hardware related, can't be dealt with) and the issue you describe. The quantization level setting in the dialog does not stick. Each time I change resolution setting, display frequency, reboot or do a suspend-to-ram/resume cycle, the setting reverts back to 'limited'.

When it is set at 'limited', my tv set shows significant 'banding' in gradients, especially in darker areas. It isn't pretty! When I switch it to 'full' the banding is greatly reduced.

I've tried this also under a user account that has windows administrator rights, as I thought this might have something to do with access rights, but the dialog setting would not stick then either.

I would very much like this issue to be fixed, as I would rather again just use the built in graphics: my HTPC is now using almost twice the amount of electric power, with the associated added heat, fan noise...

I've reported this on an Intel forum, but so far no official word from Intel.
post #4 of 98
Quote:
Originally Posted by bryansj View Post
So my system is the only one that will not save the black level setting of Full?
I think not.

I suspect I have the same issue with my i3 2100.

Stupid question but were do I find the "Quantization setting"?
post #5 of 98
Thread Starter 
Quote:
Originally Posted by AFryia View Post
I think not.

I suspect I have the same issue with my i3 2100.

Stupid question but were do I find the "Quantization setting"?
Graphics Properties / Advanced Mode then Display / Monitor/TV Settings.

There is a Quantization Range setting for Limited and Full.
post #6 of 98
Quote:
Originally Posted by bryansj View Post

For some reason I can't get the black level set on my Intel i5 integrated graphics to stick to Full. It keeps reverting back to Limited under the Quantization setting.

I've tried two different versions of the driver. Is this thing broken or is it just my system (Onkyo TX-805 and Panny Plasma)?

I've got an Nvidia 430 that I could dust off, but I'd rather just use what is built in if I can get it to work. I'm just seeing crushed blacks and realized that it keeps reverting back to Limited. My Nvidia card never did that.

You are not alone. I finally gave up and put my ATI card in the machine to get correct color space.
post #7 of 98
Thread Starter 
I guess I could put my Nvidia 430 in until they sort out their driver issue.

My new HTPC was build around having minimal hardware and being quiet with all the storage and other tasks offloaded to my new server. The server is the guts out of my old HTPC and the Nvidia card was left behind since I didn't think it was needed, until now.
post #8 of 98
Quote:
Originally Posted by bryansj View Post

Graphics Properties / Advanced Mode then Display / Monitor/TV Settings.

There is a Quantization Range setting for Limited and Full.

The "Quantization" setting does not show up on my i3 HD2000 Intel control panel, nor does the "IT" control.



All I see is "Monitor/TV settings not supported". The control panels does identify my SONY IFB DVI input card on my projector on other screens.

To see the BTB data I had to override application settings and bump Brightness from default 0 to ~12. My fear is this work around is compromising the video quality. Never had this issue with my ATI DVI card.

post #9 of 98
I have the same issue with an I3-2100. It won't stick at Full.
post #10 of 98
same here
i5-2500k, it won't stick at full
post #11 of 98
Thread Starter 
I've got my Nvidia 430 ready for when I get my Ceton this week. If I can't find a fix by the time I crack open my case then I'll pop in the 430 at the same time.
post #12 of 98
I have an Intel i3-530 and have been using an older version of the graphics driver because black levels seemed to vary with the newer versions. I recently upgraded and everything was fine until I reboot my system...it seemed a bit dark. All my settings were still the same and that's when I saw this thread.

The quantization setting must be new since I never saw it in my older driver version. In the past versions I would have problems with my xvYCC setting becoming unselected whenever I switched inputs on my receiver. Now it sticks with the latest driver but this quantization setting won't stick. I guess I will complain to tech support and see how far that will go.
post #13 of 98
I have been experiencing the same issue with my i3 2100 build . It is frustrating.
I am using a small Rosewell case with a 150 watt power supply. Are there any low wattage video cards that would work well?
I may have to reinstall in a bigger case and larger power supply. Does anyone have suggestions for a budget high quality video card for 1080p playback?
Thanks!
post #14 of 98
Quote:
Originally Posted by Alan Winslow View Post

I have been experiencing the same issue with my i3 2100 build . It is frustrating.
I am using a small Rosewell case with a 150 watt power supply. Are there any low wattage video cards that would work well?
I may have to reinstall in a bigger case and larger power supply. Does anyone have suggestions for a budget high quality video card for 1080p playback?
Thanks!

The fanless 5450 cards use about 20 watts at peak and 3 watts at idle.
post #15 of 98
Assassin, Thank you for the quick response. I am using the Rosewill RC-CIX-01, Have you used a 5450 in any of your builds? How does the 1080P video quality compare to the Intel? Are there other higher quality cards for comparison out there that would fit the case regarding size and power draw.
I really appreciate your help.
post #16 of 98
Quote:
Originally Posted by Alan Winslow View Post

Assassin, Thank you for the quick response. I am using the Rosewill RC-CIX-01, Have you used a 5450 in any of your builds? How does the 1080P video quality compare to the Intel? Are there other higher quality cards for comparison out there that would fit the case regarding size and power draw.
I really appreciate your help.

Alan - Personally I like the Intel better mainly because the ATI driver were absolutely abysmal with my particular setup. NVidia was a little better but nowhere near as stable as the Intel drivers. Other have no issues at all with ATI or NVidia. So ymmv.

Picture quality honestly was about the same on all 3 subjectively.
post #17 of 98
Assasin, Maybe I'll sit tight and see if they come out with a driver update. I'll just change the setting in the Intel HD Panel setup each time turning the computer on. It will hold for a movie but reset itself each time I turn the computer back on. It has been a great HTPC.
Thank you for the help.
post #18 of 98
Same issue with my Intel I5 processor graphics. Nothing happens after setting "Quantization" to "Full". After reboot it reverts to "Limited". Black level depth considerably reduced.

New driver version 15.22.50.64.2509 released 7 September still not fixes this bug.
post #19 of 98
Thread Starter 
Every time I see this thread bumped I hope that the last post has a fix...
post #20 of 98
Driver version 15.22.50.64.2509 did not fix it for me. It will sometimes stay set for an entire power state. However, any resolution change (Desktop vs 7MC) will cause it to revert to limited (yes, I had set the two differently in an attempt to fix another issue).
post #21 of 98
Quote:
Originally Posted by shortcut3d View Post

Driver version 15.22.50.64.2509 did not fix it for me. It will sometimes stay set for an entire power state. However, any resolution change (Desktop vs 7MC) will cause it to revert to limited (yes, I had set the two differently in an attempt to fix another issue).

When you set it to "Full", do you see visible changes? It seems that two issues are reported in this thread:
  1. Full quantization doesn't work (remains limited after setting it to Full). After reboot quantization setting resets to Limited. (My case)
  2. Full quantization works, but after reboot quantization setting resets to Limited.

So, is your case #2? I am just curious to know whether someone managed to see full rgb range signal from intel hd graphics.
post #22 of 98
i think i found a workaround. it worked for me, at least.

system specs: celeron g540, msi h67 mb, asus ml239h monitor (native resolution 1920x1080), latest intel hd graphics drivers (build 2509).

my motherboard has vga and dvi-i outputs, and my monitor has vga and hdmi inputs. i'm using the dvi to hdmi cable the monitor came with.

the problem: the graphics driver detects the monitor as a 'digital television', and sets the quantization range to 'limited', resulting in blacks that are dark grey and whites that are light grey. changing the option in the pulldown doesn't have any effect.

playing around with the resolutions a bit, i noticed that the limited range only occurred at certain resolutions. if you set the windows background color to black and scaling to 'center', you can immediately see which resolutions have this problem when you switch to them (the border would be the monitor/tv's true black and the windows desktop would be a lighter shade).

the solution that worked for me was to create custom resolutions to override the ones which have the problem.

i only use my monitor at 1920x1080, but this happened to be one of the problematic resolutions, so i created custom resolutions of 1920x1080, all color depths, and at both 59hz and 60hz (both of these appeared as acceptable refresh rates for my monitor, although windows defaulted to 59hz. i really didn't need to create the 60hz custom resolution). this resulted in a total of 6 custom resolutions. it warned that this custom resolution already exists (it didn't, but what it probably meant was that the new custom resolution would override a standard resolution), but i said yes to overwrite.

after rebooting, blacks were black and whites were white. confirmed this with calibration - before the custom resolution, the monitor calibrated to 120 cd/m2 luminance and a .5 black point. afterwards, it calibrated to 140 cd/m2 luminance and a .2 black point with the monitor settings untouched.

the quantization range now shows 'default' instead of 'limited'. however, changing it still has no effect, so if you need to change the range on a regular basis, this fix won't really do much.

hope this helps.
post #23 of 98
Thread Starter 
So you basically created a custom resolution that was the same as the standard one that you were already using?

I'll try that when I get home this evening.
post #24 of 98
Interesting... implies that the driver is assuming "all digital televisions MUST be limited quantization", but that digital monitors (again, an assumption on the part of the drivers that a custom resolution will be done on non-TV equipment) are permitted to have full quant.
post #25 of 98
Quote:
Originally Posted by sacrebleu View Post

i think i found a workaround. it worked for me, at least.

...the solution that worked for me was to create custom resolutions to override the ones which have the problem.

hope this helps.

It works!!! Thank you very much!
post #26 of 98
Tried it at 1920x1080, 59Hz, all color depths and got a "not supported" reading on my HDTV screen.

I chose this first because that is what was set at default.

Restarted in safe mode and changed to 1920x1080, 60Hz, all color depths.

Working now. Works great.
post #27 of 98
Thread Starter 
I think mine works too, but I'm still testing with reboots and such. I also had to do the safe mode thing to change my refresh rate. I think I had to go from 60 to 59.
post #28 of 98
I'm still testing too.
post #29 of 98
That custom setting worked. Thanks!!

It does revert back though when i turn of my tv or restart the computer :/
post #30 of 98
I had this problem, too.

With version 8.15.10.2509 of the Intel graphics drivers, I'm able to set a custom resolution for 1920x1080, 32 bit, 60Hz, and change the Quantization Range to "Full."

That seems to fix the problem, and it keeps the settings after turning the monitor off or rebooting, though after rebooting the Quantization Range is "Default" instead of "Full." At least it's not "Limited" and it's still working properly.

After upgrading the Intel graphics drivers to 8.15.10.2559, however, it stopped working properly. The resolution would constantly revert back to 59Hz, and the Quantization Range would revert back to Limited when turning the monitor off & on or rebooting. Even before turning the monitor off, the Full setting had no effect.

So I reverted the Intel graphics drivers back to 8.15.10.2509, and all is fine again.

For what it's worth, I'm using a i7 2600K cpu and an Intel DH67CFB3 mini-itx motherboard.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › Intel Integrated HD Graphics Black Level Setting