or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Integra receiver center channel problem
New Posts  All Forums:Forum Nav:

Integra receiver center channel problem

post #1 of 2
Thread Starter 
I have a client whose Integra (I think 50.2, but its probably irrelevant) plays the center channel through all the speakers except the center channel. I know this because when I played the speaker level test tones, all of the speakers played the tone correctly, except the center which played through the other 4 speakers.

I'm sure the answer is, "it's a blown amp, call Integra CS for a replacement," but I just wanted to see if anyone had run across this same problem, and if there is something I can look for myself.

Thanks for the input!
post #2 of 2
Quote:
Originally Posted by aweeks77 View Post

I have a client whose Integra (I think 50.2, but its probably irrelevant) plays the center channel through all the speakers except the center channel. I know this because when I played the speaker level test tones, all of the speakers played the tone correctly, except the center which played through the other 4 speakers.

I'm sure the answer is, "it's a blown amp, call Integra CS for a replacement," but I just wanted to see if anyone had run across this same problem, and if there is something I can look for myself.

Thanks for the input!

Let me get this right. You're saying that when you attempt to play the test tone through the center speaker the tone emits from the other four speakers instead?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Integra receiver center channel problem