or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › Advanced MPC-HC Setup Guide
New Posts  All Forums:Forum Nav:

Advanced MPC-HC Setup Guide - Page 13

post #361 of 2890
Quote:
Originally Posted by renethx View Post

rica, for me this is very confusing. WaveOut means that ReClock chooses *WASAPI shared mode* so that LPCM audio streams are subject to resampling by Windows Audio Engine. ReClock tells "Audio: WaveOut (bit exact)", but this simply means ReClock does not resample. Windows Audio Engine still does. But if this is what you intend, that's OK.

Yes you are right. When we select waveout, windows' mixer touches the audio.
So you have to select Wasapi and 24 bit padded to 32 bit for real bitexact streaming. Sorry for the confusion i made.

Thanks for the caution.

EDIT: My latest post including false information will be modified tomorrow.
post #362 of 2890
nand chan proposed WASAPI exclusive mode without media adaptation for PCM audio streams. Here (I found it in his post at Doom9's Forum).

OK, rica also proposed it. Sorry.

I wish there were a simple audio renderer that supports WASAPI exclusive/shared modes selection.
post #363 of 2890
Quote:
Originally Posted by InfernoSplash View Post

Renethx, I've been having issues with reclock. I followed the http://forum.doom9.org/showthread.ph...20#post1534720 but I get this error when trying to watch mkv's with flac.

The audio format is not supported by the hardware / driver:
48000 samples/sec
24 bit PCM
6 channels

I am using madvr, madflac, lav, and mpc-hc. Is there anyway I can get this to work? I've been trying everything and reading all over and finally decided to post the question. Thank you for your help.

As you use stereo TV speaker, use ffdshow Audio Decoder instead of madFlac to downmix multichannel LPCM to stereo. Then select: ReClock Configuration > Audio Settings > PCM Ouput > Format: 24 bit int padded 32.

The purpose of using ReClock in WASAPI exclusive mode in your case is not get so-called "bit perfect" or "bit exact" sound, but just bypass Windows Audio Engine. Low volume problem is likely caused by Windows Audio Engine. For example, look at the thread

Why do my MKVs with FLAC have low volume?

With ReClock the problem was fixed:

Quote:
Originally Posted by Gabuk View Post

That setup works great now. I can continue to create MKVs as FLAC and not have low-volume issues.

BTW converting TrueHD/DTS-HD MA to FLAC is not recommended any longer. Just keep TrueHD/DTS-HD MA intact and decode them by LAV Audio Decoder (+dtsdecoderdll.dll) only when necessary.
post #364 of 2890
Quote:
Originally Posted by renethx View Post

nand chan proposed WASAPI exclusive mode without media adaptation for PCM audio streams. Here (I found it in his post at Doom9's Forum).

Code:
Audio: WASAPI excl. (bit exact)
So neither ReClock nor Windows Audio Engine resamples, i.e. true bit perfect. Three points:

In ReClock Configuration

- Select Audio Interface to use for PCM: "WASAPI Exclusive".

In ReClock Properties

- Check: Clocks correction > "Slave reference clock to audio (debugging only)"
- Select: Media adaptation > Speed: "Original speed" and check "Locked" (otherwise next time ReClock is loaded, "Audo (best)" will be restored).

I wish there were a simple audio renderer that supports WASAPI exclusive/shared modes selection.

OK, you may find out my very earlier advices at slysoft forums and doom9.

This is not new for me but this f*** pcm test with different decoders made me confused by mistake.

What can i say?
No i wasn't drunk btw.
post #365 of 2890
Quote:
Originally Posted by ricabullah View Post

So you have to select Wasapi and 24 bit padded to 32 bit for real bitexact streaming.

Nope
bit exact = same as source
speed adaptation = sound processing and conversion to the higher supported bit depth (24 padded to 32) after that
post #366 of 2890
rene, btw i found this post and pls check out the date of the post (02.09.2009) and the last SS here:

http://www.avsforum.com/avs-vb/showthread.php?t=1118204
post #367 of 2890
Yup, I missed your post. sorry for that.

ffdshow sends 24-bit output only when either only "24 bit integer" or "24-bit integer"+"32-bit floating point" is selected. I tested it a long time ago in this post. LAV Audio Decoder is better in this regard.
post #368 of 2890
Quote:
Originally Posted by renethx View Post

Yup, I missed your post. sorry for that.

ffdshow sends 24-bit output only when either only "24 bit integer" or "24-bit integer"+"32-bit floating point" is selected. I tested it a long time ago in this post. LAV Audio Decoder is better in this regard.

Confirmed. I compared them too as you know.
post #369 of 2890
Hi,

Thanks for this guide, just worked my way through it on a flat install of Win7-64bit without too much hassle

I have a few questions, I seem to be getting a minor pause/jitter mostly during motion which I want to confirm is the card's GPU peaking, the spec of my system is:-

Intel E8500 (3.16Ghz) dual core
4Gb DDR2
NVIDIA 8500GT DDR2 512MB (passively cooled)

During an mkv playback I can see with GPU-Z (v0.5.5) that GPU load hovers round 88-92% but it never reaches 100%, am I right in thinking the pause/jitter is a result of the GPU running out of juice?

The playback PQ with theses settings even with the pause/jitter is awesome, I have'nt experienced anything like it before, I cant wait to see the results on a bigger screen but I can see I will need a better gfx card thou, hopefully I can tweak out the pause/jitter...

Hope someone can help,

Thanks,
ManC

PS: Will try and post the GPU-Z screengrab.
post #370 of 2890
Thread Starter 
set the various scaling to bilinear in madvr and try again.
post #371 of 2890
Thread Starter 
Quote:
Originally Posted by renethx View Post

Yup, I missed your post. sorry for that.

ffdshow sends 24-bit output only when either only "24 bit integer" or "24-bit integer"+"32-bit floating point" is selected. I tested it a long time ago in this post. LAV Audio Decoder is better in this regard.

ffdshow audio processor can pass through 24 bit audio untouched if the mixer is unchecked.

and ofc, 24 bit has to be enabled as an output format.
post #372 of 2890
Quote:
Originally Posted by MlNDBOMB View Post

ffdshow audio processor can pass through 24 bit audio untouched if the mixer is unchecked.

and ofc, 24 bit has to be enabled as an output format.

Even configuration of both decoders is similar, lav audio always select the right bit while ffdshow always need to be ticked appropriate to the original file's bit to pass it as it is:



When i send the same audio over both decoders, lav audio selects it as is (24 bit) while ffdshow selects it as 32 bit.
post #373 of 2890
Thread Starter 
yea, lav audio doesnt have a mixer.

uncheck mixer in ffdshow and see what happens
post #374 of 2890
Quote:
Originally Posted by MlNDBOMB View Post

yea, lav audio doesnt have a mixer.

uncheck mixer in ffdshow and see what happens

Do me a favor and tell me where it is?
post #375 of 2890
I think it's here, is it?



_ _ _
post #376 of 2890
Quote:
Originally Posted by MlNDBOMB View Post

yea, lav audio doesnt have a mixer.

uncheck mixer in ffdshow and see what happens

If so, i unchecked it and nothing happened; i see still 32 bit instead of 24.
post #377 of 2890
Thread Starter 
oh, ok, thats interesting.

what format were you playing? 24 bit flac?
post #378 of 2890
Quote:
Originally Posted by MlNDBOMB View Post

ffdshow audio processor can pass through 24 bit audio untouched if the mixer is unchecked.

and ofc, 24 bit has to be enabled as an output format.

I guess rica and I are not talking about "Mixer" ("Mixer" is always turned off; even if it is on, that won't affect output bit-depth) but "Output" > "Output format for uncompressed or decoded streams".

I guess rica and I are using 24 bit input and are concerned with relation between "Output format for uncompressed or decoded streams" and output bit-depth. So you can use any input audio format, LPCM, FLAC, or TrueHD (or any format ffdshow audio decoder can decode). Sample rate won't change unless you turn on "Resample". A summary is here.

"Output format for uncompressed or decoded streams" Output
16 bit 16 bit
24 bit 24 bit
32 bit 32 bit
32 bit float 32 bit float
16 bit, 24 bit 16 bit
16 bit, 32 bit 32 bit
16 bit, 32 bit float 16 bit
24 bit, 32 bit 32 bit
24 bit, 32 bit float 24 bit
32 bit, 32 bit float 32 bit
16 bit, 24 bit, 32 bit 32 bit
16 bit, 24 bit, 32 bit float 16 bit
16 bit, 32 bit, 32 bit float 32 bit
24 bit, 32 bit, 32 bit float 32 bit
16 bit, 24 bit, 32 bit, 32 bit float 32 bit

If you use a different input bit-depth, you will get different results. In general you'd better check all four bit-depth (16, 24, 32, 32 float), otherwise audio could be crippled. (Unfortunately I often see poor instructions.)
post #379 of 2890
Quote:
Originally Posted by MlNDBOMB View Post

set the various scaling to bilinear in madvr and try again.

Ah, should of thought of that myself as there is referance to it within you guide , will give it a bash this evening and let you know what happens. By switching to bilinear within madvr will I get a poorer quality image?

Below is a screengrab of gpu-z busy!

post #380 of 2890
Problem solved.
post #381 of 2890
Rene explained very well.

You can compare ffdshow and lavaudio with these sample files i'm adding:

96_24 flac mkv:

http://www.mediafire.com/?u0dh194e0q74tyt


96_24 pcm mkv:

http://www.mediafire.com/?het2xcoug60hvni
post #382 of 2890
Question....when upgrading all of these different pieces, (MPC, lav, madvr) what is the best method of doing this? Should I delete the existing programs or will all of these install over the top of what is already on my machine?
post #383 of 2890
Quote:
Originally Posted by JDz View Post

Question....when upgrading all of these different pieces, (MPC, lav, madvr) what is the best method of doing this? Should I delete the existing programs or will all of these install over the top of what is already on my machine?

Keep your all existing SW, no matter at all.
post #384 of 2890
which is the best way to verify that the exported video stream is de-interlaced
properly to 50p/60p and not 25p/30p?
post #385 of 2890
Hi,
Thank you for the brilliant guide. However I have an issue.

Every few seconds the video stutters and my CPU spikes. My hardware is:
Q9550 @ 2.83ghz
8gb ddr2 memory
ATI 5850
intel X-25m SSD (160gb)

I have only things described in this guide installed - no further codec packs.

I have tried with and without ffdshow deinterlacing. I have tried using madvr 'trade quality for performance' none of it made any difference at all.

this happens on both mkvs and mpg files I have tried (more so on the mkvs though)
is my hardware not good enough to run this smoothly? Or am I missing something else? Any other data I can get to see what is causing the spikes?

Thanks in advance

P.S. I just used GPU-Z to determine if the GPU was overloaded at all at it tells me GPU Load is at 0%. So it looks like nothing is being offloaded to it, how come?
post #386 of 2890
Quote:
Originally Posted by Tony_Montana View Post

which is the best way to verify that the exported video stream is de-interlaced
properly to 50p/60p and not 25p/30p?

"Statistics" of MPC HomeCinema tells frame rate and the number of frames drawn. In the screenshot below (Die Zauberflote (2003) [2 min SD video MKV].mkv [480i60, MPEG-2, AC3], LAV Source Splitter+LAV Video Decoder+madVR), the frame rate is ~30fps, the number of frames drawn = 1760 ~ (30fps) x (60s) = 1800fps.

(Edge enhancement by AMD post-processor is too strong. )

Or you can see difference between 30fps and 60fps immediately with this clip: La Traviata (2010) [2 min HD i video MKV].mkv (1080i60, AVC, DTS-HD MA).
LL
post #387 of 2890
Quote:
Originally Posted by Tony_Montana View Post

which is the best way to verify that the exported video stream is de-interlaced properly to 50p/60p and not 25p/30p?

MPC OSD stats, EVR CP stats. Note after proper IVTC from 29i telecined source you got 23p out.
post #388 of 2890
I thought Tony_Montana was keeping the recent addition of DXVA2 deinterlacing to madVR in mind...
post #389 of 2890
I want to test the several ways & combinations of codecs/renderers for playing properly interfaced material.


I really didn't know that 50i/60i is converted by DXVA to 24p first and then to 25p/30p

I thought that the only correct way is 50i/60i -> 50p/60p

One more question out of madvr topic.

Do the ati cards do properly 50i/60i -> 50p/60p .

Does DXVA & vector adaptive follow the same process?
post #390 of 2890
Qaq is talking about film-mode deinterlacing for movies broadcast in TV. For video-based 1080i60 contents, video-mode deinterlacing is applied and you should get a 60 fps video stream from the original 60 field/s (= 30 fps) stream.

Of course AMD/NVIDIA/Intel all deinterlace properly to produce a 60 fps stream under DXVA2/EVR.

From posts at Doom9's Forum, it looks like many people get only 30 fps (or 25 fps in PAL) under DXVA2 deinterlace/madVR. DXVA2/madVR uses AMD's own deinterlacing (and other post-processing if enabled in CCC) algorithms implemented in the Catalyst driver (or NVIDIA driver or Intel driver). DXVA2/madVR is still at alpha stage, be patient.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › Advanced MPC-HC Setup Guide