or Connect
AVS › AVS Forum › Display Devices › Digital Projectors - Under $3,000 USD MSRP › OPTOMA HD20 HELP! white static flickering in dark scenes
New Posts  All Forums:Forum Nav:

OPTOMA HD20 HELP! white static flickering in dark scenes

post #1 of 2
Thread Starter 
Im having an interesting problem with my (just out of warranty) hd20 projector. In dark scenes I get white static flickering interference and thick but subtle horizontal flickering white sparkle bands. Its not typical sparkles from using cheap cables....been there done that. Some discs are much worse than others. Streaming and tv doesn't seem to be affected. Heres the testing Ive done to rule out everything but the projector itself as the problem...

-tried three different blu-ray players
-tried many different discs
-tried 3 different "higher quality" cables with and without equalizers
-tried a short cable/with b-ray player away from other equipment
-tried different electrical outlets for possible emi rfi interference
-jiggled "carefully" hdmi inputs for loose hookups
-opened up the HD20 and completely and CAREFULLY cleaned it

While at my wits end, painfully watching a flickering movie last night I started messing with ever setting on the PJ and was amazed to find that if I put it in native mode the problem completely goes away. Any of the other settings causes the static to come right back including the edge mask type features. This sounds like some sort internal picture processing problem.

Has anyone had this problem or can anyone explain to me in more technical terms what internal component may be causing this. Thanks
post #2 of 2
I figured out how to fix this! Turn down the sharpness and it fixes the prob. Honestly that's it!!
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Display Devices › Digital Projectors - Under $3,000 USD MSRP › OPTOMA HD20 HELP! white static flickering in dark scenes