or Connect
New Posts  All Forums:Forum Nav:

Micca EP950! - Page 54

post #1591 of 1651
Quote:
Originally Posted by rypaul View Post

You would usually only find that connecter in what is usually called a pico/micro computer.
Its not just a Micca thing, even hard drive enclosures typically use that connecter.
I have three lying around my office right now from non-functional enclosures.
I hope you are able to find and old sata connecter. Just be careful with prying the
connecter open and then just gently remove the original cables keeping in mind
the order of the wires. To help you out I will take the pics of mine that I promised
earlier in the thread so you can see what I did with the cable

Thanks for your help. I ordered the one cable you listed and a sata data cable. I'll see what I can do once I have everything in front of me otherwise this thing is going in the trash and I'm ordering something else.
post #1592 of 1651

 

 

 

 

 

I really hope you succeed, up to this moment my unit has been rock

solid where the internal drive is concerned ever since I did this procedure.

I am glad I bought it while it was still in production, it has served my needs

well.

Here are the pics as promised.

Please pay close attention to the one showing the notch in the

SATA connector and its relation to the wires. Basically just make sure the

Yellow wire is furthest from the notch then the black then red then black again

The other pics help with arrangement and wire length examples. I tried not to

get too long a data cable because space inside the unit is already cramped.

 

Lastly I am now testing this firmware alternative. The menus are a bit less flashy

but the unit is more responsive and the network speeds are much better over my

wireless network. Whereas with the original firmware gave me copy speeds of

5MB/sec from my laptop to the Micca I now get up to 12MB/sec.

The page is partly Russian but the firmware is in English

http://code.google.com/p/bast-castle/


Edited by rypaul - 6/12/13 at 8:43pm
post #1593 of 1651
Hey there my question...Do you know for a fact that the micca ep950 supports 4 tb hard disks...For sure?
I bought an ep950 a year ago and i really like it. Thanks
post #1594 of 1651

I am pretty sure it does. For any drive over 2TB you have to use a GUID partition.

The EP950 supports drives formatted in that manner so any drive over 2TB should be no

problem

post #1595 of 1651
Hii , Please I am going to buy a new media player and I want to Play my external 2 TB Seagate on it
I have HD TV with HDMI ( not 3D ) but i have a 3D video Wizard That acts as a way between the player and the TV to make me able to watch SBS movies
so i am asking is it better to buy Micca EP950 or Measy X5 ??
And can I connect them to the 3D wizard and enjoy 3D features ??
thanks in advance
post #1596 of 1651
Thread Starter 
Neither. The best 3d media player at the moment is the Mede8er.
post #1597 of 1651
Ooh Thanks for the reply
I searched for Mede8er , there is 600X3D , 800X3D , 1000X3D
Which is better and you recommend based on my info in the previous post
Thanks
post #1598 of 1651
Thread Starter 
Quote:
Originally Posted by minawahid View Post

Ooh Thanks for the reply
I searched for Mede8er , there is 600X3D , 800X3D , 1000X3D
Which is better and you recommend based on my info in the previous post
Thanks

All three are the same media player. The 600 is the smallest and doesn't have the option for internal hard drive. The 800 and 1000 has space for internal hard drive. They all use the same firmware.

I would suggest to go to the Mede8er thread before committing to buying anything.

http://www.avsforum.com/t/1440149/mede8er-med600x3d-new-3d-version-to-2013
post #1599 of 1651
Can you guys please please look at my post and tell me what is the best/affordable network media player out there:
http://www.avsforum.com/t/1483035/best-affordable-digital-network-media-streaming-player

thanks!!!
post #1600 of 1651
Can someone please help me - I got the EP950 from a friend of a friend and I tried to hook it up and I cannot get it to display anything on my screen...I tried HDMI and then figured this person might have changed the output to Component or composite and I tried all 3 outputs and no results.

Here is what I can tell is happening -
The Unit powers on and off
Unit responds to key presses on the remote, I can at least confirm the on and off is working.
The unit responds to touch in the front and powers on and off that way as well
It also seems to power the hard drive if I connect one internally but all I hear is powering up, no spinning.

I tried to install the latest firmware but I cannot get it to start recognizing the USB drive (in either of the two ports) - pressing the hole at the back is not helping...

I would appreciate any suggestions to at least get this thing to display something.

Thanks in advance
post #1601 of 1651

Please describe in detail how you are trying to do the firmware update. Please describe

your actions step by step.

 

This is how I usually do it.

To do the firmware update I use a usb flash drive formatted to FAT32 or FAT and copy the

firmware file to it. I unplug everything from the EP950 except the HDMI cable

I then insert the usb stick into either port and use a paperclip or some other small item

to hold down the small button in the hole at the rear of the unit. I do not remove the paperclip

until I perform the next steps.

I then plug the power cord back into the EP950 and count to 5 then I press the power button

on the front of the EP950 making sure it actually powers on because sometimes when you hold the

front power button the lights just flash on and then go off. When powered on I count to 5

again then I remove the paperclip. Since you are not getting

anything to display on yours please just leave the unit alone for 10 minutes after you

remove the paperclip just to ensure the firmware update has enough time to load.

Report back if anything changes


Edited by rypaul - 7/31/13 at 6:48pm
post #1602 of 1651
I have the micca EP950 with firmware 1.0.4.23 and am trying to use the recommended wireless dongle (Monoprice 8075 300mbps USB Wireless Lan 802.11N Adapter). The dongle communicates to my 802.11n network but I’m only getting speeds between 500K bits/sec to 1000K bits/sec on the EP950. Using the same adapter in a laptop computer I am able to consistently achieve around 20M bit/sec. This test would seem to indicate that the adapter and wireless network are operating correctly. Micca customer service has been pretty much worthless. Has anyone got wireless working with acceptable speeds to stream a DVD? If yes, what wireless adapter are you using.

For those thinking about using this device wirelessly, be sure and test while you still have a chance to return the product. As far as I can tell it does not work as advertised with respect to wireless.
post #1603 of 1651

Where is the EP950 located in relation to the router? Especially in regards to physical distance.

Also how are you testing the tranfer speeds and are you accessing a SATA drive in the EP950

or are you using an external USB drive with it?

post #1604 of 1651
The router is about 20 feet away in a separate room. I have a NAS on my network and am streaming dvd's from the NAS to the 950. Using an ethernet connection everything worked fne but I recently moved and an ethernet connection isn't readily available so I'm trying the wireless dongle.

Using the wireless dongle with a laptop, I put the laptop next to the 950's location and transfer files from the NAS to the laptop with excellent transfer speeds. Given that result, I don't believe there are any interference issues. There seems to be something about the 950/wireless dongle combination that doesn't yield the expected transfer rate.

I'm just wondering if other folks have achieved transfer speeds high enough to stream a DVD via a wireless dongle. If yes, what wireless dongle were you using?
post #1605 of 1651
Thread Starter 
Your laptop has a faster and better CPU than the 950. It doesn't matter if any media player support gigabit speeds if their CPU is too slow / old, it will not support it.
post #1606 of 1651
It's been a while since I checked the thread here, so please excuse me if the following question was already answered.

Last time I checked, the Micca EP600G2 / EP950 firmware had playback issues with the 24fps occasional frame skipping, and also did not playback camcorder 3D files in 3D.

I have seen firmware upgrades for other players, which use the same RTD1186 chips as the Micca players mention here. These upgrades correct the 24fps playback issue and also directly play in 3D the 3D camcorder files.

According to the posts, the Realtek chip maker updated the SDK firmware that all of the RTD1186 players use, and these two new features are included in this new SDK, and are accessible to Micca if Micca chooses to support new features.

So the question is: Is / has Micca updated their firmware to use the new SDK so that these improvements are supported?

Thanks for considering my question.
post #1607 of 1651
Hi Rypaul

I have tried the steps as you describe but will do so again this weekend and follow your steps down like a script.

My issue is that I have no way of knowing what is going on since I do not get any video output (I have tried HDMI, component and composite - in different attempts) and the front left side of the display which shows text status never comes on...all I get is the buttons on the right to light up.

Also, I am using USB sticks that have LED's on them - they flash if the stick is recognized and powers....here I do not see the sticks(I have several and have tried 3) flash...

And one final note - While the USB sticks do not power up...when I do connect hard drives (the portable 2.5 inch laptop external drives) they all power up (light comes on) BUT they do not spin (the kind of spinning and movement of heads you hear when the drive is recognized). I get the exact same thing happen when I connect a 3.5 inch SATA drive in the internal caddy provided...I can hear the gentle hum like it is powered up but no real head reading going on...

If only i could get some video to display so I can see what is going on I am sure I can take it from there...

Anyhow, I will surely try the steps you describe to a tee and report back...if you have any further advice please do not hesitate to share here...

BTW, FWIW I contacted Micca support and after some basic troubleshooting steps they concluded it was perhaps a hardware problem and then when I reported my serial number they said it was purchased in 2011 and so it is past its warranty and then simply stopped communicating so I am stuck with a doorstop at this point and I am willing to try anything to revive and dont care if I damage it - what have I got to lose :-(!
post #1608 of 1651
good info, I'm trying to make the decision to either buy Popbox V8 or EP950. thank you mZjw
post #1609 of 1651
Thread Starter 
Quote:
Originally Posted by jianghug View Post

good info, I'm trying to make the decision to either buy Popbox V8 or EP950. thank you mZjw

I wouldn't buy neither. Top media players are Dune, Mede8er and PCH.
Edited by GusGus748s - 8/20/13 at 12:33am
post #1610 of 1651
rapjp.....Sometimes the Micca needs to have the resolution set on start-up after updating....just press the resolution button slowly.....until you get a picture...has happened to me many times...
post #1611 of 1651
Can i connect a Micro Bluetooth Usb to one of the usb ports and use it via bluetooth??
post #1612 of 1651
I highly doubt it would work unless they decided to include a Bluetooth stack in the firmware which is very unlikely.
post #1613 of 1651
Thanks..another question if you may know? what kind of usb dongles can i use that i can buy in colombia because i wanna use my wifi??
post #1614 of 1651

Hey all,

 

    I just bought a used unit on ebay for about 15.00 shipped.  It was for the unit only without the ps,remote or cable.

I took it on my own to get a 5 amp 12 VDC ps but I need to know if it has a center pin of positive or negative.

I am hoping the EP350 remote that I bought on another auction works with basic functions on this unit. If not, I will buy a logitech 650.

I was wandering if a 2.5 inch hard drive would work as well (if not run cooler) as a larger 3.5 HD. (I'm thinking of using a 1 TB SATA)

My main goal is to use this as a FLAC player and steer clear of AV usage as this seems to be the number one objections of users

who posted their dilemmas (yes I read all 54 pages) here on the forum.

I am curious to know if the small capacitors had a contributing factor in errors and glitches.  I know if a PC motherboard was suffering from heat and voltage drops,the capacitors are usually the tragic victims of being poorly underrated.  I plan to study this closer and I have plans to try to improve conditions for operations where heat is concerned.

While the specs were clear on the video, I really did not see anything in the way of audio specs and performance in the manual.

I have not gotten the unit in just yet (couple more days)  and I will let you know how it all works out. (may be DOA for all I know)

Remember, I am just looking for a good audio streamer/player.

post #1615 of 1651

Greetings,

 

The center pin is positive

 

As stated in my earlier posts the freezing and drive disappearing issues i had

largely cleared up after I replaced the SATA power and data cables in the unit.

Any SATA HDD should work regardless of physical size as long as it's smaller

than 3.5

 

When you say audio specs are you referring to audio reproduction quality or

just recognized file types?

If its the specs for audio quality you are searching for I doubt you are gonna

locate any.

 

FLAC files play fine, just tested one

 

As for heat issues I find the unit runs reasonably warm and I have had no

instances that I can think of where something happened that seemed heat

related. I clean the fan every few months and have twice opened the unit to

clean any trapped dust from it. I am currently running and unofficial firmware

called Bastcastle that is no longer being supported. I use it mainly because

the copy rates for files over my network using this firmware are much higher

than the stock firmware. It's quite bare bones but that gives it the advantage of

being quit snappy when navigating the folders.

Another plus with this firmware for me is that it powers down the drive after

half hour of idleness and wakes the drives back up if you try to play a file

or access the unit over the network.

 

If there is anything else I can help with please feel free to ask.

post #1616 of 1651

Thanks for the quick reply Rypaul! 

As soon as I get the unit In I will report back with what I have.  Sure hope that 350 remote works on at least

the basic functions.  I have a logitech on my watch list if that fails.  I have plenty wiring harness adapters for

SATA and I am good at soldering and splicing.  I will concentrate on that as a first priority.  You have been

very helpful and I hope you do not mind if I lean on you for any issues coming up in the future.

As far as audio specs, I was looking for frequency bandwidth (20-20k etc) Being this is an all digital unit,

specs for audio is probably limited to compression ratios and bitrate.  Thanks agin.

 

       Allen

post #1617 of 1651

Where to start.  Well, last post I was waiting for the EP950 to come in and It came in with some front panel damage. There is a

3/4 in by 1 inch irregular hole with cracks around it with small shards of plastic all in the display slot.  I opened it up and investigated and surveyed for further damage.

The display and IR assembly is un damaged and working just fine but the touch sensitive part of the face plate suffers errors like when you touch the OK part, then the unit would shutdown.  This was not good when you would want to navigate and the risk to

corrupt your files was just waiting for a disaster to happen.  The EP 350 remote came in the next day...No Go.  The USB parts and all the video/audio outs were working fine.  I did not like the way the unit was behaving erratically with the firmware it had in it so I upgraded to the latest firmware and that stabilized errors better and I was able to use the OK button by trial and error using a pencil eraser but usually crashed to a power off situation.  I managed to connect a 2.5 inch seagate 120 gb to the internal connectors (still need to upgrade the connectors but it's working fine for now).  I loaded some folders of Fattburger's albums in flac format and I scanned the drive after disconnecting from the USB3 port.  Manually managing through the broken faceplate was a real chore and I contacted Micca and appealed to them for a new faceplate/touch control board and a Remote control.  Their email back to me was cordial but with a flat out "This unit is no longer being manufactured and we no longer support this unit for parts."  Wow not much more than 3 years old and Hi media is rolling out this same configuration with several different evolutions using this very faceplate.

Well, Amazon has a remote for 59.99 on sale (Harmony 650)  I am really hyped up now, I already invested too much in this thing (5bucks + 10 bucks to ship) (12 bucks for wrong remote) (4 bucks for a pair of HDMI cables shipped) (9 bucks for a 3 way HDMI switcher shipped) The rest is up to me...hmmmmmmmm...walmart is down the street and I got no remote.  I went to the local walmart and there hanging on one of the outer electronics mark-down shelves is a Harmony 600 marked down to 30 bucks!

Yeah! just what I needed.  If this Micca was gonna work The time is now to find out.  I got home and 5 minutes later I had the remote programmed for my vizio 24inch 1080p, My Manhattan RS-1933 Sat RCVR/PVR, Hitachi sound bar, and the Micca!

After that, I powered everything up via one remote and every function on the Micca obeyed smoothly every command through the setup, navigation and playing various flacs and with a ASUS USB outboard (1dollar garage sale score) DVD burner suddenly became a full featured DVD player.  OK, now I am elated.  Smooth transitions from one song to the next, the audio is just superb and clean.

I notice a slight crackle or pop coming through the audio until I relocated the outboard 1TB Toshiba drive away from the display.

This player has a lot of potential.  I successfully upgraded to Himedia's firmware and the transitions between menus seemed a slight sluggish but smoother in the process.  More on that later.  The player is still guts open and I need to work on the hardware a bit.

I may use a Dremel cutter /polisher to clean out the jagged mess on the front plate and find a suitable cover to cement over the open slot.  I have several comments about the way Micca handles their business and how possibly Hi-Media stays silent.  Anyways, enough for Jack's domain but if I can find a way to score a new faceplate, I would be a happy camper!  I am exploring a way to find a small 5-7 inch high res touch screen and incorporate this with the Micca to save having to use the TV as a visual interface for music functions as it's primary mission.  Will report back with further observations when I get this puppy put back together!

 

            ciao,

 

              Allen


Edited by MusicAVlvr - 2/12/14 at 8:25am
post #1618 of 1651

I am happy to hear it's mostly functional except for the faceplate.

Honestly for my purposes I would not care too much about the faceplate

functionality if I were you. Even when the units are brand new alot

of people including myself found the touch sensitivity to be really

dodgy. Since day one turning my unit on and off from the front panel

has been a 50/50 affair. Most of the time pressing one button activates

a different one. Stick to your Harmony trust me, unless you or somebody

you know can reverse engineer and make a new front panel for it.

Good luck and I hope to hear positive feedback about your

continued experiences.

post #1619 of 1651

Thanks Rypaul!  The Harmony is a definite keeper for sure.  I manged to get DVDs to play with very sharp images and I am going to start building hard drive based libraries of my massive FLAC collection.  I am impressed with what I have found so far and as I explore further I am sure the Micca will continue to impress.

 

          Cheers,

 

             Allen

post #1620 of 1651

I too am unable to do a firmware upgrade as the unit isn't recognising my USB stick. Same as the previous guy, I plug the thing in and the light on the usb drive flashes for an instant and then goes off. If I navigate to file manager it doesn't see the connected USB drive. I've tried this with a couple of different drives and same problem. It looks like the USB ports are not functioning.

 

Any ideas on how to fix this or a workaround?

 

Thanks

New Posts  All Forums:Forum Nav:
  Return Home