or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Klipsch SW-310- how is it?
New Posts  All Forums:Forum Nav:

Klipsch SW-310- how is it? - Page 2

post #31 of 37
Quote:
Originally Posted by Kini62 View Post

Sounds like something is wrong with the sub or the cable or the hookup etc....

The SW310 is fairly robust for its size. It should have WAY more output than the 8" Sony.

I have a similar in design sub (Deft Tech supercube). My avr is set to -2db and the gain (digital on mine) rarely ever goes past 15 on a scale of 0-40.

Yea I used the same cable for both the Sony sub and the Klipsch sub, a Monster M-Series M850 sub cable. Because the Sony is working very well with the same cable and receiver, I think that would narrow it down to the sub itself. I definitely thought there should be better output from the Klipsch over the Sony.

I tried setting my AVR to +3/4db as suggested to me with the output level of the Klipsch being only slightly louder from that at 0db, but not much. I then set the sub out to max at +12db and the gain to max on the sub and at that point it was just about matched to the output of my towers, but not quite. Listening to different music as well as the test tone and some explosions and tanks from movies to try and hear the base from different inputs I wasn't impressed. Meanwhile with these same settings I feel as if the Sony sub is going to shake my house down and I could clearly hear it from outside my neighbors house.

EDIT: For what its worth, I also experimented with changing the crossover frequency as well as setting my towers to "small" so that all low frequencies would be handled by the subwoofer, and this didn't make a difference either.
post #32 of 37
Can you return the Klipsch as there has to be a problem with it not keeping up with your Sony. If you can return, get something else while you are at it as per the databass from Audioholic, it is one bad sub especially for its price.
post #33 of 37
Can you return the Klipsch as there has to be a problem with it not keeping up with your Sony. If you can return, get something else while you are at it as per the databass from Audioholic, it is one bad sub especially for its price.
post #34 of 37
Quote:
Originally Posted by Cowboys View Post

Can you return the Klipsch as there has to be a problem with it not keeping up with your Sony. If you can return, get something else while you are at it as per the databass from Audioholic, it is one bad sub especially for its price.

They just told me they are going to ship me another one, hopefully that one will work.
post #35 of 37
How much did you pay for it? If it is more than $500 and you have room for bigger sub, i would just return it and get some ID sub that is much much better for the same price.
post #36 of 37
Quote:
Originally Posted by Cowboys View Post

How much did you pay for it? If it is more than $500 and you have room for bigger sub, i would just return it and get some ID sub that is much much better for the same price.

Thanks, yea I'm starting to look around if this doesn't work out
post #37 of 37
Received a replacement and it is much better. The original sub had a defect
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Klipsch SW-310- how is it?