or Connect
AVS › AVS Forum › Audio › Speakers › Klipsch ProMedia 2.1 speakers
New Posts  All Forums:Forum Nav:

Klipsch ProMedia 2.1 speakers

post #1 of 10
Thread Starter 
Just bought these from Best Buy, reading several reviews not only on Amazon but also the Best Buy site reviews that state these work with TV's. I have a 42 inch but am wondering how do I hook these up correctly?

A poster (reviewer) on Amazon stated the green plug goes to the Headphone jack but I'm still getting sound from my TV speakers and nothing from the speaker system.

My current setup is HDMI from TV to Tivo and HDMI2 from TV to PS3.

Any help you could provide me would be great, thx.
post #2 of 10
Go into your TVs menu and set the sound to "external" (and disable the internal speakers, if there's an option for that).
post #3 of 10
Thread Starter 
I have no such option available.
post #4 of 10
Have you tried using headphones with your headphone jack? To see if there's any output coming out?
post #5 of 10
What kind of TV do you have? Go into the audio menu, is there anything else that sounds like it might do what you want in there? There has to be a way to reroute the sound to external speakers, otherwise why would they have included the 3.5mm jack?

If the Tivo has a similar 3.5mm jack, try plugging the speakers directly into that and watching something off of the Tivo, does the sound come out of the speakers with that setup?
post #6 of 10
Thread Starter 
I have a Dynex DX-LCD42HD-09.

Don't see any options at all under the audio settings.
post #7 of 10
Thread Starter 
Quote:
Originally Posted by Remonster View Post

What kind of TV do you have? Go into the audio menu, is there anything else that sounds like it might do what you want in there? There has to be a way to reroute the sound to external speakers, otherwise why would they have included the 3.5mm jack?

If the Tivo has a similar 3.5mm jack, try plugging the speakers directly into that and watching something off of the Tivo, does the sound come out of the speakers with that setup?

Also the jack you speak of is lableled headphone jack.

Here is what I have available on the back of this set:

left to right -
power plug insert
s/pdif (manual says connect to a digital sound system)
av out
av in/ audio L-R
av video in
s video in
component 1/ component 2
vga audio/ pic
hdmi 1/ hdmi 2
headphone jack

UNDER AUDIO SETTINGS in menu:

Sound mode: personal, movie, standard or music (that is all)
Bass
Treble
Balance
Surround sound: off or on
AVC (auto volume control): off or on
SPDIF Type: PCM or RAW whatever that means
Audio Language: set to English

Thanks!

Thanks
post #8 of 10
I purchased the same speakers from Best Buy today. They sound tremendously better than the TV speakers. I don't know a whole lot about the SPDIF Types...but, PCM is a more basic setting...it decodes the audio signal somehow....VS the RAW setting which does not (I think). All I did was hook up the Klipsch L/R speakers to the sub, plug the preamp cord. The green connection I plugged into my audio out jack (for headphones). I get sound from TV speakers too, but I went to the menu and turned them off. I get sound with both PCM and RAW options, but since these speakers are THX Certified I am assuming they will sound better with the RAW setting.
post #9 of 10
I bought these speakers yesterday, and I'm blown away! They sound amaaaazing!
post #10 of 10
Old thread, but I have these speakers and am getting no sound from my left channel output or left headphone speaker. I'm not very electronically inclined, but have opened up the unit and don't see any blown fuses or obviously damaged circuitry. Any suggestions?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Speakers
AVS › AVS Forum › Audio › Speakers › Klipsch ProMedia 2.1 speakers