or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › Mediabrowser and NAS problem
New Posts  All Forums:Forum Nav:

Mediabrowser and NAS problem

post #1 of 7
Thread Starter 
I am trying to use a ReadyNAS Ultra to hold my media (mkv's) but when I select a file to play in MB there can be a delay of up to a minute before it will run. I have tried using a mkv file on a ReadyNAS NV and a Qnap TS101 with the same result. All the switches, NAS and HTPC are gigabit enabled and normal file transfer speeds are lightening quick. Disk spin down on the NAS is disabled. Media files on the HTPC HDD play instantly as do media files hosted on a networked PC. The ReadyNAS Ultra hosts all my FLAC music and the Squeezebox plays them flawlessly but there seems to be a big problem with MB and the NAS. I have tried optimising the settings on the Ultra with no improvement. Sometimes the file takes so long to load it locks MB or MPC-HC.

Is this level of performance to be expected from a NAS or am I doing something wrong?

NB: using MPC-HC + ffdshow + MadVR + Reclock
post #2 of 7
Thread Starter 
Update: VLC media player starts playing immediately from the NAS and the WMC native player does exactly the same. Seems the problem is with MPC-HC and/or the video or audio renderers. Running MPC-HC directly (rather than via MB) to the NAS gets a movie playing in about 12 seconds but if you stop it and start another movie it takes 60 seconds before it starts playing. Same behaviour as via MB. Same movies play immediately in VLC.

I wonder if I should do a fresh install of MPC-HC and the codecs?
post #3 of 7
I think it has to do with buffering, what splitter is mpc-hc using?
post #4 of 7
Thread Starter 
LAV splitter is being used.
post #5 of 7
How do you have MB configured to look for the drives/files ? Here are a couple of ideas ...http://community.mediabrowser.tv/per...on-htpc-wakeup....or this http://community.mediabrowser.tv/per...ct-on-playback


Im using a FreeNAS 8 server with a Giga switch, startup and playback with mkv's, vob's, and iso's with no delays.
post #6 of 7
Thread Starter 
Thanks. I saw that but am using UNC anyway and the NAS is showing as connected. There seems to be something in MPC-HT causing the problem but no idea what.
post #7 of 7
Just wanted to point out that I also have this problem.

At first I found this, its correct. If you look in resource monitor, you will see the player showing higher than playback disk activity whilst loading the file and once playing, that activity ends.

So, the problem is the same with Zoom Player and MPC. That means it exists with Lav Splitter, mpc avi splitter, haali splitter and zoom players built in splitter.

What could be stopping it from being streamed?

EDIT# just checked .mkv files and they stream instantly. Problem relates only to .avi files.
Edited by Dodgexander - 6/8/12 at 6:41am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › Mediabrowser and NAS problem