or Connect
AVS › AVS Forum › Audio › Speakers › My speakers made a loud pop, now they don't work. Help?
New Posts  All Forums:Forum Nav:

My speakers made a loud pop, now they don't work. Help?

post #1 of 5
Thread Starter 
It came out of nowhere and sounded like a gunshot, completely jumping me out of my chair. My music was relatively quiet, you probably couldn't hear it outside the room if I closed the door.

After the pop, my speakers stopped working and my music stopped playing. My receiver stayed on but there was no sound, and rebooting had no effect. I double checked all the settings and it all seemed to check out.

I've tried to connect my speakers to my onboard motherboard sound, but there's still nothing. I'm not sure if it could be plugged in wrong or not, but it appears right. This leads me to believe it's the speakers themselves, but then again I doubt that 1 pop could stop 5 speakers and a sub from working all at once.

I've got a 5.1 Logitech setup w/an X-Fi XtremeMusic

Thanks for any help, guys.
post #2 of 5
most likely the amp croaked (the loud pop) and possibly took your speakers with it....
post #3 of 5
An easy test to see if a speaker is completely burned out is to remove the grille so you can see the cones, and disconnect the wires from the receiver.

Then bring the wires ends around to the front of the speaker and use a 1.5 volt battery to check for cone movement.

Just touch the wire ends to the AA or C battery for a moment and you should see the cone move in or out, and then return when you disconnect it.

If the cone moves when you connect voltage, the speaker is not completely burned out




Quote:
Originally Posted by YeuEmMaiMai View Post

most likely the amp croaked (the loud pop) and possibly took your speakers with it....
post #4 of 5
What kind of a setup do you have? The X-Fi XtremeMusic is a sound board. The Logitech 5.1 setups are integrated amp/speaker combos. What receiver is there? How is all connected? Seems likely to me that you blew the electronics in the Logitech.
post #5 of 5
That does not sound good at all. Almost sounds like something might have shorted out. Hope it's not too bad.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Speakers
AVS › AVS Forum › Audio › Speakers › My speakers made a loud pop, now they don't work. Help?