or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Onkyo 509 won't pass 1080p video to TV
New Posts  All Forums:Forum Nav:

Onkyo 509 won't pass 1080p video to TV

post #1 of 4
Thread Starter 
I'm sure I'm doing something dumb, but I don't know what.

I have a new Onkyo 509. Connected to it are a DirecTV HD/DVR box and a Sony Blu-Ray box. The 509 is connected to a Sony TV. All HDMI connections (all 1.4). So, pretty simple system.

The BD was set to output 1080p via HDMI. When connected directly to the TV, it works fine.

However, when I run it through the 509, I get flickering video. Not quick flickering. More like: on for 1 second, off for 7 seconds, on for 1 second, off for 2 seconds, on for 2 seconds, off for 20 seconds, etc. Audio works fine and doesn't cut in and out with the video -- the audio is continuous.

I tested all of the 509 inputs with no difference in performance. I tested 4 different cables with no difference (which was no surprise since the BD worked when connected to the TV with the same cable).

The problems go away when I set the BD to output 720p or 1080i.

The DirecTV box outputs in 1080i and I have no other 1080p devices other than the BD to test with. However, since it works fine when connected directly to the TV, I don't think there is any issue with the way the BD is outputting the signal. It seems that the 509 cannot handle the 1080p and pass it on to the TV.

Any ideas on what I'm doing wrong?

Oh and the firmware has been updated on both the 509 and the BD player.

Thanks a lot.
post #2 of 4
Thread Starter 
http://www.youtube.com/watch?v=bFtzU8A9-Tg

Searched around and found nothing on the net. Posted my question. Then, decided to search some more. Quickly found the link above. Deep Color must be set to off.

Well, I feel dumb, but hopefully this helps someone else on this board.
post #3 of 4
Nothing to feel dumb about. On the contrary, you should feel smart that you were able to solve the problem on your own!
post #4 of 4
This issue is discussed several times in the Onkyo 509 Owner's thread.

http://www.avsforum.com/avs-vb/showthread.php?t=1322401

Also note that in addition to adjusting the Deep Color Output setting on the PS3, you can also turn the DeepColor setting to OFF on the 509 as well (p. 63).
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Onkyo 509 won't pass 1080p video to TV