or Connect
AVS › AVS Forum › Gaming & Content Streaming › ReplayTV & Showstopper PVRs › Panasonic Showstopper internal battery
New Posts  All Forums:Forum Nav:

Panasonic Showstopper internal battery

post #1 of 28
Thread Starter 

My Showstopper was working like a dream and then POOF!
Now it dials up, gets all of the information, and when it's finished, the guide is empty, and the time is incorrect.

I tried clearing out the channel guide info, changing the dial up number, etc. - basically everything I could find online to do. Still nothing.

I was thinking maybe something was messed up on the HD, since (as I understand it) the time and channel info is stored on the HD.

I popped my old drive back into the unit, forced the dial up, and the same thing. Blank channel guide and wrong time.

Then I got to thinking about how the unit would be blank and would need to dial up after even the fastest power loss (like my son flipping off the battery backup unit).

Inside the unit, under the HD mount is a battery that has popped and leaked a small amount onto the motherboard. I pulled this battery, and cleaned the motherboard. I'm hoping that replacing this battery will fix my problems.

If it does, it may be a good idea to replace your battery before it messes something up!

The problem is, the battery has no markings. Any clue what I can do for a replacement?

post #2 of 28
Originally Posted by TheRealAnubis View Post

... Inside the unit, under the HD mount is a battery that has popped and leaked a small amount onto the motherboard. I pulled this battery ...

The problem is, the battery has no markings. Any clue what I can do for a replacement?

First, you might see a marking under those tabs, if you can remove them.

Second, you could ask Mikeyboy, at this web address: http://www.replaytvparts.com/

Let us know how it comes out.
post #3 of 28
Thread Starter 

I got the tabs off and the top is unmarked..

I've emailed Mikeyboy to see if he can help.

I pulled the two 'batteries' apart, and the bottom one has a strange top that isn't flat like a battery. Also, the position on the board is C183, which would indicate that it's a capacitor - but it doesn't look like a capacitor...

post #4 of 28
My understanding, from reading other threads, is that this is a capacitor, not a battery. This capacitor is designed to hold enough charge to keep the timekeeping circuit (clock) powered through an extended power failure. (The term "clock" has another usage in digital circuits and I did find one part on the board labelled as a clock, but it has nothing to do with keeping track of time of day.)

The capacitor is brought to full charge in normal operation and the timekeeping circuit draws current from the capacitor during a power outage.

Unless we want to redesign the circuit to use a battery instead of a capacitor, we need to locate a suitable replacement capacitor. Note that the replacement need not mount on the board. External mounting removes size contraints on the substitute. It can be mounted elsewhere and connected by wires.

I believe that the capacitor had poor reliability. Modern computer motherboards use a replaceable lithium battery, probably to avoid the reliability issues.

I would strongly suggest that everyone install flipflop7146's panel for manually setting the clock. Instructions are posted elsewhere. Note that the procedure does require removing the hard drive and installing the panel from a suitable host PC. I am not sure if the machine will update the time from a ReplayTV server if it has gone back to 1999, but the manual time setting procedure will work.
post #5 of 28
Thread Starter 
Well, it sounds like we're getting somewhere at least!

I would be fine putting whatever upgraded part that's needed to get my clock going - and who knows, even my guide back. I would have no problem installing a non-standard solution, but I'm not sure what the value of the capacitor is. I searched for a service manual online, but no luck yet.

I'll see what I can do regarding the manual clock setting panel. I did get another drive ready just in case mine was croaking, and I used the image with the manual time set already installed, but when I installed the drive, it gets stuck at the "please wait" and just keeps shutting off and coming back on.

I'm not sure why this is happening, but the drive that is in it (that I also setup) works fine.

I called Panasonic parts and they are researching the battery/cap part to see if it is still available. Either way, I'll try to get them to tell me the value.

post #6 of 28
The term I was looking for is "real time clock." The real time clock integrated circuit (IC) appears to be U23 and the timekeeping quartz crystal Y4. The IC is likely a second source for Dallas Semiconductor DS1307.

The DS1307 datasheet is available here:


Continuity checks show the crystal connecting to pins 1 and 2 of the IC, but crossed over. The negative terminal of U183 has continuity to pin 4.

I didn't remove my board to check continuity of the positive lead of U183, which I suspect connects to pin 3.

If my suspicions are correct, we can, with the correct tools, lift pin 3 and connect the positive terminal of a CR2032 battery in a holder to it, and the negative battery lead to the circuit board's negative terminal connection of C183, which we have removed. We must not connect the battery directly to the terminals for U183, because the circuit will be charging the battery when the ReplayTV is powered up. Charging current will ruin the battery.

The holder for CR2032 can come from a junked computer motherboard and mount to a homemade external circuit board.

If we are more clever, there may be a better way to disconnect the charging circuit for U183 and avoid lifting a pin on the real time clock IC.
post #7 of 28
Thread Starter 

I like where this is going!

I have a battery holder, and batteries, so I'm considering trying this out!

Basically, lift pin 3 from the MB, attach the (+)pos lead from the battery to pin 3, then connect the (-)neg lead to the (-)neg spot at C183.

Should I attempt this now, or do you think anyone can figure out how to take the charging part out of the equation?

Panasonic got back to me and they don't carry the part. Their obligation to have parts is 7 years, and we're past that!
They referred me to the repair center, which is now closed, so no help there yet. I'll try them on Monday.

My question to them would be, if you get this unit in for repair, how do you fix it?


******* UPDATE! *******

Mikeyboy just emailed me back and said that the part is a: 5.5 Volt .1 Farad polarized capacitor.
That should simplify the job, but now I'm wondering if I should mess with another capacitor, or just do the battery thing...
post #8 of 28
Check this one out:


Note that the picture shows a 0.22 Farad capacitor, but the picture is likely wrong.

Also search ebay.com for item 120791325675 (copy and paste to the ebay search window.)

The straightforward solution is to replace the capacitor. Before moving forward with lifting pin 3 and connecting a battery, verify that pin 3 connects to the positive lead of the capacitor.

Either capacitor is electrically suitable. The elegant solution is to get one that will directly replace the capacitor on the board (matching physical size and leads that drop directly into the holes.) Otherwise, you must improvise.
post #9 of 28
Thread Starter 

Yes, I found a few links as well, including one that looks exactly like the old one, but it's strange, all the pics are of the .33F instead of the .1F.

I know the old one lasted 11 years, but I still wonder about doing the battery instead.

I'll check to see if that pin connects where you think it might before I try anything.

Also - Mike emailed me and said that the clock should set with or without the battery, and he gave me the number he used to dialup.

That number did set my clock from 1999 to the correct date, but I got an out of memory error because I probably should have cleared the channel guide first. I cleared the guide twice and then I changed the numbers back to my local ones and after a connect to the mothership the time and the guide is working properly!

I just have to make sure the power doesn't go off before I get the new part in.

My guess as to why my channel guide was blank is this - since the clock was set at 1999, 3AM, there was nothing to display because the program data downloaded was for 13 years in the future. Once the clock had the correct date, the data was displayed!

Anyway, thank you for the help, and I'll keep you posted on the battery idea.
post #10 of 28
The straightforward solution, which is probably best for most of us, would be a drop in replacement capacitor that could be installed by someone experienced with working on circuit boards, either in an engineering lab or in production, applying static electricity precautions.

I do find other sellers of the 0.1 F 5.5 volt battery on ebay. Some of the parts definitely are not physically compatible, so will require an improvised mounting arrangement.

As for the battery solution, you can avoid lifting a pin by putting a diode in series with your battery to block the charging current. The clock chip is supposed to work down to 2.0 volts, so a new 3.0 volt battery with an estimated diode drop of 0.6 volts would provide a more than adequate 2.4 volts. This is probably fine for a DVR since it is only powered down during power outages, while a computer might be powered down daily overnight. Current is rarely drawn from the DVR battery, so shelf life predominates.

The actual diode voltage drop may even be lower than 0.6 because the current is so low.

The diode will decrease the useful battery life. Batteries lose voltage over time. Assuming 0.6 volt drop, the 2.0 volt minimum for the IC will be reached when the battery voltage drops to 2.6 volts. Without the diode, the battery voltage can drop as low as 2.0 volts before hitting that minimum. If you are really worried about battery life, you can use a germanium diode such as 1N34A, with a forward voltage drop in the 0.2 volt range.

However, now that I know that I can obtain the capacitor for a reasonable cost, I plan to implement that solution.
post #11 of 28
I removed the circuit board and checked continuity. The positive pin of the capacitor connects to pin 8, the positive power pin, of U183, not pin 3.

If you do run the battery experiment, you need to verify that the real time clock IC is DS1307 or, if not, uses pin 3 as a battery input. Most likely, pin 3 is open on the board, so need not be lifted.

Forget about the series diode connected to a battery. That idea was based on the capacitor connecting to pin 3.

I find no markings on the capacitor. The replacement from mcmelectronics appears to be electrically correct but not a mechanical drop in replacement. The ebay.com item number 120791325675 appears to be a drop in replacement. The stated diameter of 9.9 mm is very close to what I crudely measure on the old part, using a ruler. The pin spacing does not appear to be correct, but the pins probably can be bent (reformed) to fit well.
post #12 of 28
Thread Starter 

I will probably end up just putting the same part back in. I'd like to try the battery idea, but I'm not sure I have the time to research it to make sure I don't fry something!

I can't stand having the Showstopper out of the TV loop for too long - even when the guide was not working, I could still pause whatever I was watching, which is something you get used to and can't stand to be without. I particularly like to pause it right before a show that I want to watch, then do something else for about 20 minutes or so, then watch the show and whizz past the commercials.

I found a pic online that looks a lot like the actual one that came out of the Showstopper:

It gives a better overall view of the part.

I have a parts place nearby that I am going to call on Monday to see if they have the part. I'd rather just go get it if possible!
post #13 of 28
Good work! The capacitor replacement for C183 shown in the picture is a good visual match to the one that I removed from my ReplayTV dialup unit in the HS1000/2000/3000 series.

Here are the results of some experiments I ran on one unit, in the above series, that had been disconnected for a long time, and, therefore, did not have a current channel guide. Prior to these experiments, I had removed C183.

1) My ReplayTV unit powered up and appeared to run normally. The clock reset to 11/12/1999 at 12:00 AM and kept time from there. There was a message about a power loss, time stamped 11/12/1999 12:00 AM

2) On a network connection, the unit went through the motions of setting the clock, but the clock retained the 1999 time and date. Interestingly, when I programmed a zip code in a different time zone, it corrected for the time zone difference, but did not set the correct time and date.

3) The channel guide was empty after updating. I had flipflop7146's time setting hack installed. After setting the correct time, the program guide remained empty.

4) After manually setting the correct time, I downloaded the channel guide again. It filled out through 4 PM Pacific one week from today. (Note that this cut off was 7 PM when I downloaded a program guide for the Eastern time zone.)

5) I powered down the unit and powered it up again. The clock reverted to 11/12/1999 at 12:00 AM. The program guide appeared to be empty. I manually entered the correct time and was able to access the program guide as before. So, the machine didn't delete the program guide information.

Conclusion based on these experiments:

1) The ReplayTV will run fine without C183 until it loses power, at which time it will revert to 11/12/1999 at 12 AM on subsequent power up. Therefore, TheRealAnubis, go ahead and reconnect your Showstopper and use it until you take it out of service again to install the new capacitor.

2) I had to set the clock manually to the correct time and date (or something close) in order to get the server to update time and date. (However, others have reported success without manually setting the clock, so this could be just a fluke.) In any event, it is probably best install flipflop7146's hack and set the clock manually.

3) Capacitor C183 probably does not stand the test of time and should be replaced on all units. However, you may need the capability to manually set the time in order to get the program guide back after replacing C183. So, do not replace C183 until after you have installed and tested flipflop7146's hack.

4) The time setting procedure is much more straightforward from the 777-zones screen than from 888-zones within display brightness. After each power up, enable 777-zones from 888-zones within display brightness. (Refer to the readme for the hack.)
post #14 of 28
Thread Starter 

This was a lot of great information.
I'll check out the time hack panel you suggested.

It's strange that the time doesn't set correctly from my local dialup, and I also tried one in Indianapolis, IN just to see if that made a difference.

Based on what Mike sent me in the email, you can try this dial up number to get the clock set correctly if you don't have the time hack:
(as you would enter it in the showstopper/replay3000)
I looked up the zip, which is 01570
then pick the Webster number - 508-213-0019

When I did this, the clock was updated to the correct time. He thinks there may be a server error causing the time to be set incorrectly.

To speed things up, I picked the non-digital option for the cable provider, which downloads a short list of channels and finishes faster.

Then I cleared the channel guide twice, set the numbers to my original ones, and forced a dial up. Once that was finished, everything was back!

Now to read up on that time panel...
post #15 of 28
The number 508-213-0019 for Webster, MA, is on the AT&T list of dial-up numbers:


I suspect that all of these numbers connect back to the same bank of servers, so there would be nothing special to make this number work any better than others on that list. However, the network administrators would know for sure.

Correction on my comment on the channel guide. It filled out through 4 PM one week from tomorrow (not one week from today.)

If the memory backup capacitor C183 is electrically leaky, in other words, drawing current, it may drag the real time clock voltage down to less than 5 volts. So, removing a bad C183 might actually help the unit keep better time (but only while the unit is powered up, of course)!
post #16 of 28
When this discussion started, it sounded familiar, having read the following from last summer in the Showstopper Tests topic:

Originally Posted by KenL View Post

Folks it's not a clock battery its a capacitor. Mikeyboy used to stock the replacement part for 2xxx/3xxx/SS.

Do we know yet what the spec is for C183, or where to obtain it (with confidence it is the right value)?
post #17 of 28
Here's a picture from the thread referenced by gring40:

(You may need to be signed in to view the picture.)

The same capacitor value, 0.1 F, is shown. My continuity tests show the capacitor directly connected to pins 4 and 8 of U23, the real time clock IC. A quick calculation, using a standby current of 200 uA for the DS1307 (which may not be the part for U23) shows a decrease in capacitor voltage of 0.12 volts per minute, so the real time clock would run about 4 minutes before the chip's power pin dropped from 5.0 volts to below 4.5 volts.

I would say match the electrical specs and not be too concerned with the mechanical, since we are doing the replacement by hand and have some liberty with the mounting arrangement.
post #18 of 28
Thread Starter 
Just a quick trip back to - The number 508-213-0019 for Webster, MA
I wonder what changed my result then? I tried dialing to other time zones, other cities, clearing the channel guide multiple times etc. with no results -
the clock remained set at 1999, 3AM, but when I tried the number Mike suggested the clock was updated correctly the first time.
post #19 of 28
There is nothing to make the Webster, MA number stand out on the list of AT&T dialup numbers, but, if you haven't installed flipflop7146's manual clock setting panel, it is worth a try.

Note that the clock will drift without regular nightly updates. If you go back to your local dialup number after having success with the Webster, MA (or some other number that someone claimed did work,) and the clock doesn't get set nightly, it will lose or gain time as the days go by.
post #20 of 28
Thread Starter 
That's the strange part about my Showstopper. The clock was spot on until it went toes up and reset to 1999!
It did ooze some fluid out, so maybe that's when it sent its last bit of voltage to the RTC.

Anyway, I'm still waiting for the local parts warehouse to tell me if they have it and how much.
If I have to buy several to get a deal, I'll do that if anyone is interested in buying the extras from me. If not, I guess I'll make a necklace out of them or something!!

I have found several parts places online that have the part from $1.50 to around $3, but they want to charge $10 for shipping, so that's not really a good deal. I'd like to do the ebay thing, but I'm not fond of paypal, and that's all most of the ebay sellers accept for payment.

Well, all of the parts places nearby are apparently useless! I have contacted several and haven't heard a thing, so I broke down and ordered one from ebay.. It's supposed to be in on the 13th or 14th.
post #21 of 28
Have you considered just building the simple 3 wire PTVIO serial cable that allows you to set the time (as well as give you more feedback on what's really happening with the dial connection?
post #22 of 28
Thread Starter 

Nope, I haven't heard of that. Do you think it will be easier than just replacing the cap?

Anyway, pop in the link (since my brief search came up with stuff about 5500 models), and I'd be happy to read up on it!

I am thinking about setting up Freesco, after getting a different external modem, and letting it get the update from the net...

post #23 of 28
Originally Posted by TheRealAnubis View Post


Nope, I haven't heard of that. Do you think it will be easier than just replacing the cap?

Anyway, pop in the link (since my brief search came up with stuff about 5500 models), and I'd be happy to read up on it!

I am thinking about setting up Freesco, after getting a different external modem, and letting it get the update from the net...

Didn't save the link, but the cable is the same for all the models

replay pin pc pin rs232
1 3 txd
4 2 rxd
5 5 gnd

I did verify that the command rtcget returns the current time and rtcset allows changing. This was on a R3k unit.

I've never had a unit that would lose time so I can't comment on leaving the cap alone and just ensuring I could manually set the time, but I'd try the cable first because:

1) it's less risky than soldering on a 10 year old circuit board

2) If you can't get the time consistently I would think the cap would be irrelevant.

3) Even with FREESCO through WiRNS V2 I see "silent" failures setting the clock (4 timed out attempts to pool.ntp.org). I've had recorded shows cut out too soon, so it's now nice to see if it's a timing problem and be able to easily correct.

>>>> Important update <<<<<. Tried using my PTVIO cable on my mom's showstopper (I wanted to see why her nightly download is completing even after this network authentication change). Cable didn't work and it reminded me that you have to issue the "pvtio on" command from the network, typically from WiRNS access - more details at

post #24 of 28
Thread Starter 
Well, I got the part and installed it. It is slightly smaller than the original, but it fit back in the spot with no modifications.

I'll attach pics of before and after, in case anyone wants to have a look.

As far as soldering on a 10 year old board, that's the fun part! I soldered the 1541 serial to PC cable onto my old 1541 drive with no problems, and that's from the early 80's!

I will try that cable if I get a chance - It can't hurt to have other options.

I had a problem again with getting the time to update correctly. I went into 243 zones and toggled the clock so I could see when (or if) it happened.

I cleared all of the guide data 2 times to start with.
I tried 3 times on my local number with no change, and it took 2 tries to the 505-213 number (but I didn't update the channels, just that first dialup where it gets the numbers and stuff - the 5 minute dial in) but it did finally update the clock. After that it was all ready to go! I'm letting that cap charge for a day or two, then I'll pull the plug and see what happens. Wish me luck!

Here's a pic of the board without the part (looking from rear of unit):

and here's a pic with the part installed (looking from rear of unit):

*&*&*&*&* Update *&*&*&*&*

It works! I had to unplug my system to replace the UPS battery, so it was all off for a couple of hours. When I got it powered back up, the Showstopper had the correct time and the channel guide was intact!
So if you are thinking about replacing the part, the one from ebay works fine!

I also got the power loss messages in the messages area.
post #25 of 28

I seem to be having the same problem with my showstopper 2000 clock. Its 50 secs slow. Tired clearing the guide, rebooting, calling different numbers with no change.

Also, it stops at 28 mins and 30 secs for a 30 min program.

Not a big deal, if something important comes up I use the manual program setting guide.

Since you have corrected yours perhaps you, or another member, can list the steps needed to replace the capacitor.

I know that my system is at least 8 years old, but I use it everyday and really like it.
post #26 of 28
The capacitor serves the function of a battery to keep the Showstopper's real time clock running through loss of AC power. If your clock is off by 50 seconds but otherwise keeping good time, the capacitor is not to blame.

The clock is normally set once daily as part of the nightly connect to update the program guide. Other forum members and I have found that the clock doesn't always get set.

If you haven't installed flipflop7146's manual clock setting panel, I highly recommend that you do so. You could use it to correct the 50 second error.

I have observed an apparent clock setting bug. When the clock has reverted back to 11/12/1999 after loss of AC power with a bad C183 and you set the time correctly from the 777 Zones panel, you may find the clock correct just after setting it, but jumping an hour ahead later. I think the bug has to do with switching from a standard time date to daylight saving time. I tried setting the time and date twice and that seemed to work around the bug.

A bad capacitor could cause the real time clock to run slow (or fast.)

As for replacing the capacitor, it should be done by someone experienced with doing component replacement on static sensitive circuit boards, using the right tools. Note that there are a large number of screws to remove to disassemble the unit and get access to the bottom of the board.

On ebay, I bought a set of 5 capacitors 0.1 F 5.5 V that mount vertically, from a seller who shipped from China. The leads needed to be re-formed (bent) to get the right spacing. I have installed some of them in my Showstoppers and they work well.

I also like my Showstoppers. I credit an excellent design which has stood the test of time well, much to the chagrin of those who are continuing to support the nightly guide updates. Not having to pay a monthly subscription fee is a major selling point for keeping these machines. However, a lot of credit is due to those who developed the "hacks", such as hard drive upgrades to 137 hours, retrofit cooling fans, the time setting panel, support for controlling new cable and satellite boxes, and, probably necessary soon, the FreeSCO, WiRNs and Schedules Direct program guide. Without the hacks, the boxes would likely have gone obsolete.
post #27 of 28
Originally Posted by cap_ncrunch View Post

...I also like my Showstoppers. I credit an excellent design which has stood the test of time well, much to the chagrin of those who are continuing to support the nightly guide updates. Not having to pay a monthly subscription fee is a major selling point for keeping these machines. However, a lot of credit is due to those who developed the "hacks", such as hard drive upgrades to 137 hours, retrofit cooling fans, the time setting panel, support for controlling new cable and satellite boxes, and, probably necessary soon, the FreeSCO, WiRNs and Schedules Direct program guide. Without the hacks, the boxes would likely have gone obsolete.

Nice historical summary.
post #28 of 28
Thanks for the compliment, ClearToLand!

Daylight Saving Time (DST)

The 777 Zones time setting panel, which allows users to set date and time in local time format, doesn't handle the DST correctly during the extended weeks in the spring and fall. After you set the date and time, the notation will show standard time. The work around is to enter the date and time in standard time (one hour earlier) and then reboot the system to get the display to convert to DST.

Real Time Clock Backup Time

The real time clock continues to run several hours from the charged capacitor, which is well beyond the 4 minutes that I calculated in my earlier post, based on the power supply load of a DS1307.

Installing Vertical Mount Capacitors from ebay

1) These capacitors must be installed with correct polarity, but + and - designations were not provided on the parts I received. The seller informed me that the + lead is the longer lead.

2) I found it necessary to decrease the capacitor pin diameters to fit into the holes on the PC board. However, I acknowledge that I may not have cleaned out the holes well enough, so this step may not be necessary.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: ReplayTV & Showstopper PVRs
AVS › AVS Forum › Gaming & Content Streaming › ReplayTV & Showstopper PVRs › Panasonic Showstopper internal battery