or Connect
AVS › AVS Forum › Gaming & Content Streaming › Home Theater Gaming › HTPC Gaming › Tritton ax 720 setup
New Posts  All Forums:Forum Nav:

Tritton ax 720 setup

post #1 of 2
Thread Starter 
Hey everyone,

I just picked up a pair of ax 720's, and so far I like them a lot more than the behind-the-head bluetooth headphones I was using before.

I was having issues with static coming through the headphones and wondered if they could be interfering with something else plugged into the computer so I started unplugging things that were connected to the USB ports, but the static continued. Then I unplugged the optical cable connecting the computer and the Tritton's amp box.

What's weird is the headphones continued to transmit sound, which means they must be receiving it through USB rather than optical. Am I losing out on the 7.1 aspect of the headphones with this type of setup? When I go into my sound settings and configure the headphones it only lets me set them up as Stereo, not 7.1.

I tried switching the Sound Device to the optical port, but that doesn't send the sound to the headphones. I've gone into the device manager and uninstalled the headphones, then reconnected them so they would redownload the drivers, but that didn't make a difference. I've also tried googling this for info but can't find anything relevant.

Oh, and it turns out the static was caused by the SVM (selective voice monitoring). When I would have that on (it allows you to hear yourself in your headphones when you talk) and the microphone connected, it would send really loud and constant static. Unplugging the mic or turning off SVM would stop the static. I haven't tested to see if it works on my 360 yet, has anyone else experienced that?

Thanks!
post #2 of 2
How do you turn SVM OFF!!! its so annoying
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HTPC Gaming
AVS › AVS Forum › Gaming & Content Streaming › Home Theater Gaming › HTPC Gaming › Tritton ax 720 setup