or Connect
AVS › AVS Forum › Display Devices › Rear Projection Units › Unusual Toshiba Bulb issue...
New Posts  All Forums:Forum Nav:

Unusual Toshiba Bulb issue...

post #1 of 3
Thread Starter 
Hey everyone! Total nubee here. Anyway, after scouring these & other forums, I seem to have a different issue/problem/cause than what I've found so far:

Toshiba 72HX196 (Cinema Series). Purchased new in mid 2006. Has worked flawlessly for years. About 2 months ago the original bulb popped. Was late at night & we were watching when it exploded. Anyway, in expectation of this day, I had purchased a replacement bulb which I believe is a factory unit, but unsure. Bulb was left in box & put away until needed. Next day I followed instructions & replaced bulb.

Here's the issue: Ever since the bulb went out/was replaced the unit will randomly fail to light. Audio works fine, but no picture & bulb out LED flashes. Unit will go through its relight sequence, usually to no avail. I can cycle the unit off & on with limited success. In other words, sometimes it will come on & work fine, other times I have to unplug it & replug it to get it to work. Have noticed problem is becoming more prevalent lately. At first it was a rarity, but now it will not light more often than it will & after powering it off-n-on a few dozen times I usually have to pull the plug to get it to come on.

Any ideas/advice as to what is wrong here?? I'm considering finding another bulb to replace the original with, but am leery of pouring too much money into that hole before I start it on fire...

Thanks in advance for any help!
post #2 of 3
1. It's a lamp.
2. Sounds like the ballast.
post #3 of 3
I have a different model Toshiba but mine has the same problem if I use anything other than an official Toshiba brand bulb/lamp.

I've tried compatible lamps and they all develop problems igniting, which is the problem you are having. Once lit, they work fine.

I buy my replacement lamps directly from Toshiba. They are more expensive, but they do come with a 6 month warranty. I buy them with a credit card that doubles the manufacturer's warranty, which gives me a year's coverage.

It is hard to tell with on-line vendors whether they are selling an official Toshiba product (if so, it will come in a Toshiba box with the Toshiba name plainly evident. It will also contain a Toshiba warranty card inside the box.

Even if you buy a Toshiba product from an on-line vendor, there is no guarantee that it is the latest version of the lamp. Toshiba has had problems with premature failure of their lamps, and had supposedly made improvements to them.

To me, the lamp issue comes down to the age old comparison of price vs value. Other lamps may be less expensive, but the ignition problems they present make them a poor value to me.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Rear Projection Units
AVS › AVS Forum › Display Devices › Rear Projection Units › Unusual Toshiba Bulb issue...