or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › Noob Needs Help: MKV NO HD Audio from Laptop to AVR
New Posts  All Forums:Forum Nav:

Noob Needs Help: MKV NO HD Audio from Laptop to AVR

post #1 of 8
Thread Starter 
Thanks in advance for the help! I have a Dell XPS 17 (L702x) laptop with an Nvidia GT 550m card. I have ripped some blu-ray discs to MKV with MakeMKV. I am now playing back the MKVs on my laptop with it hooked up to my system but I'm not getting HD sound. I have it set up like this:

Laptop -HDMI cable- Pioneer Elite VSX-94TXH AVR -HDMI cable- Sony HDTV

I can play back the files fine and watch them on my TV but no HD sound. I can get the AVR to display DTS (or Dobly Digital depending on the movie), "stereo", or PCM sound but no bitstream HD audio. I don't really care that it's bitstreamed per se but I don't think the PCM audio is decoded HD audio (LPCM). The files definitely have the HD audio tracks as part of the file, every program I use shows the lossless track is there.

I have tried play back via VLC, XMBC (with and without the HD bitstream patch) and Potplayer. I have installed FFD show and LAV Audio. Still can't get it to work. I must be missing something. Please let me know what I'm doing wrong.

Thanks again!
post #2 of 8
update nvidia drivers.

that will do it.
post #3 of 8
Thread Starter 
Quote:
Originally Posted by MlNDBOMB View Post

update nvidia drivers.

that will do it.

Thanks for the suggestion but, unfortunately, I tried that. I had been using older drivers (no reason to update often on a laptop that I wasn't gaming on) and I installed with very latest version last night and it didn't change anything.
post #4 of 8
Do you have your Pioneer set to pass the signal through to your TV? If so change that and have the Pioneer decode it first.
post #5 of 8
Thread Starter 
Quote:
Originally Posted by assassin View Post

Do you have your Pioneer set to pass the signal through to your TV? If so change that and have the Pioneer decode it first.

Hmm... I hadn't thought about the receiver being the problem. I'll check the settings. For what it's worth, I have no trouble at all getting HD audio from my blu-ray player to my receiver.
post #6 of 8
Do you get any audio at all by way of your laptop's HDMI connection?
Like the various chimes generated by desktop operations?

If you haven't already, open Control Panel's Audio menu and use its test options.
post #7 of 8
Thread Starter 
Quote:
Originally Posted by Selden Ball View Post

Do you get any audio at all by way of your laptop's HDMI connection?
Like the various chimes generated by desktop operations?

If you haven't already, open Control Panel's Audio menu and use its test options.

Yes, I get sound from the laptop to the AVR with no problem. I can get the following soundtracks when watching movies: DTS, Dobly Digital, "stereo", or PCM sound. I don't think the "PCM" sound is HD, but it was hard to tell. Definitely no bitstream HD audio.
post #8 of 8
Thread Starter 
I figured it out. Had to remove everything and install Shark007 codecs per Assassin's website. Then I tried Mediabrowser and it would crash with some of my files. XBMC is working perfectly though
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › Noob Needs Help: MKV NO HD Audio from Laptop to AVR