or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › flac in 7MC -- start of each song cut off
New Posts  All Forums:Forum Nav:

flac in 7MC -- start of each song cut off

post #1 of 13
Thread Starter 
If I play a flac file in 7MC using media player, the beginning of each song is cut off. I'm using madflac to play the files and WASAPI through reclock to achieve bit perfect playback.

I'm pretty sure it has something to do with my receiver pickup up the stream so there may be no way around it.

Just curious... any ideas on how to eliminate the gap?
post #2 of 13
Thread Starter 
Anybody have any idea what I'm talking about? I have an Onkyo 706 if that makes a difference? Is this more of a receiver question?
post #3 of 13
It's probably the receiver. Did you try without reclock?

The solution may be for the player to play a short clip of silence before the track. But that may not be an option.
post #4 of 13
I have the same issue using Foobar into a Denon 1910, with WASAPI out. I lose the first half second of each song. I assume it's the receiver but will have to do some troubleshooting.
post #5 of 13
I have a Onkyo 875 and it takes about 2 seconds to switch modes. So during commercials on a feed from my cable box the sound mutes for several seconds when the audio format goes from stereo to 5.1 format, real pain. Your 706 is a year newer model than mine I had hoped they had fixed this problem. I read somewhere that a firmware update might fix this delay.

Mike T
post #6 of 13
Thread Starter 
It doesn't do it if I turn Reclock off. The pause -- mine is about 2 seconds -- only happens for anything that takes exclusive control of my audio drivers.

Is there a solution or does this just have to happen as the receiver switches modes?
post #7 of 13
Thread Starter 
Also, it seems like if I set the Windows mixer to anything other than default (16 bit/48KHz) that my receiver has the delay in switching. I pretty much bitstream everything except for flac music files (44.1 KHz) and YouTube videos (mostly 44.1 KHz I believe). So I changed my sample rate in Windows to 44.1 KHz to avoid any unnecessary conversions and the pause is back whether I use reclock or not. Is this normal behavior?
post #8 of 13
Could you convert to WAV and bitstream that, too?
post #9 of 13
Thread Starter 
Quote:
Originally Posted by jriver View Post

Could you convert to WAV and bitstream that, too?

I'm not sure I understand -- what would this accomplish?
post #10 of 13
My Onkyo 605 does the same anytime the audio stream switches between Dolby/DTS and PCM. This is very noticeable with Live TV, when the local commercials come on. It did that even when I had a cable box so it's not specific to HTPC.

Do you have WMC setup as 5.1 or 2.0?
post #11 of 13
This is most likely due to an issue with AVRs not syncing(switching) fast enough when different audio signals are sent to the receiver.

I've had the same issue in the past 4-5 years with mid-level Onkyo and HK receivers. I just splurged on a Pioneer Elite SC-57, no delays at all, go figure.
post #12 of 13
Thread Starter 
Quote:
Originally Posted by StardogChampion View Post

My Onkyo 605 does the same anytime the audio stream switches between Dolby/DTS and PCM. This is very noticeable with Live TV, when the local commercials come on. It did that even when I had a cable box so it's not specific to HTPC.

Do you have WMC setup as 5.1 or 2.0?

WMC is set as 5.1. Sound properties in the control panel is set to 2.0. It even affects programs like Spotify that stream music.
post #13 of 13
Thread Starter 
Also, it seems to only happen on the stereo setting on music. It doesn't seem to happen on plx2 in movies. Interesting...

EDIT: now it's working fine in Spotify on the stereo setting. No pause in switching. I can't find a pattern here. Any ideas for testing to isolate the problem?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › flac in 7MC -- start of each song cut off