or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › Annoying display switch - How to disable monitor/display detection in Win7?
New Posts  All Forums:Forum Nav:

Annoying display switch - How to disable monitor/display detection in Win7?

post #1 of 9
Thread Starter 
I upgraded to a new projector from an older Sony with DVI to a Sony VPL-HW30AES. I am still using the dual link DVI cable that is behind walls. However, I am using a DVI to HDMI converter to connect the projector.

My setup consist of a Win7 MediaCenter PC with an AMD card. The primary display goes to a VGA screen that I use as the control screen. The projector is setup as the secondary display. I am using the extend function. I keep MediaCenter full screen on the projector screen.

The issue:
When I power on my system the PC is switching MediaCenter to my control (VGA) display. After a projector power off MediaCneter is not switched.


With the old projector the MediaCenter remained on the projector screen even when the projector was switched off. At least it didn't jump to the VGA screen.

So, the issue is that wehn powering on the projector the full screen MediaCenter app is switched from the projector screen space to the VGA space.

I checked all the stings and couldn't find anything "do not detect display". Catalyst is set to detect displays manually. Also, on the projector side I tried to disable any HDMI power smarts.

Any help is appreciated!
post #2 of 9
I feel your pain. I haven't found any solutions that don't involve a dedicated piece of hardware. The hardware makes it look your your display is on all the time to the pc.
post #3 of 9
This is all I can think of...it tricks EDID on the HDMI cable.

http://www.hdfury.com/products/dr-hdmi-getting-started/
post #4 of 9
Thread Starter 
It don't seem to "loose" the display when powering off the projector. Something seems to happen when powering it on. I wonder if disabling some W7 discovery service would help.
post #5 of 9
Thread Starter 
So, this is as simple if I power on the projector the display switches. When I power on I hear the typical Windows sound for recognizing a device. The same as plugging in a USB stick. Is there any way to get this fixed? Would it help if I switched off "auto discovery" of devices? Can that even be done on Win7?
post #6 of 9
Thread Starter 
After some more research I came across one potential solution. Disconnect the "hot plug" pin. Pin for reference: http://www.hdmi.org/installers/insidehdmicable.aspx

I have not tied it yet. I am still hoping for Win7 based solution.
post #7 of 9
Thread Starter 
Anybody came across a solution for this?
post #8 of 9
I'd been using Sony PJs for years and have always used it as the DEFAULT display device and my 19" in my equipment room on the VGA. When both the AVR and PJ are switched on the PC sees its default is available and automatically restores the SINGLE screen to that connection (HDMI). When I power off the PJ/AVR the display reverts back to the 19" VGA. BTW, only the HDMI is 1920x1080p, the VGA is like 1440x900 as I recall.

I don't use dual displays, just a default and alternate. Also, I have the AMD driver in CCC set to NOT auto-detect the EDID.

Let us know!
post #9 of 9

This was super annoying for me cause I use a HTPC (Home Theater PC) and the PC kept moving the contents from one monitor to the other when I switched their inputs.

I also tried blocking the pin on the HDMI... that gave me even more issues, also adjusting Windows, Video-card or registry was a total moot.

 

Anyway, this device took care of the monitor detection..


http://www.monitordetectkiller.com

 

I was surprised that it worked without any settings on the video card :)

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › Annoying display switch - How to disable monitor/display detection in Win7?