or Connect
AVS › AVS Forum › Audio › 2 Channel Audio › i need help with parts!! ka-880d
New Posts  All Forums:Forum Nav:

i need help with parts!! ka-880d

post #1 of 8
Thread Starter 
Hi everyone

First post here. I have a old Kenwood ka-880d. Its a nice amp. Ive had it for 5 years now but the amps about 25 years old. I'm pretty sure the power supply burnt out. It wont power on anymore. I've replaced the fuse. When I opened the cabinet I got a slightly plastic odor. No lights not a thing happens. I have no access to a shop within 3 hours. I'm up in the mountains. So I'm looking for parts. I've searched the model numbers and all the parts I've found are no longer available. I'm looking for sumthing that'll work to run my amp safely. Is my amp worth fixing?

Part number is. L01-7801-05
Atleast I believe that's the right numbers

Thank you all for your help
post #2 of 8
Quote:
Originally Posted by darkrider7589 View Post

Hi everyone

First post here. I have a old Kenwood ka-880d. Its a nice amp. Ive had it for 5 years now but the amps about 25 years old. I'm pretty sure the power supply burnt out. It wont power on anymore. I've replaced the fuse. When I opened the cabinet I got a slightly plastic odor. No lights not a thing happens. I have no access to a shop within 3 hours. I'm up in the mountains. So I'm looking for parts. I've searched the model numbers and all the parts I've found are no longer available. I'm looking for sumthing that'll work to run my amp safely. Is my amp worth fixing?

Part number is. L01-7801-05
Atleast I believe that's the right numbers

Thank you all for your help

You might want to check eBay to see if someone has a unit they are selling for parts.
post #3 of 8
Parts are almost certainly not available. If the parts could be found the price would be prohibitive. It's time to get a new amp. You might want to check the classified ads on the site here.



Quote:
Originally Posted by darkrider7589 View Post

Hi everyone

First post here. I have a old Kenwood ka-880d. Its a nice amp. Ive had it for 5 years now but the amps about 25 years old. I'm pretty sure the power supply burnt out. It wont power on anymore. I've replaced the fuse. When I opened the cabinet I got a slightly plastic odor. No lights not a thing happens. I have no access to a shop within 3 hours. I'm up in the mountains. So I'm looking for parts. I've searched the model numbers and all the parts I've found are no longer available. I'm looking for sumthing that'll work to run my amp safely. Is my amp worth fixing?

Part number is. L01-7801-05
Atleast I believe that's the right numbers

Thank you all for your help
post #4 of 8
Quote:
Originally Posted by commsysman View Post

Parts are almost certainly not available. If the parts could be found the price would be prohibitive. It's time to get a new amp. You might want to check the classified ads on the site here.

Why should anybody buy your NAD integrated when you have stated multiple times that it did not sound good?
post #5 of 8
Hi Darkrider,
Quote:
Originally Posted by darkrider7589 View Post

Part number is. L01-7801-05

Is that the part-number for the power supply? Or of a part in the power supply? Or of the amp itself?

If it's the power supply, then I would agree that you won't find someone selling one. But eBay may be a good source, as Arny said. The risk is that you buy one that is being sold for parts because the power supply is bad.

I would suggest repairing the power supply, as the individual components would certainly be available. Simple resistors and capacitors would be easy, but transistors might need to be cross-referenced. A deal-killer would be a burnt-out transformer. I have a lot of old 70's gear, and have had no problem finding parts. The challenge is determining which part is bad.

I don't know the quality of that particular model Kenwood, but as Commsysman said, it may simply be time for a new one. It depends on the time and effort you wish to spend.
post #6 of 8
Quote:
Originally Posted by beaveav View Post


Why should anybody buy your NAD integrated when you have stated multiple times that it did not sound good?

post #7 of 8
Have a look inside the amp and check for bulging/burst electrolytic capacitors. Might all that's wrong with it and easily sourced.
post #8 of 8
Thread Starter 
Thanks for the help everyone. I'm calling an end to this thread. More threads soon gotta pick a new receiver or amp. I have some ideas for speakers. So keep your eyes out round the forums. Ill be around.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: 2 Channel Audio
AVS › AVS Forum › Audio › 2 Channel Audio › i need help with parts!! ka-880d