or Connect
AVS › AVS Forum › Gaming & Content Streaming › Portable A/V › Help With Satechi Cyclone Micro 2+
New Posts  All Forums:Forum Nav:

Help With Satechi Cyclone Micro 2+

post #1 of 2
Thread Starter 
Not sure if this is the best place to put this but here it goes. I have been having a problem thats been driving me crazy. I use makemkv to rip the blurays I own and put them onto a usb and play it through the satechi micro. They all play fine. Naturally the videos are in 24 fps and I make sure the players setting is set accordingly. The problem I am having is every DVD I rip using makemkv plays on the cyclone, but it ends up being "choppy" "stuttery" or "juddery". This isn't the same as natural motion judder, the actual whole video will freeze for a half second and play doing this over and over about every 3 seconds. This occurs when I have the cyclone set to 60hz, which is what I thought I was supposed to do because the DVD runs a 29 or 30 fps. If I put it on 24hz it will not stutter nearly as bad, but the audio will be way off. This only occurs with every DVD I try to rip, and the blu rays work beautifully. Suggestions?
post #2 of 2
Thread Starter 
I ran one of the DVD's through handbrake on high profile and made sure to have the fps "same as source". Now the video and audio play perfectly, and the player is reporting the video is in 59 fps. This just doesn't make sense....
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable A/V
AVS › AVS Forum › Gaming & Content Streaming › Portable A/V › Help With Satechi Cyclone Micro 2+