or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › XMBC subtitle issues....help or suggestions?
New Posts  All Forums:Forum Nav:

XMBC subtitle issues....help or suggestions?

post #1 of 17
Thread Starter 
So, just installed the latest version of XMBC. Converted over from MediaBrowser with MPC-HC external. I was having way too many issues with MPC-HC minimizing or closing or ... just not working. It wasn't a big deal for me...but it was for the wife.

I have everything in XMBC working...I mean everything basically, besides subtitles.

A decent chunk of my 480 movies (let's say 100) have subtitles built into the video. Some are forced english (District 9, Star Wars), others are just the English track, and the rest are a mix or English, Russian, Netherlands and more.

My problem is that XMBC recognizes none of them. It automatically plays the first subtitle in the list regardless of the language. So, even though I'm currently watching Coraline and do NOT need english subtitles...it's playing them. And of course, XMBC is showing no subtitles as running, so there's no way to turn them off.

Is there any way for XMBC to recognize subtitles built into the video without physically extracting them and having them as a separate file or is this a limitation of the player?

If it is, it seems to be a gross oversight.
post #2 of 17
I'm assuming you're running the latest version of XBMC (12.0). While a video is playing, press 'm', go to the audio menu and then turn subtitles off. At the bottom of that menu there should be an option to make those settings the default for all video. Now, XBMC should only play subtitles if there's a forced flag. I know this at least works for my mkv's with forced PGS subtitles. Let me know if that works.

Also, I'm not sure if you've tried it, but Media Browser just released a new version (2.6) with much better external player support. Like you, I've had problems with external players in the past. It seems to be working pretty well so far, but it's too early to tell.
post #3 of 17
What he said. The option to change or turn off subs are located in the audio menu during playback.
post #4 of 17
I have a problem when I turn subtitles off that way. We are watching the Game of Thrones series at night and have no need for the automatic English subtitles but then when people speak in other languages that are supposed to be subtitled, we don't see those either... so we have no idea what they are saying. Can I not get it to just show the subtitles when it is in a language other than English?? I'm amazed that this is an issue.
post #5 of 17
I'm using this build:

http://forum.xbmc.org/showthread.php?tid=128935

It has support for forced PGS subs and HD Codecs. I use it like this:

1) Subs are turned off by default for all movies in XBMC>

Since MakeMKV still doesn't mark subtitle tracks properly:

2) I use the Header Editor in MKVMerge to change the subtitle track I want to see to forced. which means the forced subs for English movies, and the default English subs for foreign language films.

Works perfectly.
post #6 of 17
Quote:
Originally Posted by robnix View Post

I'm using this build:
http://forum.xbmc.org/showthread.php?tid=128935
It has support for forced PGS subs and HD Codecs. I use it like this:
1) Subs are turned off by default for all movies in XBMC>
Since MakeMKV still doesn't mark subtitle tracks properly:
2) I use the Header Editor in MKVMerge to change the subtitle track I want to see to forced. which means the forced subs for English movies, and the default English subs for foreign language films.
Works perfectly.

Yep, I tell makemkv to grab all forced subtitles. With Game of Thrones, each episode had two subtitle tracks, neither of which were marked by makemkv as forced. I also used the header editor in mkvmerge to fix it. The second subtitle for each Game of Thrones episode is the one you want to marked as forced IIRC. After that, XBMC will display them automatically.
post #7 of 17
Quote:
Originally Posted by lockdown571 View Post

Yep, I tell makemkv to grab all forced subtitles. With Game of Thrones, each episode had two subtitle tracks, neither of which were marked by makemkv as forced. I also used the header editor in mkvmerge to fix it. The second subtitle for each Game of Thrones episode is the one you want to marked as forced IIRC. After that, XBMC will display them automatically.

It will display them with subtitles off? I need to turn off subtitles from automatically playing too... but i think I can find that info elsewhere. So I have to know which track is supposed to be forced when I rip something like Game of Thrones (since you said MakeMKV showed neither as forced)?
post #8 of 17
Quote:
Originally Posted by bfhancock View Post

It will display them with subtitles off? I need to turn off subtitles from automatically playing too... but i think I can find that info elsewhere. So I have to know which track is supposed to be forced when I rip something like Game of Thrones (since you said MakeMKV showed neither as forced)?

MakeMKV will grab the forced subs, but doesn't set the proper for them, you have to do it manually. If you rip more than the forced subs you'll have to pick the right ones. Use the Header Editor in MVKMerge to set the correct subtitle track to "yes", it doesn't remux the files, takes a second or two that's it. You'll can then play the movie in the build I linked to to see if you get the forced subs in XBMC even with the default subtitle setting set to off. If you get the wrong track just run the file through the Header Editor again.

http://www.bunkus.org/videotools/mkvtoolnix/doc/mkvmerge-gui.html
post #9 of 17
Quote:
Originally Posted by robnix View Post

MakeMKV will grab the forced subs, but doesn't set the proper for them, you have to do it manually. If you rip more than the forced subs you'll have to pick the right ones. Use the Header Editor in MVKMerge to set the correct subtitle track to "yes", it doesn't remux the files, takes a second or two that's it. You'll can then play the movie in the build I linked to to see if you get the forced subs in XBMC even with the default subtitle setting set to off. If you get the wrong track just run the file through the Header Editor again.
http://www.bunkus.org/videotools/mkvtoolnix/doc/mkvmerge-gui.html

AFAIK, makemkv, for many if not most movies, does correctly tag the forced subtitles as forced. Game of Thrones is the first movie/show I've found where it didn't. I'm not sure why it works for some and not others.
post #10 of 17
Quote:
Originally Posted by lockdown571 View Post

AFAIK, makemkv, for many if not most movies, does correctly tag the forced subtitles as forced. Game of Thrones is the first movie/show I've found where it didn't. I'm not sure why it works for some and not others.

I used District 9, Star Wars, and Avatar as my test files for the XBMC build. MakeMKV ripped the forced subs on all of them, but didn't set the flags. This is with 1.7.5. Changing the flag with Header Editor fixed it.
post #11 of 17
Bumping an old thread ...

Editing the mkv to set the forced flag for the PGS subtite (using mkvmerge's header editor) did not make a difference in my case frown.gif

In addition to the Forced flag, do i need to set anything else

Text #1
ID : 4
Format : PGS
Muxing mode : zlib
Codec ID : S_HDMV/PGS
Codec ID/Info : The same subtitle format used on BDs/HD-DVDs
Language : English
Default : No
Forced : No

Text #2
ID : 5
Format : PGS
Muxing mode : zlib
Codec ID : S_HDMV/PGS
Codec ID/Info : The same subtitle format used on BDs/HD-DVDs
Language : English
Default : No
Forced : No

Text #3
ID : 6
Format : PGS
Muxing mode : zlib
Codec ID : S_HDMV/PGS
Codec ID/Info : The same subtitle format used on BDs/HD-DVDs
Language : English
Default : No
Forced : Yes
post #12 of 17
Nope - that's all that's required (but let me check my forced subtitles to ensure they are in the same format as yours - will get back to you shortly) - which xbmc build are you using?

EDIT - yes the same format and showing as it should.

Might want to demux and check with BDSup2Sub, or similar that they have been ripped correctly, or alternatively re-rip. Are you sure that is the correct 'forced' stream.
Edited by steelman1991 - 3/29/13 at 7:42am
post #13 of 17
Thanks steel man.

Yeah! This should be the correct stream. And I am using Frodo 12.1
I know which parts of the movie are supposed to contain forced subs. So if I explicitly enable this track ("Enable subtitles" in xbmc), then the subs show up where they are supposed to
I even tried an iso version of the same movie. Had the same problem. Forced subs didnt show if "enable subtitles" is de-selected

But good suggestion. Let me try some other titles.
post #14 of 17
Hmmm something not quite right - nothing like stating the obvious biggrin.gif

I use the same build - out of curiosity what movie are these from?
post #15 of 17
Maybe I need to keep that track enabled as well i.e. in addition to setting the forced flag, set the enabled flag?
If "Enable subtitles" is disabled globally, I wonder if the enable flag for the track will override this
Will try it when i get back home
post #16 of 17
Yup. Looks like thats the case
If the track's forced and enabled flags are set, then even if subtitles are disabled in xbmc, the forced subs get enabled (overriding the global setting)
Woohoo!
post #17 of 17
Sorry mate not with you on this one - what, if anything did you actually change to achieve the end result. Might be just me, but some clarification may help others with a similar issue.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › XMBC subtitle issues....help or suggestions?