or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Quick question: old = amp error now dead, what do I need to test before connecting new recvr
New Posts  All Forums:Forum Nav:

Quick question: old = amp error now dead, what do I need to test before connecting new recvr

post #1 of 2
Thread Starter 
I had an old receiver (RCA 4090) that I was using to hold me over until I got a new one. The receiver was working fine for about a month and then it started getting an "amp error" message, I thought it might be some bad wiring and narrowed it down to one speaker, I connected the speaker to a different port and no error appeared. I reconnected everything and it ran fine for a week and then gave me one last "amp error" message before completely dying.

I don't want to ruin my new receiver (yamaha rx v673) but if it is indeed a wiring issue is it something that should cause issues right away or is it something that slowly happens?

Basically, I'm unsure if the old receiver was just old or bad (it was about 10 years old before I acquired it) or if I have a wiring problem.

Thanks!
post #2 of 2
The good news is newer electronics have ample circuit protection, but double check all your speaker wiring anyway. Obviously, if the new unit goes into protection mode, then it's time to seriously troubleshoot.

I would not concern myself with a used 10 yr old RCA unit failing. That would be expected. biggrin.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Quick question: old = amp error now dead, what do I need to test before connecting new recvr