or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Subwoofer Amplifier Died - I need your help :(
New Posts  All Forums:Forum Nav:

Subwoofer Amplifier Died - I need your help :(

post #1 of 3
Thread Starter 
I have a FIVE year old Adire Daeva 15. Everything was completely fine until today.... It wouldn't turn on. I tried every plug, outlet, and switch- and nothing. The red LED never came on.

So AVS- what are my options now? I want to fix her up frown.gif. I should also mention I am a n00b who knows VERY little about these things. I seriously need your help on this.
post #2 of 3
Dig out the owner's manual ... it MIGHT be as simple as replacing a blown fuse (However, many times a bad amplifier causes the fuse to blow).

Good Luck,

Bill C
post #3 of 3
You can get a new fuse a Radio Shack if you are in a hurry. If, after replacement, the fuse immediately blows again, then you know that you amplifier is likely bad.

To do the repair yourself, you need the subwoofer service manual, a volt/ohm meter, and soldering equipment. Many manufacturers consider the service manual proprietary.

If you take the amp off the enclosure (sometimes they are glued down for a better air seal), you can check whether any capacitor is obviously blown or enlarged.

Amplifier repairs can cost $200-300+ and usually are returned with a 30-90 day guarantee. You can also contact the manufacturer because sometimes their repairs cost somewhat less (but you will need to pay return shipping).
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Subwoofer Amplifier Died - I need your help :(