or Connect
AVS › AVS Forum › Display Devices › Digital Hi-End Projectors - $3,000+ USD MSRP › Need help with JVC DLA X70
New Posts  All Forums:Forum Nav:

Need help with JVC DLA X70

post #1 of 9
Thread Starter 
Hello everyone, I just received my JVC dla-x70 back from JVC, When the lens cover opens there is a piece of rubber that surrounds the lense , I never noticed it before, I phoned JVC and they told me to remove it, I tried to pull it off without success, anybody else have this problem, Its a long weekend in canada any my dealer is closed till wednesday, thanks:)

Gear mentioned in this thread:

post #2 of 9
Try taking a high quality photo if you can and post it
post #3 of 9
Thread Starter 
450
post #4 of 9
Thread Starter 
450
post #5 of 9
Thread Starter 
I hope these pics help, thanks
post #6 of 9
It looks like the piece of rubber that fills the gap around the lens when you lens shift it. Don't remove it! It's normal. Just move your lens using lens shift on the remote, and you'll see why it's there.

As long as it's not in the way of the usable part of the lens (i.e. obscures part of the projected 1080p picture) it's not a problem.
post #7 of 9
I would wait and talk to your dealer, if you rip that out and you shouldn't have then you will have to send it to jvc for repair.

I would document who at jvc said to remove it
post #8 of 9
Thread Starter 
Thanks everyone, I just found out that its part of the seal to keep light from escaping out of the projector, they told me to take a pencil and with the eraser end to gently push back along the edges until it disappears, I can' t believe that customer service told me to rip it out in the first place. thanks for your help guys.smile.gif
post #9 of 9
Glad too hear it, enjoy my friend
New Posts  All Forums:Forum Nav:
  Return Home

Gear mentioned in this thread:

AVS › AVS Forum › Display Devices › Digital Hi-End Projectors - $3,000+ USD MSRP › Need help with JVC DLA X70