or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Def Tech SC4000
New Posts  All Forums:Forum Nav:

Def Tech SC4000

post #1 of 3
Thread Starter 
I got a buddy who is looking for a sub and he found a DT SC4000 that powers up,but no sound. I asked him if the guy selling it had opened it up to see if anything had blown,etc. and he hasn't. He's selling it for $75,but I'm not sure if he should take a chance on it to see if it's something simple or something major.
I'm not sure of the internals of the SC4000,so I'm not sure what could be wrong with it.So,should he or shouldn't he?Thanks
post #2 of 3
To be frank... I am not impressed with the Supercube 6000... And even less impressed with the SC4000... You should look elsewhere.
post #3 of 3
Quote:
Originally Posted by Scooby06 View Post

I got a buddy who is looking for a sub and he found a DT SC4000 that powers up,but no sound. I asked him if the guy selling it had opened it up to see if anything had blown,etc. and he hasn't. He's selling it for $75,but I'm not sure if he should take a chance on it to see if it's something simple or something major.
I'm not sure of the internals of the SC4000,so I'm not sure what could be wrong with it.So,should he or shouldn't he?Thanks

Could be something as simple as a loose connection, or it could be a bad amp or driver. Might be worth the gamble...
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Def Tech SC4000