or Connect
AVS › AVS Forum › Industry Area › HDMI Q&A - The One Connector World › HDMI Extender over Cat5E stopped working
New Posts  All Forums:Forum Nav:

HDMI Extender over Cat5E stopped working

post #1 of 2
Thread Starter 
I was using this model about half years and it worked perfectly with full hd resolution. But then suddenly it just stopped working. At first i did not receive any picture at all, after i got not so bad picture with 1280*1024, but it is flashing and flickering after i set resolution back to 1920*1080(this is what happens).

After i also tested TV next to computer with only 1m long cat5E cables and the result is same. I also tested it without HDMI-Cat5E extender to be sure if the TV or computer settings are OK and i received perfect picture, so i am 100% that the HDMI extender is broken(Power supply that gives 5V to HDMI receiver is also working fine).

So i have cull HDMI extender and i need to buy new set.
But is there any reason why this model worked only half year?
Maybe i should have used Cat6 cables instead of Cat5E(can this prevent damage to extender)?
Or maybe this model that i bought is known bad quality cheap converter and i should buy better one? Then which model is better?

Thanks for help and suggestions in advance.

Gear mentioned in this thread:

post #2 of 2
Those things fail all the time. I've replaced at least half a dozen of them this year for my customers. I can't recommend a good one to you because I haven't found one yet.

I think I'll try one of these next time I need a long run
http://www.rainbowfishcorp.com/Fiber-Optic-HDMI-Pro.html
New Posts  All Forums:Forum Nav:
  Return Home

Gear mentioned in this thread:

AVS › AVS Forum › Industry Area › HDMI Q&A - The One Connector World › HDMI Extender over Cat5E stopped working