or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Do I have a blown subwoofer?
New Posts  All Forums:Forum Nav:

Do I have a blown subwoofer?

post #1 of 4
Thread Starter 
I accidentally made my subwoofer thump while I was changing out the cables... I forgot to power it off while making the change.

Now the subwoofer sounds distorted, almost like static. I think I have blown my subwoofer driver, but I have no previous experience with what a blown driver sounds like.

Does anybody have any thoughts on what happened?

Thanks!
post #2 of 4
What's the possibility that your new cable is the issue? Not sure how loud/severe the "thump" was, but it seems to me that a sub should be able to survive more then that. Who makes the sub?
post #3 of 4
I love when stuff breaks, it always means you are getting something new!
post #4 of 4
Thread Starter 
Quote:
Originally Posted by JimWilson View Post

What's the possibility that your new cable is the issue? Not sure how loud/severe the "thump" was, but it seems to me that a sub should be able to survive more then that. Who makes the sub?
I switched cables and still have the problem. It's a MFW-15, so there aren't a lot of spare drivers around. However, with the the Seaton/Sandbagger Turbo Kits starting to ship, maybe somebody will have a spare driver to sell. However, I want to make sure that a blown driver is the problem and it is not the amp.
Quote:
Originally Posted by Reefdvr27 View Post

I love when stuff breaks, it always means you are getting something new!
The guy in me thought the exact same thing. smile.gif Unfortunately, the father and husband in me says that I should probably be more careful with my money. We've had a lot of unexpected expenses this past year. frown.gif
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Do I have a blown subwoofer?