or Connect
AVS › AVS Forum › A/V Control & Automation › Home Automation › Vantage Qlink installation
New Posts  All Forums:Forum Nav:

Vantage Qlink installation

post #1 of 4
Thread Starter 
My Windows XP computer died and I am trying to install Qlink on my new Windows 7 computer but am having problems. I would appreciate any input. I tried both the old version running on XP (4.2) and the latest version (4.8) and had different issues with both.

QLink 4.2 – Appeared to install correctly but when launched received the error ‘VComInterface.dll did not register correctly’. I tried Retry from that error which of course didn’t work. I tried reinstalling both first doing Repair and then Uninstall and then Install again with the same problem. The Qlink files are not associated with the program so I can’t open the program by clicking on the file but if I open QLink and ignore the error my file appears to load. However, I am hesitant to attempt to load anything into the Vantage system for fear of it corrupting what’s already there (and currently working).

QLink 4.8 – I figured I would see if 4.8 would install cleaner since it’s in the proper timeframe of knowing about Windows 7. However, this was even worse. I got the following error during installation:
‘The following files did not self-register or unregister’
C:\Windows\SysWOW64\OLEAVT32.DLL
Access Denied
C:\Windows\SysWOW64\STDOLE2.TLB
Error accessing the OLE registry


Has anyone had either of these problems and any/some idea what to do? Someone suggested installing using XP compatibility mode but I really do NOT want to do that for fear of messing up my new computer.
post #2 of 4
There is nothing to mess up by using XP compatibility mode. It is a standard feature of Windows 7. That said, using that mode is reserved for when a program doesn't run properly. You are getting serious install errors with a DLL not registering due to permission problems.

Try running the setup as Administrator (the thing you clicked on to install the program). Right click on it, get properties and go in compatibility tab and enable that. You can also try setting XP compatibility there to see if it helps.
post #3 of 4
Thread Starter 
Thanks a million. I uninstalled 4.2 and then reinstalled both versions using your instructions and I now have both versions properly installed.
post #4 of 4
That's great. I had never used either program but that seemed to be the problem smile.gif.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Automation
AVS › AVS Forum › A/V Control & Automation › Home Automation › Vantage Qlink installation