or Connect
AVS › AVS Forum › Display Devices › Rear Projection Units › Hi, guys, Got my hands on a used WD-82837
New Posts  All Forums:Forum Nav:

Hi, guys, Got my hands on a used WD-82837

post #1 of 7
Thread Starter 
HI, just got my hands on a wd-82837 set, now it has its problems, now for the first good news, It was only $100 On my local craigslist, second it turns on great picture but shuts off after 15-20 minutes, yes I replaced the lamp with a new one and it still does the same, now less frequently, sometimes it can run all day with out powering off, what could be the problem? oh, before it shuts down it flickers and powers off with error 34, lamp failure, on both lamps. Set only has 3200 Hours.
post #2 of 7
I don't know this for sure, as I know nothing about this particular set. But for older gens, this error pointed to a bad ballast or bad power supply (assuming we know the lamp is good). I'd suggest pricing both and replacing them if you're comfortable doing so. Good luck!
post #3 of 7
Thread Starter 
I opened up the set and no visible bad caps, i took out the ballast and retouched the solder in case it had cracks and has been working fine today. hasnt flickered or powered off for 2 hours
post #4 of 7
I have repaired 4 dlp's from Craigs list over the past several months. If lamp was replaced error code 34 is definitely a ballast issue. If you put in a new lamp why risk the investment when new ballast can be found on Ebay for as little as $25. I replaced the ballast on a wd-65737 and zero issues afterwords.
post #5 of 7
Thread Starter 
Thanks gman, thats what im aiming for, ballast arent that expensive, i think i saw one a shopjimmy with free 2 day shipping, what do you think about the wd-82837? my last tv, which im currently selling is a 62in model wd-62725, im trying to see if i can get $300 for it, it works fine is that a good price point?
post #6 of 7
Thread Starter 
gmanhdtv, well i had it working for about a week after going over the solder and adding more solder to the ballast, it did it again, already had order the ballast and replaced it, now its still doing the same, screen flickers and shuts the tv off with error code 34, what else could it be? error logs all say 34. The ballast gets power from the power supply or main board? could be a cap going bad or a cracked solder or what?
post #7 of 7
Quote:
Originally Posted by XCALIBURPCS View Post

gmanhdtv, well i had it working for about a week after going over the solder and adding more solder to the ballast, it did it again, already had order the ballast and replaced it, now its still doing the same, screen flickers and shuts the tv off with error code 34, what else could it be? error logs all say 34. The ballast gets power from the power supply or main board? could be a cap going bad or a cracked solder or what?

34 is a lamp cartridge failure. Replacing the lamp isn't enough, the entire cartridge needs to be replaced. Stay away from aftermarket lamps. The Mits lamp including cartridge is just $99 from Mitsubishi parts.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Rear Projection Units
AVS › AVS Forum › Display Devices › Rear Projection Units › Hi, guys, Got my hands on a used WD-82837