or Connect
AVS › AVS Forum › Display Devices › Digital Projectors - Under $3,000 USD MSRP › Need advice repairing/troubleshooting an optoma HD65
New Posts  All Forums:Forum Nav:

Need advice repairing/troubleshooting an optoma HD65

post #1 of 3
Thread Starter 
I have a Optoma HD65 that started failing, lamp wouldn't turn on and we thought it was a lamp problem, so we bought a new one, but it turned out to be another problem.

There is no official Optoma service (or unofficial for that matter) in my country, so we took it to someone that tested it and said that the problem was probably the ballast. From what I read it seemed plausible so I started disassembling it. Took out the ballast, expecting to find some obvious problem, burnt out components or something, but the ballast looks totally OK.

I'm wondering if someone with experience can tell me if there might be a chance of the ballast not working even if it looks absolutely fine, I don't want to buy one if it's obviously not broken. If I could test it in any obvious way it would be great too, maybe some test points, output voltage, etc.

I'm open to any other suggestions. Thanks,

Francisco
post #2 of 3
Hi theres an infrared sensor on the color wheel... Point your tv remote at a digital camera and you'll see the infrared light. Remove the sensor from the color wheel assembly put the color wheel back in place without it and plug the sensor back in.point that sensor toward your camera and see if theres any light.
post #3 of 3
Hi theres an infrared sensor on the color wheel... Point your tv remote at a digital camera and you'll see the infrared light. Remove the sensor from the color wheel assembly put the color wheel back in place without it and plug the sensor back in.point that sensor toward your camera and see if theres any light.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Display Devices › Digital Projectors - Under $3,000 USD MSRP › Need advice repairing/troubleshooting an optoma HD65