or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › Windows Closes Audio Stream When Paused
New Posts  All Forums:Forum Nav:

Windows Closes Audio Stream When Paused

post #1 of 24
Thread Starter 
This may or may not be related to the ATI silent stream bug...not sure, so I thought I would post it as a new thread.

When I pause any video (TV, BluRay, DVD) Windows stops sending audio to the Receiver. Naturally, I expect no sound when paused, but Windows is fully closing the audio stream. This causes my receiver to change to "no audio detected" mode. When I restart the video, it has to redetect the audio and then start to play it. This causes a 1 or 2 second loss of audio.

Is there any way to force windows to keep the audio stream open, in the same format it had been sending, instead of closing it? If it is the ATI silent stream problem, what revision of drivers solves this problem? Relevant specs of my setup are:



Onkyo 3010
Windows 7 64 bit
ATI 6570
DriverVer=08/09/2012, 9.000.0.0000 (9.00-120809a-145085E)
post #2 of 24
Thread Starter 
Any ideas anyone?
post #3 of 24
This only occurs with bitstreamed audio signals.
When you pause playback, there is no stream, therefore, no signal.
It is not related to ATI (or any other manufacturer), it is how bitstreaming works
post #4 of 24
Thread Starter 
So no way to fake a stream?
post #5 of 24
If it bothers you in a huge way, just stop bitstreaming.
It doesnt matter (to your ears) if your PC CPU or your AVR hardware decoded that stream.
The decoded audio is always PCM audio before it reaches your ears, no matter what device decoded it.

Of course, it will matter to your eyes because your avr will no longer display TrueHD or DTS-MA on its display.
post #6 of 24
Thread Starter 
SACRILEGE!!! BURN HIM!!! BBBUUUURRRRNNNN HIIIIIMMMM!!!!!!!!!!

smile.gif

I had not thought of that, to be honest. I will give it a test and see if I hear a difference. My AVR is outside my theater room anyway, so I do not get to see the lights - and Onkyo does not make the lights pretty regardless. I will shift to having TMT5 do the decoding. How do I make 7MC decode for TV shows?
Edited by cybrsage - 9/13/12 at 10:02am
post #7 of 24
Thread Starter 
OK, I just changed TMT5 to "convert to PCM" and tested Transformers: Dark of the Moon. The AVR said PCM on it, so there was positive confirmation of the change (when I changed it back, it said Dolby HD or something like that instead). It did not change the loss of sound. When I paused the program, the AVR lost connection to the audio stream and removed the PCM lights. It then had to resync when I turned it back on.
post #8 of 24
Your issue is not the silent stream bug (which was fixed in AMD drivers over a year ago). Your issue is your Onkyo and "Exclusive Mode" audio (which is what TMT5 is using for BD playback regardless of bitstreaming or decoding). Onkyos are notoriously slow for switching audio streams. Search for an app called HDMIOn which is supposed to take care of it.
post #9 of 24
Thread Starter 
Thanks! I will do so.

I just tried it and it does not do anything to fix the problem. I wonder if unchecking the "allow exclusive mode" will help.

EDIT: I do not mind going to shared PCM mode for everything and letting whatever player decode in the player itself.
Edited by cybrsage - 9/13/12 at 11:39am
post #10 of 24
It might. TBH, I haven't used TMT in so long I can't remember if this was an issue for me or not. But I have a Yammy so it was quicker on switching streams.
post #11 of 24
Thread Starter 
I am going to try WinDVD, since it operates very differently from TMT and see if it also has the issue. I have no idea how to change 7MC to make it stop bitstreaming and instead use a shared mode PCM.

EDIT: WinDVD has the same problem as TMT has when in bitstream mode (as expected). When I change it to PCM it no longer has the large pause.

EDIT EDIT: I unchecked the "allow exclusive mode" in the drivers and now everything works without the loss of sound after pausing. I will test later to see if the audio sounds better/worse/no different.

TMT and WinDVD no longer allow me to select anything other than Mix to PCM, which is fine provided my test later shows audio is not suffering because of it.
Edited by cybrsage - 9/13/12 at 12:24pm
post #12 of 24
Quote:
Originally Posted by vladd View Post

Your issue is your Onkyo...

I do test with AMD / NVIDIA and INTEL, video with integrated audio but I do own an Onkyo also.
So with his initial post possibly blaming AMD (drivers), I stepped in to let him know it is the same for all manufacturers.
I didnt realize or even think to place the blame on the Onkyo.
post #13 of 24
Thread Starter 
This is why I love this site...everyone knows a little about everything and when we are all combined together we know everything about everything. smile.gif
post #14 of 24
Quote:
Originally Posted by Shark007 View Post

I do test with AMD / NVIDIA and INTEL, video with integrated audio but I do own an Onkyo also.
So with his initial post possibly blaming AMD (drivers), I stepped in to let him know it is the same for all manufacturers.
I didnt realize or even think to place the blame on the Onkyo.
It's definitely not something that would spring to mind right away. I'm not even sure what tripped my memory banks on it.
post #15 of 24
Thread Starter 
OK...Obviously I am doing something wrong (or maybe it is just how things work).

I unchecked the "allow exclusive control" settings in the audio control panel and then TMT5 defaulted to Mix to PCM Uncompressed (as expected). The problem is then I only have Stereo Sound - or at least it appears that way. I do not have surround sound even though the Onkyo is set to use NEO:X (verified it at the recevier while the movie was playing). TMT5 says the audio is DTS Master during one of the movies, and I ensured the movie audio was set to English DTS Master 7.1 in the movie's options themselves. When I restore exclusive control and turn bitstreaming back on, I get full surround sound.

Any ideas?
post #16 of 24
I also have an Onkyo and have the same issue and I looked into fixing it but ultimately decided it was not that big of an issue. Whenever I pause/resume a video I just skip back a few seconds with MPC-HC and then hit play. It is two buttons instead of one but it allows the audio to resume at the right spot and also still bitstreams DTS/DD audio. My suggestion is try to adapt to the minor inconenvience rather then spending hours trying to put together a workaround.
post #17 of 24
Thread Starter 
That is what I have been doing, but a work around would be better AND make the wife happier. smile.gif
Edited by cybrsage - 9/19/12 at 6:23am
post #18 of 24
Quote:
Originally Posted by cybrsage View Post

OK...Obviously I am doing something wrong (or maybe it is just how things work).
I unchecked the "allow exclusive control" settings in the audio control panel and then TMT5 defaulted to Mix to PCM Uncompressed (as expected). The problem is then I only have Stereo Sound - or at least it appears that way. I do not have surround sound even though the Onkyo is set to use NEO:X (verified it at the recevier while the movie was playing). TMT5 says the audio is DTS Master during one of the movies, and I ensured the movie audio was set to English DTS Master 7.1 in the movie's options themselves. When I restore exclusive control and turn bitstreaming back on, I get full surround sound.
Any ideas?
Sounds like your default windows sound device is set to 2 channel output.
post #19 of 24
Thread Starter 
It does appear to be windows set to 2 channel, but it is not. I installed WinDVD as a test and it worked properly. I mentioned it to a well known Arcsoft Engineer who just reported back to me that he was able to reproduce the problem and that it most likely is a bug. I doubt it will get any attention, since I am most likely the only person who is using the software this way.
post #20 of 24
I've always said that WinDVD had the best audio implementation of the "big three". To bad the rest of WinDVD sucks. Hope ArcSoft fixes it for you.
post #21 of 24
Thread Starter 
Yeah, 7MC integration is sorely lacking in WinDVD. Oh, it creates an icon and I can setup MediaBrowser to launch it...but then it does not return when I hit stop. I have to hit the green button to return, not that doing such is difficult.
post #22 of 24
Probably because you cannot apply post processing to a PCM signal. A lot of receivers have that limitation.

i.e. - you cannot apply Dolby Digital EX or DTS NEO to a PCM signal. You can to a DTS or DD signal.
post #23 of 24
I didn't even think about that. I've been spoiled by my Aventage.

But I don't think that's his issue since WinDVD works as expected.
post #24 of 24
Thread Starter 
Quote:
Originally Posted by almostinsane View Post

Probably because you cannot apply post processing to a PCM signal. A lot of receivers have that limitation.
i.e. - you cannot apply Dolby Digital EX or DTS NEO to a PCM signal. You can to a DTS or DD signal.

Quote:
Originally Posted by vladd View Post

I didn't even think about that. I've been spoiled by my Aventage.
But I don't think that's his issue since WinDVD works as expected.

Yeah, the Onkyo 3010 has the umph to add post processing to any signal...one of the reasons I went back into the upper end after being forced to leave it when my Denon 3808 died an untimely (read that to say just a few months after the warranty expired) death and forced me into an emergency purchase. While I far prefer TMT5, I am using WinDVD 11 until/if they fix the TMT5 bug to keep the WAF high.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › Windows Closes Audio Stream When Paused