or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › JBL Venue Sub12 making odd sounds
New Posts  All Forums:Forum Nav:

JBL Venue Sub12 making odd sounds

post #1 of 12
Thread Starter 
I have a JBL Venue Sub12 subwoofer. Lately it's been making ODD sounds after it has been off for about 10 or 15 minutes. The sound is like a like a gurgling type sound with a brief rumble (not the good kind of rumble). Any idea what happening?
post #2 of 12
Off, as in powered off, or off as in standby mode?
post #3 of 12
Thread Starter 
Off as in standby.
post #4 of 12
Try disconnecting the RCA cable from your receiver. There may be some type of interference, and if so you'll need to isolate the source.
post #5 of 12
Thread Starter 
The sub has been in the same place for over 3 years. Just yesterday, 9/26/2012, installed a better, thicker cable but it still makes that odd sound after being on standby 10 or 15 minutes.
post #6 of 12
But does it make the same sound without a cable connected?
post #7 of 12
Thread Starter 
I'll have to give that a try later this evening.
post #8 of 12
Thread Starter 
It does not make that sound when I disconnect the cable, but about 30 minutes after I reconnect the cable it does make the sound.
post #9 of 12
Do you have cable TV?
post #10 of 12
Thread Starter 
Yes, Cox Communicaions is my cable provider.
post #11 of 12
You may have a ground loop issue. Although historically the noise associated to that is pretty consistent, it might not be a bad idea to consider using an isolator on your cable line. Another thing you may want to try is an electrical adapter to remove the ground path on your subwoofer.
post #12 of 12
Thread Starter 
Thanks. I'll have to look into that.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › JBL Venue Sub12 making odd sounds