or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › Subtitle question
New Posts  All Forums:Forum Nav:

Subtitle question

post #1 of 13
Thread Starter 
I use XBMC to watch movies. In general I have no interest in subtitles, unless the movie happens to switch languages. Since I don't speak Russian I miss the specifics of interrogations unless I switch subtitles on, but in general I don't want them for the majority of the movie. How do I have subtitles on that generally would be on in most movies when they are speaking some other language.
post #2 of 13
Quote:
Originally Posted by jefejt View Post

I use XBMC to watch movies. In general I have no interest in subtitles, unless the movie happens to switch languages. Since I don't speak Russian I miss the specifics of interrogations unless I switch subtitles on, but in general I don't want them for the majority of the movie. How do I have subtitles on that generally would be on in most movies when they are speaking some other language.

That depends on how the subtitles have been muxed in the file and the format you are watching them. Are you watching in an mkv container, or straight from the disc.

If you are using mkv files, you can check (using mkvmerge - part of the mkvtoolnix package) whether a seperate 'forced' subtitle stream is included with the file. Open mkvmerge, load the file, highlight the sub stream and check if its been ripped as 'forced'. If it has then xbmc will recognise it and play it automatically. If not and the 'forced' stream is available, again using mkvmerge, open 'header editor' identify the forced stream and change it to 'forced', then save the file.
post #3 of 13
Thread Starter 
I'm using makeMKV to rim and then compress to mp4 via handbrake. Is there a way to check still? Is there a forced subtitles setting in XBMC?
post #4 of 13
Are you including subtitles when you rip using makeMKV? Does handbrake allow you to retain the subtitles when compressing to mp4? To see if there are subtitles in your mp4 file just pause the movie while it is playing in xbmc and go to the audio options and see if you see subtitles tracks listed there.
post #5 of 13
Thread Starter 
I can select subtitles yes but I only want subtitles for the non English portion of the video
post #6 of 13
No experience with mp4 and/or handbrake sorry.

There is no setting in xbmc for 'forced' subtitles - only the loading and selection of all subtitle streams. With mkv's if the file has been ripped correctly and the appropriate subtitle flag set as 'forced', then xbmc automatically recognises the flag and displays the 'forced' stream - unfortunately don't know what happens with the format you are compressing to, or do I know a way of checking what flags are set.
post #7 of 13
Are you checking "Forced Only" on the subtitle tab in Handbrake?
post #8 of 13
I assume you are talking about Avengers. I'm working on that right now. For some reason my media players are having an issue showing subtitles after a fresh rebuild, haven't had time to look into it, BUT what I can tell you as a quick solution for just this movie is first, download a nightly build of HB as the official 098 does not support PGS subtitles from Blurays. Then in teh subtitle tab add English 3, and just check "Burn In", as default means nothing when you burn it in, and this track does not contain any forced subs (if you check "forced only" and "burn in" you won't get anything.
post #9 of 13
Are you guys sure the subtitles are supposed to show up on that scene? I watched it the other day directly from the 3D bluray optical media and there were no subtitles during the Russian interrogation. Unless its missing from the 3D media for some reason...
post #10 of 13
Thread Starter 
I am in fact talking about Avengers. I'm not really up to speed on nightly builds and other computer jargon. I'm kind of learning as I go. I guess at this point it will just be easier for me to turn subtitles on and off if needed. I'm guessing it would take me forever to figure it out. I was hoping there was an easy fix.
post #11 of 13
XBMC 11.0 should by default recognize forced subtitles and display them. Unfortunately, I've found that makemkv does not always flag forced subtitles appropriately. I had this problem with the Game of the Thrones Season 1 blu-rays. You should be able to check (and fix) the forced subtitles flags using mkvtoolnix.
post #12 of 13
Quote:
Originally Posted by natedogg661 View Post

Are you guys sure the subtitles are supposed to show up on that scene? I watched it the other day directly from the 3D bluray optical media and there were no subtitles during the Russian interrogation. Unless its missing from the 3D media for some reason...

Was this a standalone player or PC? There is a conversation in this scene. I still don't understand why every dumb player on the market can do this right but no PC software can.

Anyway as I understand it this subtitle is default but not forced. Make sure in Makemkv it (third English track) is set as default and it should work.
post #13 of 13
Quote:
Originally Posted by augerpro View Post

Was this a standalone player or PC? There is a conversation in this scene. I still don't understand why every dumb player on the market can do this right but no PC software can.
Anyway as I understand it this subtitle is default but not forced. Make sure in Makemkv it (third English track) is set as default and it should work.

It was a standalone player, Oppo BD-93. If I remember I'll confirm tonight. Maybe its a 3D thing.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › Subtitle question