or Connect
AVS › AVS Forum › Display Devices › Digital Projectors - Under $3,000 USD MSRP › Front Projectors Great Found Deals! › sony blu ray displays a blue screen instead of home page menu
New Posts  All Forums:Forum Nav:

sony blu ray displays a blue screen instead of home page menu

post #1 of 8
Thread Starter 
I have an Epson 710 HD projector connected to a Sony blu ray player and when ever I try to display the home menu, for instance to go to Netflix , my projector drops the signal and I get a blu screen.

Anybody know whats going on here?
post #2 of 8
Your projector is having problems re-syncing to the resolution of the player's home screen (probably 1080p). You might try configuring the player so it always outputs 720p so it matches the resolution of your projector.
post #3 of 8
Thread Starter 
Hey thanks for your suggestion.

I'm guessing that to reset the resolution to 720p I would have to be able to access the home screen menu. If so, then even doing that is a problem because all I get is a blue screen. Or, is there another way to do it?

If I were to connect it to another display and set it to 720p would it stay set or would that have to be something I would need to do every time I fire up the blu ray player?

Sorry for all the questions.

Thanks.
post #4 of 8
When using HDMI, sorry, yes, you'll need to use another display to see the home screen so you can step through the player's menu system.

However, if your projector has a composite video input (yellow coax), you might try using that connection. It should show the menu, too.

Once you've set the HDMI output to 720p, it'll stay that way.
post #5 of 8
Thread Starter 
Thanks again for your help...I will give that a try.
post #6 of 8
You're very welcome. Please let us know if it works.
post #7 of 8
Thread Starter 
Your solution for my problem did work. I set my players resolution to match the display (720p) and it now goes right to the home page. However, after a few minutes, for instance while I am browsing Netflix, it drops it again. I am able to power down then power on my sony A/V receiver and get it back but it drops it again after a few minutes. This only happens while I am on the Sony blu ray menu. This is not an issue whenever I am playing a disk or when I am watching TV on the cable box.

Any thoughts on this problem?
post #8 of 8
It might be the player's built-in screensaver, which comes on after the same image is shown constantly for several minutes. Perhaps it's always at 1080p. You might look in the player's menu for a way to disable the screensaver.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Display Devices › Digital Projectors - Under $3,000 USD MSRP › Front Projectors Great Found Deals! › sony blu ray displays a blue screen instead of home page menu