or Connect
AVS › AVS Forum › 3D Central › 3D Tech Talk › Help! PS3 won't recognize 3D Samsung 67a750 with Mits adapter
New Posts  All Forums:Forum Nav:

Help! PS3 won't recognize 3D Samsung 67a750 with Mits adapter

post #1 of 5
Thread Starter 
I was an early adopter of the Mitsubishi adapter for my Samsung DLP. The early method where I flashed the EDID of the TV. It used to work perfectly. Still works with my satellite box, actually. However, I haven't used it with my PS3 for awhile, and can't get it to work with my 320GB PS3 (and it worked fine with my old 60GB fat going through a Pioneer VSX 918). The new PS3 goes through a 3D ready Pioneer VSX 521. No matter what I do, when I run the display options setup on the PS3, it won't recognize that I am connected to a 3D display. I have the tv on the correct HDMI 3 input, and the tv allows me to select 3D mode. The Mits adapter powers on automatically with signal. I have tried running HDMI from the PS3 through the AVR to the Mits to the TV, and directly from the PS3 to the Mits to the TV.

I'm really stumped here. It used to work perfectly on the old PS3. I only used it for games, but it worked fine through the old non-3D Pio 918. Today I wanted to watch Prometheus, and it should work fine through the Pio 521.

I'm open to ideas!
post #2 of 5
I think the order is key as well is the the way it is connected. If I recall you have to connect the PS3 directly to the TV, and do the display set-up again so that it recognizes that your set is 3D. Once that is set you can turn it all off and set it up the way you want it to work.

When I did mine I think I actually went: PS3->3DA-1->Tv (powered on in reverse order: TV, Adapter, PS3). The key is to turn off the PS3 and then turn everything else back on and rerun the display settings. Try it connected both way, one of them should work.

There is a long, long, long 3DA-1 thread in here that may have better directions for making the PS3 work with the adapter:
http://www.avsforum.com/t/1280874/3d-on-samsung-1080p-dlp-with-mitsubishi-3da-1-and-no-gefen

Found this post:
Quote:
Once you flash the EDID and hook your PS3 up through the 3DA-1, you'll go into display settings and select auto configure...it should then say 1080p 3D supported and ask you to select your screen size for 3D.

Edited by nickels55 - 10/19/12 at 9:25am
post #3 of 5
Thread Starter 
Thanks, I was looking for that thread. I'll add my question on there and hopefully some of the vets from there can chime in.
post #4 of 5
In the Sony PS3, go back and redo the HDMI setup from the beginning. Often after software updates on the PS3 you have redo the HDMI setup from scatch.
post #5 of 5
Thread Starter 
Quote:
Originally Posted by nickels55 View Post

I think the order is key as well is the the way it is connected. If I recall you have to connect the PS3 directly to the TV, and do the display set-up again so that it recognizes that your set is 3D. Once that is set you can turn it all off and set it up the way you want it to work.
When I did mine I think I actually went: PS3->3DA-1->Tv (powered on in reverse order: TV, Adapter, PS3). The key is to turn off the PS3 and then turn everything else back on and rerun the display settings. Try it connected both way, one of them should work.


You can't power up the adapter before the PS3. It won't turn on until there is an HDMI signal present.

Quote:
Originally Posted by GEP View Post

In the Sony PS3, go back and redo the HDMI setup from the beginning. Often after software updates on the PS3 you have redo the HDMI setup from scatch.

Trust me, I've tried. Every combo I can think of. I have even reset the video on the PS3 by holding power until the second beep.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: 3D Tech Talk
AVS › AVS Forum › 3D Central › 3D Tech Talk › Help! PS3 won't recognize 3D Samsung 67a750 with Mits adapter