or Connect
AVS › AVS Forum › AVS Forum Information › Forum Operations Center › Compatible Browser Alert Message
New Posts  All Forums:Forum Nav:

Compatible Browser Alert Message

post #1 of 20
Thread Starter 
Hi,
I recently updated my OS to Windows 8 and it has Internet Explorer 10. The forum does not operate correctly unless I put the browser in Compatibility Mode. Even though the forum works correctly, I do get the following message at the top:
Quote:
You are using an outdated web browser.
AVS will be ending support for this browser soon. Please upgrade your browser to Google Chrome, Mozilla Firefox, or a newer version of Internet Explorer.
Any chance of supporting IE 10 soon? Some things that don't work are the editor, i.e., none of the text controls are available, i.e., Bold, Italics, Text align, bullets, etc. The features like the "search this thread" don't bring up the search input box and so on.
post #2 of 20
Compatibility mode rolls you back to IE 7 which is no longer supported. I'm not sure how much testing they've done on IE 10 since Win 8 hasn't even officially been released yet.

I'd suggest using Firefox or Chrome, at least for now.
post #3 of 20
Thread Starter 
Compatibility mode in IE can be set by the source via a meta tag, i.e.,
Code:
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8"/>

I wonder if the forum software can be set to do that. But, yeah, I already have Chrome and FireFox too, but I mainly use IE as my primary browser.
post #4 of 20
AVS is not the only place I go. I am staying @ IE7 to be compatible with my other sites.
post #5 of 20
I am on Internet Explorer 9 and am receiving this same error message. Please fix this.
post #6 of 20
Quote:
Originally Posted by Sherbona View Post

I am on Internet Explorer 9

In Compatibility Mode?
post #7 of 20
Thread Starter 
@Mike,
Have you had a chance to check if the forum software is able to set the meta tag I mentioned?
post #8 of 20
I only know the programmers said that Compatibility Mode wouldn't work in IE 8 & 9 because it's treated as 7. 10 being released may change some things in the near future though.

None of it seems to be an issue with Firefox or Chrome, no matter what recent version you're on.
post #9 of 20
@ Mike Lang

I am not in compatibility mode. I checked just now by hitting F12 and clicking on "Broswer Mode IE9. This shows me with checkmark next to "Internet Explorer 9", not "Internet Explorer 9 Compatibility View".
post #10 of 20
With compatibility mode off, IE9 works without issue currently. I'm using it to post this.
post #11 of 20
Thread Starter 
Quote:
Originally Posted by Mike Lang View Post

I only know the programmers said that Compatibility Mode wouldn't work in IE 8 & 9 because it's treated as 7. 10 being released may change some things in the near future though.
None of it seems to be an issue with Firefox or Chrome, no matter what recent version you're on.
When you set that meta tag, the browser will automatically recognize it and go into the IE8 Standards mode and will NOT show the Compatibility Mode option any longer. This is what you want. My company has an app that was designed for IE8 and did not work properly in IE9 in either normal or Compatibility Mode. So we used this meta tag to tell the browser to automatically use the IE8 standards. Your developers should be able to find that info on MSDN and what IE supports.

The tag above should suffice for IE 8, 9 and 10 if the forum software can add it to the output page. It's recommended that it goes in the header section if that helps.
post #12 of 20
@ Mike Lang

Unfortuantely today I still see that 'outdated web browser' alert message at the top, yet I am also using IE9 and am not in compatibility mode. It appears there is something else, probably on the user side/machine, that can trigger that error message besides actual browser version/mode.
post #13 of 20
oops, I just assumed I wasn't in compatibility mode today since I didn't see the symbol But based on what AYColumbia said I doublechecked by hitting F12 and then going to mode and sure enough this site had automatically and transparently put me in compatibility mode. I manually changed it out of this and the warning message has gone away. Thank you.
post #14 of 20

You are using an outdated web browser.

I am getting this banner telling me I have an outdated browser. . .

Since when is Explorer 9 outdated?
post #15 of 20
In Compatibility Mode?
post #16 of 20
Quote:
Originally Posted by Mike Lang View Post

In Compatibility Mode?

I haven't clicked on it but I did press F12 and I see that AVS has automatically put me in IE9 Compatibale View. So how do I stop this from happening? No - I don't want one of the other browsers.
post #17 of 20
I have IE9 and there is no "Outdated browser" banner. Pressing F12 shows Browser Mode: IE9.

Lee - If you're using IE9 and are not in compatability mode, hitting F12 will show Browser Mode: IE9

If your'e getting the banner on the webpage while your browser is in IE9 mode, I don't know what's wrong.
post #18 of 20
Quote:
Originally Posted by sebberry View Post

I have IE9 and there is no "Outdated browser" banner. Pressing F12 shows Browser Mode: IE9.
Lee - If you're using IE9 and are not in compatability mode, hitting F12 will show Browser Mode: IE9
If your'e getting the banner on the webpage while your browser is in IE9 mode, I don't know what's wrong.

LOL - Guess what? I no longer see the banner.
post #19 of 20
Quote:
Originally Posted by Lee Stewart View Post

LOL - Guess what? I no longer see the banner.

If IE is going to break itself, the least it can do is heal itself too. cool.gif
post #20 of 20
Quote:
Originally Posted by sebberry View Post

I have IE9 and there is no "Outdated browser" banner. Pressing F12 shows Browser Mode: IE9.
Lee - If you're using IE9 and are not in compatability mode, hitting F12 will show Browser Mode: IE9
If your'e getting the banner on the webpage while your browser is in IE9 mode, I don't know what's wrong.

I was getting the same message for IE9 64-bit. Turns out that I had Browser Mode as IE9 compatibility mode, and Document Mode as IE7 for some reason.

At least for the moment, turning off Browser compatiblity mode and setting Document Mode to IE9 standards may have 'fixed' the problem.

Edit - apparently it's still not so fixed. In both IE9 32 and 64-bit browsers, it seems like the Browser is forced into IE9 compatibility mode when the AVS site is entered. This can be fixed in F12, but I've had to do it every time I go to AVS.
Edited by sdrucker - 11/2/12 at 10:07am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Forum Operations Center
AVS › AVS Forum › AVS Forum Information › Forum Operations Center › Compatible Browser Alert Message