or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › HTPC - Mac Chat › EyeTV and Recordings with Zero Length
New Posts  All Forums:Forum Nav:

EyeTV and Recordings with Zero Length

post #1 of 14
Thread Starter 

I was wondering if other folks ever encounter recordings with a zero length?

I'm using a Mac Mini Core2Duo 2.4 GHz with two Elgato Hybrids. The Hybrids are from 2007 and 2008.

After getting the zero length recording last night, I tried opening (file->open next live tv window) both tuners and one of them wouldn't open. I assume that's the tuner EyeTV chose and produced the zero length recording with. The problem tuner gave the message “Device could not be initialized”. I unplugged it and replugged it and it was fine.

On a prior day, I was doing some testing and got that “Device could not be initialized” multiple times. This occurred with the computer on the whole time while I was playing with the deinterlacing options.

Could this mean one of the tuners is getting ready to fail?

Is the HDHomeRun more reliable than USB based tuners? It seems to be cheaper.

Thanks for reading.
post #2 of 14
This is from memory, pdugg, and a fading memory at that since I have only ever owned firewire and ethernet EyeTV tuners, but many users reported that bus-powered USB tuners were much more prickly than those other tuner types. Pulling power for two bus-powered USB stick tuners on the same Mac, recording two HD shows over that same USB bus never seemed like a good idea, even though there were some who reported no problems doing so. Firewire could handle that with no problem, longtime Mac users know USB is a very different animal. So first thing I'd do is just use one of the cheap USB sticks for awhile and see if you get any zero length recordings. If that goes OK for a while, try plugging the 2nd tuner in and instead of opening any "live tv" windows, just try to record in the background. Start recording one show from the guide, then try to start recording a different one a few minutes later, again, with no live tv windows open.

Obviously, you should be recording to the internal drive and not to another external USB drive.

There was a zero length recording issue many many years ago that had nothing to do with USB tuners, it had to do with EyeTV waking up and recording to external hard drives that didn't wake up in time to be recorded to. But that was ages ago, perhaps in Tiger or Leopard? Hasn't happened to me for a long time, but that is one possible avenue for you to explore, changing the location of your EyeTV archive. But your issue most likely is related to USB power and bandwidth. (I had a EyeTV 250 Plus for a while which was a powered USB tuner and never had any issues with it. But that was the only thing I had over USB at the time.)
post #3 of 14
Originally Posted by chefklc View Post

.... "I had a EyeTV 250 Plus for a while which was a powered USB tuner and never had any issues with it. But that was the only thing I had over USB at the time." ...

Rest of previous response sounds sensible. Just wanted to add that I had been getting zero-length recordings and error messages with a 250+ tuner (which delivers its data over USB but gets its power from an external brick). I traced the problem to the (failing) brick; Elgato replaced it, & that fixed it. Now running 2 of these tuners on a 2009 Mini (SL) with no problems.

The theory that the Hybrid may overtax the USB bus power supply makes sense. Anything else taxing the OP's USB bus ought to be removed as a test.
post #4 of 14
I've had this a few times in the past. I've found the EyeTV software isn't the most stable piece of software ever written! Basically the longer you have EyeTV running the higher the chance of a USB tuner failing. For example, I now either quit EyeTV or shut down my mac mini each night and this seems to keep the problem at bay. However, if I just sleep my mac and keep EyeTV running, I can guarantee that after 2 or 3 days I'll have zero length recordings or a 'failed to initialise device' message. I'm using an EyeTV Diversity and a DTT both on separate USB buses.
post #5 of 14
Thread Starter 

How do you determine what USB bus a tuner is on?
post #6 of 14
I only know from this article about Mac Mini USB ports: http://blog.fosketts.net/2009/03/10/mac-mini-diamond-rough/

Using the info in the article, I make sure that I've only got one EyeTv device on each USB bus.

Whether there's a way in OSX to see which USB bus a device is on, I don't know.
post #7 of 14
How do you determine what USB bus a tuner is on?

Whether there's a way in OSX to see which USB bus a device is on, I don't know.

You can find your USB device tree under About this Mac > More Info > System Report > Hardware > USB
post #8 of 14
I have multiple HDHomeRun's and do find that EyeTV 3 will sometimes produce empty recordings.
As another poster stated, EyeTV is not the most stable/high quality app. I leave my system on 24/7 and fnd that I need to peropdically reboot the machine.
After a while, the video rendering degrades with time such that the system is not capable of smoothly rendering the mpeg2 bitstreams and reduces the frame rate, ie drops frames while decoding, which is very annoying on a 2010 Mac Pro machine.
Its pathetic that mac's cannot utilize hardware acceleration for decoding mpeg2 ts's thanks to apples business model intentionally preventing it.
post #9 of 14
Well that's interesting. I'd always assumed it was a problem with the software and USB tuners and had been considering getting a Netstream device as a solution but as you're having the same issue with a network device it must be the actual software which is the problem.
post #10 of 14
I think it is some bug they introduced to the software. I've read somewhere that those zero length recording didn't happen with 3.5.3. I had no problems since downgrading. Actually, out of curiosity, I just updated again to 3.5.6 yesterday only to find out that the problem still persists. Pretty poor considering that the EyeTV Hybrid is an Elgato product an officially supported...

My suggestion is to go back to 3.5.3 and see whether this works for you as well.
post #11 of 14
Just registered in order to add to the experiences in this thread.

I'm running the latest (3.5.6 build 6917) eyetv software on a powerful Mac Pro 2010. I have an eyetv hd connected to the machine via USB.

In the last month or so, I've noticed zero-length recordings as well as an occasional inability to "open new live tv window".

As was the case for a user above, simply unplugging the tuner USB and reconnecting it resolves the symptom(s).

I first suspected a USB hub power issue and connected the tuner directly instead of using a powered hub. Did not fix problem. It happened again a day or two later.

I did not see a relationship between the inability to open a live tv window and the zero-length recordings. I suspected my hard drive was full, causing the software to return an error. This was not the case.

It would appear that a problem with the eyetv hardware AND/OR the eyetv software causes the tuner to become unavailable. Based on anecdotes in this thread, I suspect the problem is software-related, possibly having to do with leaving the application running at all times (with or without a live TV window open), or with the computer going in and out of standby/sleep/etc.

I am aware of many users with wake-from-sleep issues after upgrading to Mountain Lion -- perhaps there is a connection.

I do everything with this computer remotely/automatically, so I will try to have the EyeTV software closed and re-launched once a day to see if that resolves the problem.

One interesting note as a remote user: rebooting the Mac Pro does not "fix" the tuner failure. The USB cable from the EyeTV HD tuner to the computer must be physically disconnected and reconnected. This probably means something hardware-ish is going on, but I don't know what.

EDIT: corrected EyeTV software version number.
Edited by bradjshannon - 12/17/12 at 9:25am
post #12 of 14
I had the same problem with the EyeTV HD and had to RMA it. Unfortunately, I still had the same problems with the new one, but I gave up and switched to Windows/Ceton card confused.gif
post #13 of 14
I can concur with bradjshannon. Once the USB device fails to initialise resulting in zero length recordings it needs to be unplugged and plugged back in again to get it to work again. However, I have found that setting my Mac Mini to reboot every morning prevents the zero length recordings/device failed to initialize from happening. I'm running EyeTV 3.5.4 on OSX 10.6.8. Haven't upgraded as this configuration has been stable for me for a while.
post #14 of 14
Also running ETV on OSX 10.6.8, using two ETV 250+ AC-powered tuners. Was running ETV 3.5.2 on my MBP, saw no need to change version as it ran well. Had to reinstall on Mini after a crash, now running 3.5.1, still no problems or zero-length recordings, just a rare stutter associated with low signal strength.

Agree that the current reports of recording lapses may be about an OSX-ETV version conflict, since my combo is working for me. I had been reading, IIRC, that Mountain Lion had solved most ETV conflicts with Lion, so suggest going back to an earlier ETV version to resolve this one.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HTPC - Mac Chat
AVS › AVS Forum › Video Components › Home Theater Computers › HTPC - Mac Chat › EyeTV and Recordings with Zero Length