or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Strange, semi-intermittent issue with my LG LCD
New Posts  All Forums:Forum Nav:

Strange, semi-intermittent issue with my LG LCD

post #1 of 6
Thread Starter 
Hi all:

I have an LG 47LC7DF.

Here is my issue. Nearly EVERY time I turn it on (cold start), the led indicator light switches from red (off) to flashing green - normal for startup. Then, it registers to green when it is done booting up (normal, indicating on). However, I do not get the "no signal" indicator that moves about on the screen, and if my input device is switched on, I get no audio or video. I just have a blank screen, and it DOES look like the backlight is working, as it is a very bright black screen. Now if I switch off the tv (which takes a long time and multiple button pushes, akin to a frozen/unresponsive pc) and switch it back on, as few as 1 time and as many as several times, eventually it will "connect" to the input and either start displaying video/audio if the input device is switched on or display the normal "no signal" on screen if the input device is switched off.

I tried to google this but it proved difficult since this is an unusual problem and a bit lengthy to describe. I've lived with it for a while but at this point it's driving me nuts. Need to figure out what the issue is and decide if it's time to brick and replace it or if it can be fixed.

Any help is appreciated.
Edited by 123 - 11/15/12 at 12:41pm
post #2 of 6
Thread Starter 
anyone?
post #3 of 6
Thread Starter 
Some google sleuthing seems to indicate a problem with the main board. Though I wasn't able to find any instances with an intermittent issue, i.e. the tv still can work some of the time. Once I "connect" to my input, it lasts as long as I keep the tv on. What do you all think, does it sound likely that there is a problem with my main board?
post #4 of 6
Thread Starter 
So more internet searching led me to try leaving it on in that "blank state" to warm up. Sure enough, when the tv is "warmed up" I can shut it off and turn it on and it turns on fine. So now I am very confused - The main board (used, out of a previously working tv) costs about $150 so I don't want to just buy one with only a possibility of fixing the issue. Any insights?
post #5 of 6
Thread Starter 
Just for future reference, it turned out to be some bad capacitors (obviously leaking) on the main board. I bought new capacitors for about 25$ and replaced the 5 leaking ones - simple pluck out and sauder in the new ones. Good as new!
post #6 of 6
Quote:
Originally Posted by 123 View Post

Just for future reference, it turned out to be some bad capacitors (obviously leaking) on the main board. I bought new capacitors for about 25$ and replaced the 5 leaking ones - simple pluck out and sauder in the new ones. Good as new!
Well played sir, I had the same issue with an old Mitsubishi that I loved! It's still going strong in a relatives garage lol
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Strange, semi-intermittent issue with my LG LCD