or Connect
AVS › AVS Forum › Home Entertainment & Theater Builder › Theater Room Items & Accessories › MoviePoster - Virtual movie poster display software.
New Posts  All Forums:Forum Nav:

MoviePoster - Virtual movie poster display software. - Page 11

post #301 of 750
Quote:
Originally Posted by loma View Post

Thanks Meyer. Will try setting up custom lists and also await the release to see if it corrects the error.

I did send you my email address.

Meyer: I have been running MP for a few hours with no errors. This is after not running Trailers. It therefore looks like the error may have been caused by the Trailers.
post #302 of 750
With reference to using the Raspberry Pi and XBMC with MoviePoster, I recently discovered that Yatse has a PC-based remote app that "sniffs" info from XBMC on the Pi called Yatse 2. I don't know if this would be of any help in getting MoviePoster to work with the Pi or not.

I am sure that you already know of the issues/hurdles that you would face in getting MP to work with the Pi, but I would be willing to donate a Pi board with XBMC installed if it would help with the development. Ever since I have seen this thread, I've been dying to get this working in my theater. I've got a 22" LCD monitor waiting for the proper compatibility. Hopefully Yatse 2 will help give you some insight.

Yatse
post #303 of 750
Thread Starter 
Quote:
Originally Posted by bugman72 View Post

With reference to using the Raspberry Pi and XBMC with MoviePoster, I recently discovered that Yatse has a PC-based remote app that "sniffs" info from XBMC on the Pi called Yatse 2. I don't know if this would be of any help in getting MoviePoster to work with the Pi or not.

I am sure that you already know of the issues/hurdles that you would face in getting MP to work with the Pi, but I would be willing to donate a Pi board with XBMC installed if it would help with the development. Ever since I have seen this thread, I've been dying to get this working in my theater. I've got a 22" LCD monitor waiting for the proper compatibility. Hopefully Yatse 2 will help give you some insight.

Yatse


While I'd be very happy to accept a donation of a Pi board, you may be able to do what you want already.
MoviePoster does integrate with XBMC in very much the same way that Yatse does. It uses the XBMC http server and JSON to communicate. This allows MoviePoster to run on a completely separate PC as XBMC, even if XBMC is running on a different platform. I have tested this with machines running XBMC for windows as well as OpenElec (linux). XBMC versions 11 and 12 are supported, although there was a bug that broke it in 12.1 and 12.2 which is fixed in my dev build. I havent tested it with xbmc running on the Pi, but i cant think of any reason that it wouldn't work.

So, XBMC can be running on the Pi, as long as MoviePoster is running on a windows machine and the network settings in both are configured appropriately.
I would be interested in poking around on the Pi though, as I know a lot of people would love to see MoviePoster run on the Pi itself instead of windows, but I cant make any promises.
post #304 of 750
I just Installed this and it looks really awesome and really easy to set up, everything seems to work ok, except when I play movies it will not show the poster for whats is currently playing. In the log file I get this error "Error updating media information from XBMC - Object reference not set to an instance of an object." I'm running the latest version of XBMC on a windows 7 PC It says it is connected to xbmc, web server is running in xbmc and "allow programs to control this system" is turned on. Any Ideas?
post #305 of 750
Thread Starter 
yeah, there is a bug in the current release that breaks the communication between MoviePoster and xbmc 12.1 and 12.2, (works fine on 11.0 and 12.0). It's fixed for the next release. I have a few things to polish up before the next release is ready, but hopefully it will be within the next week.
post #306 of 750
Downgraded to 12.0 and its working great now! Thanks so much smile.gif Also sent a small donation to show my appreciation and eagerly awaiting the next version smile.gif
Edited by scooter1974 - 5/26/13 at 7:38am
post #307 of 750
Quote:
Originally Posted by loma View Post

Meyer: I have been running MP for a few hours with no errors. This is after not running Trailers. It therefore looks like the error may have been caused by the Trailers.

Did you see this post?
post #308 of 750
Thread Starter 
yes i did. I suspect the next release will help your issues a lot. there have been a lot of under the hood improvements to improve efficiency. ive had a dev build running 24/7 for weeks now with absolutely no stability issues.
post #309 of 750
Quote:
Originally Posted by meyer64 View Post

yes i did. I suspect the next release will help your issues a lot. there have been a lot of under the hood improvements to improve efficiency. ive had a dev build running 24/7 for weeks now with absolutely no stability issues.

Thanks. Waiting patiently!
post #310 of 750
Meyer64 - re post 123 any way you would be willing to make me something similar ... I need a motion sensor for my tv as well .. as its dedicated wall mopunted as a movie poster but would be ideal if it could detect motion and turn on as needed?

I'd be willing to pay you for your time and trouble...

Ryan
post #311 of 750
Thread Starter 
Quote:
Originally Posted by rmwilson View Post

Meyer64 - re post 123 any way you would be willing to make me something similar ... I need a motion sensor for my tv as well .. as its dedicated wall mopunted as a movie poster but would be ideal if it could detect motion and turn on as needed?

I'd be willing to pay you for your time and trouble...

Ryan
Yeah, we might be able to work something out. I'll send you a PM.
post #312 of 750
meyer: How's progress?
post #313 of 750
Thread Starter 
I downloaded and installed the media browser 3 server component tonight and so far I'm quite impressed. The API is pretty complete and it looks like it will be fairly straight forward to get to work with movieposter.
post #314 of 750
Quote:
Originally Posted by meyer64 View Post

I downloaded and installed the media browser 3 server component tonight and so far I'm quite impressed. The API is pretty complete and it looks like it will be fairly straight forward to get to work with movieposter.

Great. Can't wait. Thanks.
post #315 of 750
Thread Starter 
As some of you are aware, I started to put together a website for the MoviePoster software. Its still very much a work in progress, but feel free to check it out.
http://www.movieposterapp.com

As of version 1.0.1.6, MoviePoster will support motion posters in video formats, not just flash like previous releases. The video formats tend to have a lot higher quality than flash or gifs too. Eventually, I'd like to make the retrieval of these automatic, but for now its still a manual process. But to help you out I started to index some links to many motion posters I have found. You can find the links here to start adding them to your poster library. I'll keep adding links as I find them. If you know of any I don't have listed, please send me a PM and I'll get them on the list.
post #316 of 750
So what am I doing wrong? It says no connection at the bottom of the poster screen and the web admin page cant connect

Capture.PNG 70k .PNG file
post #317 of 750
Thread Starter 
for your IP address setting, that's for the IP of an XBMC machine that you'd like to show 'now playing information from. Just put the IP there, no 'http://' if its the same machine then 127.0.0.1 is what you want. This is what the connection status on the bottom of the screen is for. its nothing to do with the web remote. if your not using xbmc or don't care about the Now playing feature, don't worry about it.

As far as the web remote, it could be a couple things.
In the current release, the settings window opens by default when the application launches, but the web server doesn't actually start until after the settings window is closed. So it might be as simple as closing the settings window and trying again.
This has been fixed for the next release. And I've even added a handy dandy little button in the settings window to open the web remote on the local machine to make it nice and easy to get started.

i can't tell from your screenshot but make sure the page url is correct. it needs to end in .html not .htm
post #318 of 750
Cool, that did it! It is connected to XBMC now also (everything is on one HTPC)

Thanks!
post #319 of 750
Thread Starter 
MoviePoster 1.0.1.6 is now available for download at http://movieposterapp.com As always, please view the readme and changelog for info on new features, changes, etc. Report any bugs or feature requests in this thread, PM me, or contact me by email at movieposterapp@gmail.com
This release includes optional registration. Anyone who has sent me a donation should have already received a registration code by email. If you haven't, please let me know and I'll get you one right away.
post #320 of 750
Hey, i really like your software but i have a problem with XBMC 12.2 on windows 8 als tried it with a raspberry pi but the same problem. The log file gives this error:

11/06/2013 11:31:08 - XBMC Version is: 12.2
11/06/2013 11:31:08 - Error updating media information from XBMC - Input string was not in a correct format.

if you need more info just ask.
post #321 of 750
Thread Starter 
Quote:
Originally Posted by sompie View Post

Hey, i really like your software but i have a problem with XBMC 12.2 on windows 8 als tried it with a raspberry pi but the same problem. The log file gives this error:

11/06/2013 11:31:08 - XBMC Version is: 12.2
11/06/2013 11:31:08 - Error updating media information from XBMC - Input string was not in a correct format.

if you need more info just ask.

Are you using the newest version that was released yesterday?
post #322 of 750
yes I downloaded it today
post #323 of 750
Thread Starter 
double check all the port settings in MoviePoster and make sure you have the webserver and the option for control from another machine turned on in xbmc settings under services. my test environment is on a win 7 machine, but i'll set up a win 8 box to see if i can reproduce the error, although i cant see how it would make a difference unless its a firewall issue.
post #324 of 750
I've checked all settings everthing is correct. The movieposter app and the xbmc are on the same host. The app tells me it is connected but nothing shows when i play something and i still get the same error. I'm going to try it on a different machine i will let you know
post #325 of 750
Thread Starter 
are you using a password for the xbmc connection? if not, try to add one and see if it makes a difference.
post #326 of 750
i've added a pass didn't resolve the problem. tried to connect from windows server 2012 same problem will try from a windows 7 now and check if the problem is gone
post #327 of 750
okey i got i working sort of. XBMC running on windows 8 and movie poster app running on windows 7 and everything works so the problem is with Windows 8
post #328 of 750
Thread Starter 
ok. thanks for testing and tracking down the problem. I'll set up a test environment later today and see if i can find a work around.
post #329 of 750
Hi meyer. Downloaded but need some clarification setting up EventGhost and Motionposters. Can you provide a sample of the EventGhost setup? For the motionposters, are they to be placed in their own folder in MoviePoster Cache Movies? Thanks.

Is it intended that the path for the custom posters will be seen on screen?
Edited by loma - 6/11/13 at 9:49am
post #330 of 750
Thread Starter 
Are you trying to have MoviePoster send events to EventGhost or EventGhost send commands to MoviePoster?

To set up EventGhost to send commands to MoviePoster, download the plugin, extract the zip and copy it to the EventGhost Plugin directory. (ex: C:\Program Files (x86)\EventGhost\plugins)
The next time you open EventGhost the plugin will be available to add to your configuration tree. To do this, select 'Add Plugin' under the 'Configuration' menu. You'll be able to find the MoviePoster plugin under the 'Program control' heading. When you first add the Plugin it will prompt for configuration of the host IP and port. You can always change this later under the plugin configuration. The plugin can automatically add Actions to your configuration tree to make setting up Events and Macros a bit easier. So say OK when you get prompted for that option. Now you should have a MoviePoster folder in your Configuration tree with a list of actions under it. You can test the actions, by right clicking on them and selecting execute. Now you just need to set up any events and macros that you'd like to have use the actions.

To set up MoviePoster to send events to Eventghost you need to enable the 'Network Event Receiver ' plugin in EventGhost. You can find it under the 'Other' heading in the plugin list. Configure the settings so the they match what you have in MoviePoster on the 'Monitor Control' tab. The IP address in the MoviePoster EventGhost settings should be set to the IP of the machine running EventGhost if it is a separate PC. Now when you press the Test Command buttons you should see events generated in the EventGhost Log. You can drag events from the log to a macro that you want executed whenever the event occurs.

Motion posters should be stored within a cached directory for a movie with -motionposter appended to the name. Be sure the show motion posters if available option is turned on.
an example of a cached folder structure is below. if you are using a .flv file, an html will also be automatically generated to host the flash document.

MoviePoster Application Folder
+Cache
+Movies
+tt1345836-The Dark Knight Rises
-tt1345836-The Dark Knight Rises-trailer.mp4
-tt1345836-The Dark Knight Rises-motionposter.mp4
-tt1345836.nfo
-79iOLF6sCNfHoQ7hNofApAwdzoY.jpg

Edited by meyer64 - 6/11/13 at 11:11am
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Home Entertainment & Theater Builder › Theater Room Items & Accessories › MoviePoster - Virtual movie poster display software.