or Connect
AVS › AVS Forum › Audio › Audio theory, Setup and Chat › Help with lg blu-ray surround sound system
New Posts  All Forums:Forum Nav:

Help with lg blu-ray surround sound system

post #1 of 8
Thread Starter 
Hey guys, I need some help getting my ss system working with my TV. First off, here are the model numbers:

Blu-ray ss: LG BH6820SW
TV: LG LM7600
Cable set-top: generic Scientific Atlanta DVR

All I'm trying to do is get the speakers from the surround sound system to work whenever watching *anything* on the TV... i.e. when playing a movie from a usb drive, or just watching cable from the set top box.

I currently have the cable box connected via hdmi to the hdmi1 port on the TV, and the blu-ray ss is connected to the hdmi2 port on the TV. The only way I'm getting the ss speakers to work is by playing a dvd... They won't work otherwise, and I've tried every setting I could think of. Aux on the blu-ray ss seems logical, but it doesn't work. I've also switched the speakers setup on the TV to "external speakers", but it's just not working. What am I missing here?? Does the blu-ray ss need to be connected with component cables??

Thanks in advance!
post #2 of 8
Doesn't sound like you connected your tv to your htib/audio device. Use an optical cable from the audio out of the tv to your htib/audio device then select the appropriate input to hear the sound...look at page 25 of your BH6820sW manual.
post #3 of 8
Thread Starter 
Quote:
Originally Posted by lovinthehd View Post

Doesn't sound like you connected your tv to your htib/audio device. Use an optical cable from the audio out of the tv to your htib/audio device then select the appropriate input to hear the sound...look at page 25 of your BH6820sW manual.

Sorry! I forgot to mention that I tried that but it didn't work. I even went out of my way to order the optical cable on Amazon because I didn't have one. I know the cable is ok because I can see the red light coming through after connecting to the TV. I had it properly connected to the HTIB, but still no sound. I set the input to optical cable on the HTIB, and on the TV I set "external speakers"...still no sound. No clue what I'm doing wrong here. Should the HTIB be set to Aux??

I know the speakers from the HTIB all work - when playing a DVD they work fine.

Will the HTIB sound work across all applications even if the HDMI (video AND sound) is connected to the cable box?? How will the TV know to play sound only from the optical cable and not from the sound portion of HDMI? Can it play audio from both sources at the same time??? I'm a big time techie, and even to me this is confusing!
Edited by Siciliano - 11/16/12 at 5:31am
post #4 of 8
The correct way to hook all of your equipment up is as follows.

HDTV Cable Box into Surround receiver via HDMI Cable.
Surround receiver into TV via HDMI Cable

Hook all your equipment into the Surround receiver. If the devices have HDMI use it, if not use the next best option.

A receiver is really an Audio/Video receiver and switcher so it will play sound and pass the picture thru to the TV. By doing this you will get the best possible picture and sound.
post #5 of 8
Thread Starter 
Quote:
Originally Posted by flickhtguru View Post

The correct way to hook all of your equipment up is as follows.
HDTV Cable Box into Surround receiver via HDMI Cable.
Surround receiver into TV via HDMI Cable
Hook all your equipment into the Surround receiver. If the devices have HDMI use it, if not use the next best option.

A receiver is really an Audio/Video receiver and switcher so it will play sound and pass the picture thru to the TV. By doing this you will get the best possible picture and sound.

I would have hooked it up that way, but the surround receiver only has one HDMI out, and that is going to the TV currently...there is no HDMI in. The only input is optical in.

I'm really starting to think it can't be done. But why the hell would they sell a home theater in a box with wireless surround, a sub, and all these speakers if it only works when playing a DVD?!? That's just ridiculous and I'll return it in a heartbeat if that's the case. I wish Best Buy support wasn't so clueless...they say "It can be done, I'm just not sure how." Worthless. =(

I'm just not understanding why everything I play from the TV wouldn't come through the ss speakers if it's connected to the TV via optical cable...
post #6 of 8
^^^
Try moving the cable box to HDMI3 and leave HDMI1 empty. It could be that the TV is confused since HDMI1 is the ARC port and when you specify "external speakers" it's trying to send audio out that way instead of through the optical cable. I might be all wrong but it's worth a try. If that doesn't work, call LG support and see if they know what the issue is.

BTW I know my suggestion sounds silly, but I'd still try it if I was debugging this.
Edited by Possumgirl - 11/16/12 at 11:45am
post #7 of 8
If that doesn't work then run HDMI for video into your TV from the HDTV cable box and run a Fiber from HDTV box to receiver for sound.
post #8 of 8
Thread Starter 
Thanks everyone for your help. It was the @#$&in cable box! It was the only thing left I could think of. I had to reboot it, and it took forever. There might be something wrong with it, but at least it's working now, and I know what the issue is if this happens again. smile.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Audio theory, Setup and Chat
AVS › AVS Forum › Audio › Audio theory, Setup and Chat › Help with lg blu-ray surround sound system